Subject: [Raw] Proposed RAW charter

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Mon, 13 Jan 2020 21:14:44 +0000

Hi RAW,

Happy New Year!

As promised, here's a proposed charter. Please send comments. I'll be submitting it to the IESG for the first step (internal review) by the end of the week.

Note, while the BoF had the most support for doing only use cases and requirements, I've included here also a gap analysis and an architecture/framework document. I think the gap analysis will be the most critical. The architecture/framework is intended not to be the typical comprehensive protocol architecture, but only architectural aspects of what is needed to enable deployment and usage in a wireless network.

Looking forward to your comments-
Deborah
(your supporting AD)

--

Reliable and Available Wireless (RAW) provides for high reliability and availability for IP connectivity over a wireless medium. The wireless medium presents significant challenges to achieve deterministic properties such as low packet error rate, bounded consecutive losses, and bounded latency. RAW extends the DetNet Working Group concepts to provide for high reliability and availability for an IP network utilizing scheduled wireless segments and other media, e.g., frequency/time-sharing physical media resources with stochastic traffic: IEEE Std. 802.15.4 timeslotted channel hopping (TSCH), 3GPP 5G ultra-reliable low latency communications (URLLC), IEEE 802.11ax/be, and L-band Digital Aeronautical Communications System (LDACS). Similar to DetNet, RAW will stay abstract to the radio layers underneath, addressing the Layer 3 aspects in support of applications requiring high reliability and availability.

While DetNet solutions apply to both wireless and wired, there has been recent industry interest for wireless applications which were not initially included in the DetNet use cases. One critical application is Aeronautical Data Communications. The Aeronautical standards work on a physical layer and data link layer for data communications is reaching maturity and there is significant interest in developing an IP connectivity solution.

In the interests of providing timely solutions for these newly identified industry applications, RAW's focus will be on identifying use cases and requirements for these new applications. RAW will solicit input on deployment plans, requirements, and operational practices (including security and privacy aspects) for these newer industrial applications. RAW's primary focus is on identifying areas where the DetNet adaptation to wireless networks requires additional supporting mechanisms. The RAW Working Group will also examine the applicability of other existing IETF work, e.g., DLEP.  The RAW Working Group will provide input to the DetNet Working Group, MANET Working Group, and other IETF Working Groups, and cooperate in reviewing solutions to RAW's identified deployment problems. RAW is not chartered to work on a solution, if solution work is needed in addition to the DetNet solution work or other existing solution work in the IETF, it will be coordinated on where the work will be done.

The RAW Working Group is planned to be a short timeframe (12-18 months) Working Group to quickly address these newer industry applications. The initial milestones will be comprised of Informational documents. The documents may exist individually or on a git repository. The use case document may consist of one or more documents to allow users/operators the opportunity to provide comprehensive deployment plans for these new (to IETF) technologies. The group will closely coordinate with the DetNet and MANET Working Groups. The work produced by this group may be of interest to other SDOs, 3GPP, IEEE, and the Aeronautical industry. No formal co-ordination is anticipated with these groups at this time.
Milestones
Draft for "Use Cases" adopted by WG
Draft for "Problem Statement and Requirements" adopted by WG
Draft for "Architectural/Framework aspects to enable deployment and usage in a wireless network" adopted by WG
Draft for "Evaluation of Existing IETF Tools and Gap Analysis" adopted by WG
Draft for "Use Cases" submit for publication
Draft for "Problem Statement and Requirements" submit for publication
Draft for "Architectural/Framework aspects to enable deployment and usage in a wireless network" submit for publication
Draft for "Evaluation of Existing IETF Tools and Gap Analysis" submit for publication

---

From: Justin Dean <[email-masked]>
Date: Tue, 14 Jan 2020 09:47:13 -0700

Comments inline below.
Justin Dean

On Mon, Jan 13, 2020 at 2:14 PM BRUNGARD, DEBORAH A <[email-masked]> wrote:

> Hi RAW,
>
>
>
> Happy New Year!
>
>
>
> As promised, here’s a proposed charter. Please send comments. I’ll be
> submitting it to the IESG for the first step (internal review) by the end
> of the week.
>
>
>
> Note, while the BoF had the most support for doing only use cases and
> requirements, I’ve included here also a gap analysis and an
> architecture/framework document. I think the gap analysis will be the most
> critical. The architecture/framework is intended not to be the typical
> comprehensive protocol architecture, but only architectural aspects of what
> is needed to enable deployment and usage in a wireless network.
>
>
>
> Reliable and Available Wireless (RAW) provides for high reliability and
> availability for IP connectivity over a wireless medium.
>

This very first sentence seems off to me as later in the charter it's
mentioned that no solutions are going to be directly in scope so will the
work actually provide this or just outline the challenges and point towards
solutions in DetNet/Manet/other WGs?  If no solutions will be in scope then
I suggest leading with the next 1-2 sentences mixed with the first as way
of introduction to RAW.

> The wireless medium presents significant challenges to achieve
> deterministic properties such as low packet error rate, bounded consecutive
> losses, and bounded latency. RAW extends the DetNet Working Group concepts
> to provide for high reliability and availability for an IP network
> utilizing scheduled wireless segments and other media, e.g.,
> frequency/time-sharing physical media resources with stochastic traffic:
> IEEE Std. 802.15.4 timeslotted channel hopping (TSCH), 3GPP 5G
> ultra-reliable low latency communications (URLLC), IEEE 802.11ax/be, and
> L-band Digital Aeronautical Communications System (LDACS).
>
and etc. is needed here unless this his is exhaustive.

> Similar to DetNet, RAW will stay abstract to the radio layers underneath,
> addressing the Layer 3 aspects in support of applications requiring high
> reliability and availability.
>
>
>
> While DetNet solutions apply to both wireless and wired, there has been
> recent industry interest for wireless applications which were not initially
> included in the DetNet use cases. One critical application is Aeronautical
> Data Communications. The Aeronautical standards work on a physical layer
> and data link layer for data communications is reaching maturity and there
> is significant interest in developing an IP connectivity solution.
>
(using wireless links?)

>
>
> In the interests of providing timely solutions for these newly identified
> industry applications, RAW’s focus will be on identifying use cases and
> requirements for these new applications. RAW will solicit input on
> deployment plans, requirements, and operational practices (including
> security and privacy aspects) for these newer industrial applications.
> RAW’s primary focus is on identifying areas where the DetNet adaptation to
> wireless networks requires additional supporting mechanisms. The RAW
> Working Group will also examine the applicability of other existing IETF
> work, e.g.., DLEP.  The RAW Working Group will provide input to the DetNet
> Working Group, MANET Working Group, and other IETF Working Groups, and
> cooperate in reviewing solutions to RAW’s identified deployment problems.
> RAW is not chartered to work on a solution, if solution work is needed in
> addition to the DetNet solution work or other existing solution work in the
> IETF, it will be coordinated on where the work will be done.
>
In terms of presentation of information the critical bit of info that RAW
will NOT work on solutions seems a bit buried here and this should be moved
towards the top.

>
>
> The RAW Working Group is planned to be a short timeframe (12-18 months)
> Working Group to quickly address these newer industry applications. The
> initial milestones will be comprised of Informational documents. The
> documents may exist individually or on a git repository.
>
Unnecessary suggest cutting previous sentence.

> The use case document may consist of one or more documents to allow
> users/operators the opportunity to provide comprehensive deployment plans
> for these new (to IETF) technologies. The group will closely coordinate
> with the DetNet and MANET Working Groups. The work produced by this group
> may be of interest to other SDOs, 3GPP, IEEE, and the Aeronautical
> industry. No formal co-ordination is anticipated with these groups at this
> time.
>
"these groups" meaning "these non-IETF groups"?

> Milestones
>
> Draft for “Use Cases” adopted by WG
>
> Draft for “Problem Statement and Requirements” adopted by WG
>
> Draft for “Architectural/Framework aspects to enable deployment and usage
> in a wireless network” adopted by WG
>
> Draft for “Evaluation of Existing IETF Tools and Gap Analysis” adopted by
> WG
>
> Draft for “Use Cases” submit for publication
>
> Draft for “Problem Statement and Requirements” submit for publication
>
> Draft for “Architectural/Framework aspects to enable deployment and usage
> in a wireless network” submit for publication
>
> Draft for “Evaluation of Existing IETF Tools and Gap Analysis” submit for
> publication
>
>
>

> --
> Raw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw
>

---

From: <[email-masked]>
Date: Tue, 14 Jan 2020 17:10:47 +0000

<DL> In-line </DL>

From: Raw <[email-masked]> On Behalf Of Justin Dean
Sent: 14 January 2020 16:47
To: [email-masked]
Cc: BRUNGARD, DEBORAH A <[email-masked]>
Subject: Re: [Raw] Proposed RAW charter

[EXTERNAL EMAIL]
Comments inline below.
Justin Dean

On Mon, Jan 13, 2020 at 2:14 PM BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>> wrote:
Hi RAW,

Happy New Year!

As promised, here’s a proposed charter. Please send comments. I’ll be submitting it to the IESG for the first step (internal review) by the end of the week.

Note, while the BoF had the most support for doing only use cases and requirements, I’ve included here also a gap analysis and an architecture/framework document. I think the gap analysis will be the most critical. The architecture/framework is intended not to be the typical comprehensive protocol architecture, but only architectural aspects of what is needed to enable deployment and usage in a wireless network.

--

Reliable and Available Wireless (RAW) provides for high reliability and availability for IP connectivity over a wireless medium..

This very first sentence seems off to me as later in the charter it's mentioned that no solutions are going to be directly in scope so will the work actually provide this or just outline the challenges and point towards solutions in DetNet/Manet/other WGs?  If no solutions will be in scope then I suggest leading with the next 1-2 sentences mixed with the first as way of introduction to RAW.
The wireless medium presents significant challenges to achieve deterministic properties such as low packet error rate, bounded consecutive losses, and bounded latency. RAW extends the DetNet Working Group concepts to provide for high reliability and availability for an IP network utilizing scheduled wireless segments and other media, e.g., frequency/time-sharing physical media resources with stochastic traffic: IEEE Std. 802.15.4 timeslotted channel hopping (TSCH), 3GPP 5G ultra-reliable low latency communications (URLLC), IEEE 802.11ax/be, and L-band Digital Aeronautical Communications System (LDACS).
and etc. is needed here unless this his is exhaustive.

<DL> LDACS does not use IP.   A number of other systems where we need to create Reliable and Available Wireless paths do not use IP.   This limits the applicability of the technology.  Is it the PATH we wish to make Reliable and Available or the Protocol? </DL>
Similar to DetNet, RAW will stay abstract to the radio layers underneath, addressing the Layer 3 aspects in support of applications requiring high reliability and availability.

<DL> “significant interest” reads purely of conjecture to me.  If what we are trying to do is to make the link Reliable and Available, does the higher-level protocol actually matter? </DL>

In the interests of providing timely solutions for these newly identified industry applications, RAW’s focus will be on identifying use cases and requirements for these new applications. RAW will solicit input on deployment plans, requirements, and operational practices (including security and privacy aspects) for these newer industrial applications. RAW’s primary focus is on identifying areas where the DetNet adaptation to wireless networks requires additional supporting mechanisms. The RAW Working Group will also examine the applicability of other existing IETF work, e.g..., DLEP.  The RAW Working Group will provide input to the DetNet Working Group, MANET Working Group, and other IETF Working Groups, and cooperate in reviewing solutions to RAW’s identified deployment problems. RAW is not chartered to work on a solution, if solution work is needed in addition to the DetNet solution work or other existing solution work in the IETF, it will be coordinated on where the work will be done.
In terms of presentation of information the critical bit of info that RAW will NOT work on solutions seems a bit buried here and this should be moved towards the top.

The RAW Working Group is planned to be a short timeframe (12-18 months) Working Group to quickly address these newer industry applications. The initial milestones will be comprised of Informational documents. The documents may exist individually or on a git repository.
Unnecessary suggest cutting previous sentence.

The use case document may consist of one or more documents to allow users/operators the opportunity to provide comprehensive deployment plans for these new (to IETF) technologies. The group will closely coordinate with the DetNet and MANET Working Groups. The work produced by this group may be of interest to other SDOs, 3GPP, IEEE, and the Aeronautical industry. No formal co-ordination is anticipated with these groups at this time.
"these groups" meaning "these non-IETF groups"?

<DL> The general concern I have is in terms of abstracting the Layer 1 aspects from the delivery SLA.   The analogy I will draw where it works VERY well is VoLTE where the contract in terms of an IP QoS is explicitly tied to the air interface QCI and “reliability” is built by moving the voice call from a packet-switched to a circuit-switched connection if the air-interface breaks-down.   This means that the solution is anything BUT abstracted in terms of layers!

We do need to be aware that significant, non-predictable behaviour can occur on RF connections – for example, the massive tropospheric “lift” that occurred across much of Western Europe at the end of December which caused OTA TV and Radio to be severely impacted for a number of days https://www.cambridge-news.co.uk/news/cambridge-news/freeview-tv-signal-down-people-17486405

</DL>
Milestones
Draft for “Use Cases” adopted by WG
Draft for “Problem Statement and Requirements” adopted by WG
Draft for “Architectural/Framework aspects to enable deployment and usage in a wireless network” adopted by WG
Draft for “Evaluation of Existing IETF Tools and Gap Analysis” adopted by WG
Draft for “Use Cases” submit for publication
Draft for “Problem Statement and Requirements” submit for publication
Draft for “Architectural/Framework aspects to enable deployment and usage in a wireless network” submit for publication
Draft for “Evaluation of Existing IETF Tools and Gap Analysis” submit for publication

--
Raw mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 14 Jan 2020 14:25:36 -0300

All,
      For the time being, just a small comment:
I would like to define the charter about what it is going to be
made instead of what it is not (Solutions). I think it is nice to
see the right type of product we are looking for (are we looking
for Best Practices? Informational documents only? Define a
framework and/or an abstraction layer keeping relevant statistics
about the efficiency? are we looking for a model?)
Regards,

                     Diego Dujovne

Le mar. 14 janv. 2020 à 14:11, <[email-masked]> a écrit :

> <DL> In-line </DL>
>
>
>
> *From:* Raw <[email-masked]> *On Behalf Of *Justin Dean
> *Sent:* 14 January 2020 16:47
> *To:* [email-masked]
> *Cc:* BRUNGARD, DEBORAH A <[email-masked]>
> *Subject:* Re: [Raw] Proposed RAW charter
>
>
>
> [EXTERNAL EMAIL]
>
> Comments inline below.
> Justin Dean
>
>
>
> availability for IP connectivity over a wireless medium..
>
>
>
> <DL> LDACS does not use IP.   A number of other systems where we need to
> create Reliable and Available Wireless paths do not use IP.   This limits
> the applicability of the technology.  Is it the PATH we wish to make
> Reliable and Available or the Protocol? </DL>
>
> <DL> “significant interest” reads purely of conjecture to me.  If what we
> are trying to do is to make the link Reliable and Available, does the
> higher-level protocol actually matter? </DL>
>
>
>
> work, e.g..., DLEP.  The RAW Working Group will provide input to the DetNet
> <DL> The general concern I have is in terms of abstracting the Layer 1
> aspects from the delivery SLA.   The analogy I will draw where it works
> VERY well is VoLTE where the contract in terms of an IP QoS is explicitly
> tied to the air interface QCI and “reliability” is built by moving the
> voice call from a packet-switched to a circuit-switched connection if the
> air-interface breaks-down.   This means that the solution is anything BUT
> abstracted in terms of layers!
>
>
>
> We do need to be aware that significant, non-predictable behaviour can
> occur on RF connections – for example, the massive tropospheric “lift” that
> occurred across much of Western Europe at the end of December which caused
> OTA TV and Radio to be severely impacted for a number of days
> https://www.cambridge-news.co.uk/news/cambridge-news/freeview-tv-signal-down-people-17486405
>
>
>
> </DL>
>
> Milestones
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 14 Jan 2020 20:19:51 +0000

On several of the comments, the question seems to be “how can we define a reliable and available Layer 3 if the Layer 1-2 is not reliable”. That’s the work of this working group to determine. Maybe the answer will be “impossible”.

The other concern is the sensitivity on solution work. Until the working group does a gap analysis on the current solutions, we don’t know the answer. Maybe current solutions (or a combination) will be sufficient to provide a solution. First, though, we need to understand the use scenarios and what has not been addressed in on-going IETF work. RAW is not to boil the ocean – for the next 10 years. The BoF indicated there were several concrete use cases which have not been addressed by DetNET and are of immediate industrial need. RAW’s scope is to quickly identify the gaps in the current work so we can determine what work is needed.

Here’s some responses – below –

Thanks for the comments!
Deborah

From: [email-masked] <[email-masked]>
Sent: Tuesday, January 14, 2020 12:11 PM
To: [email-masked]; [email-masked]
Cc: BRUNGARD, DEBORAH A <[email-masked]>
Subject: RE: [Raw] Proposed RAW charter

<DL> In-line </DL>

From: Raw <[email-masked]<mailto:[email-masked]>> On Behalf Of Justin Dean
Sent: 14 January 2020 16:47
To: [email-masked]<mailto:[email-masked]>
Cc: BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Raw] Proposed RAW charter

[EXTERNAL EMAIL]
Comments inline below.
Justin Dean

Happy New Year!

--

This very first sentence seems off to me as later in the charter it's mentioned that no solutions are going to be directly in scope so will the work actually provide this or just outline the challenges and point towards solutions in DetNet/Manet/other WGs?  If no solutions will be in scope then I suggest leading with the next 1-2 sentences mixed with the first as way of introduction to RAW.
[deborah] I don’t read it the same way -this first sentence is simply defining the acronym for the group. Details of what the group will do are in later paragraphs.
The wireless medium presents significant challenges to achieve deterministic properties such as low packet error rate, bounded consecutive losses, and bounded latency. RAW extends the DetNet Working Group concepts to provide for high reliability and availability for an IP network utilizing scheduled wireless segments and other media, e.g., frequency/time-sharing physical media resources with stochastic traffic: IEEE Std. 802.15.4 timeslotted channel hopping (TSCH), 3GPP 5G ultra-reliable low latency communications (URLLC), IEEE 802.11ax/be, and L-band Digital Aeronautical Communications System (LDACS).
and etc. is needed here unless this his is exhaustive.
[deborah] Ok

<DL> LDACS does not use IP.   A number of other systems where we need to create Reliable and Available Wireless paths do not use IP.   This limits the applicability of the technology.  Is it the PATH we wish to make Reliable and Available or the Protocol? </DL>
[deborah] This is on the Layer 3 aspect – input was that there was interest in having IP connectivity (draft-maeurer-raw-ldacs).
Similar to DetNet, RAW will stay abstract to the radio layers underneath, addressing the Layer 3 aspects in support of applications requiring high reliability and availability.

While DetNet solutions apply to both wireless and wired, there has been recent industry interest for wireless applications which were not initially included in the DetNet use cases. One critical application is Aeronautical Data Communications. The Aeronautical standards work on a physical layer and data link layer for data communications is reaching maturity and there is significant interest in developing an IP connectivity solution.
(using wireless links?)
[deborah] Refer to the draft mentioned above.

<DL> “significant interest” reads purely of conjecture to me.  If what we are trying to do is to make the link Reliable and Available, does the higher-level protocol actually matter? </DL>
[deborah] Refer above – IETF doesn’t do Layer 1 and Layer 2 for these technologies, the scope is Layer 3.

In the interests of providing timely solutions for these newly identified industry applications, RAW’s focus will be on identifying use cases and requirements for these new applications. RAW will solicit input on deployment plans, requirements, and operational practices (including security and privacy aspects) for these newer industrial applications. RAW’s primary focus is on identifying areas where the DetNet adaptation to wireless networks requires additional supporting mechanisms. The RAW Working Group will also examine the applicability of other existing IETF work, e.g..., DLEP.  The RAW Working Group will provide input to the DetNet Working Group, MANET Working Group, and other IETF Working Groups, and cooperate in reviewing solutions to RAW’s identified deployment problems. RAW is not chartered to work on a solution, if solution work is needed in addition to the DetNet solution work or other existing solution work in the IETF, it will be coordinated on where the work will be done.
In terms of presentation of information the critical bit of info that RAW will NOT work on solutions seems a bit buried here and this should be moved towards the top.
[deborah] The flow is consistent with other charters – first define the acronym “RAW”, explain interest for a working group, and then define scope of work.

The RAW Working Group is planned to be a short timeframe (12-18 months) Working Group to quickly address these newer industry applications. The initial milestones will be comprised of Informational documents. The documents may exist individually or on a git repository.
Unnecessary suggest cutting previous sentence.
[deborah] This is to clarify the documents may not be necessarily published. The same sentence is in DetNet and other recent charters.

The use case document may consist of one or more documents to allow users/operators the opportunity to provide comprehensive deployment plans for these new (to IETF) technologies. The group will closely coordinate with the DetNet and MANET Working Groups. The work produced by this group may be of interest to other SDOs, 3GPP, IEEE, and the Aeronautical industry. No formal co-ordination is anticipated with these groups at this time.
"these groups" meaning "these non-IETF groups"?
[deborah] Yes, non-IETF groups. This same sentence is in many charters, no confusion.

We do need to be aware that significant, non-predictable behaviour can occur on RF connections – for example, the massive tropospheric “lift” that occurred across much of Western Europe at the end of December which caused OTA TV and Radio to be severely impacted for a number of days https://www.cambridge-news.co.uk/news/cambridge-news/freeview-tv-signal-down-people-17486405<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.cambridge-2Dnews.co.uk_news_cambridge-2Dnews_freeview-2Dtv-2Dsignal-2Ddown-2Dpeople-2D17486405&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tFrX-BRw_HItZY_ICnKovjX01CwQz8sNQZTxo5cyJrA&s=5uC_TEdKP2f4KVGGB9_j2DtWjoG6lNBkTSM2fjcrXoo&e=>

</DL>
[deborah] Refer to above – IETF is scoped to Layer 3 for these technologies. The same sentence is in DetNet. Any solution work on Layer 1-2 needs to be done in the appropriate SDO.
Milestones

--
Raw mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tFrX-BRw_HItZY_ICnKovjX01CwQz8sNQZTxo5cyJrA&s=anuzkCW7UDrRz2IBGv4yx63Uv0nLOm5JdPATW5A-fmw&e=>

---

From: <[email-masked]>
Date: Thu, 16 Jan 2020 07:28:01 +0000

Maybe I can clarify this a little below.
Thomas

LDACS is indeed a layer 2 wireless technology, so it technically does not use IP over the wireless link for its own purposes (although it may use IP in the backhaul control plane connecting the ground stations). However, the point of developing LDACS is to have an aeronautical data link supporting (user plane) IPv6. Something that does not exist for air traffic control up to now. (Passenger entertainment networks are different, but not in the scope of LDACS).

This is also where RAW would help the aeronautical community. Discussing how IPv6 can be used reliably and available of wireless link(s) (which are LDACS and maybe satellite in our case, but might be other links for other use cases).

——————————————————————————
Deutsches Zentrum für Luft- und Raumfahrt e.V. (DLR)
German Aerospace Center
Institute of Communications and Navigation | Oberpfaffenhofen | 82234 Wessling | Germany

Dr. Thomas Gräupl
Telephone +49 8153 28 4218 | [email-masked]<mailto:[email-masked]>
www.DLR.de<http://www.dlr.de/>

---

From: <[email-masked]>
Date: Thu, 16 Jan 2020 08:31:21 +0000

Understood and thank you for the clarification.

My comment was more general – are we limiting RAW to providing Reliable and Available IP Wireless services or are we looking at providing Reliable and Available Wireless whether the protocol is IP or something else.

I have a general concern that when it comes to small-payload IOT services, often an IP header over the air interface is very wasteful in terms of spectrum (ratio of header:payload).   This does not preclude the backhaul being IP but we already have a plethora of non-IP OTA solutions which could also benefit from work in RAW.

David

From: [email-masked] <[email-masked]>
Sent: 16 January 2020 07:28
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: AW: [Raw] Proposed RAW charter

[EXTERNAL EMAIL]

Dr. Thomas Gräupl

---

From: <[email-masked]>
Date: Thu, 16 Jan 2020 08:54:55 +0000

[TG] My understanding was “Reliable and Available IP Wireless services”. At least, this would be the work most appreciated by the aviation community.

[TG] I agree. The aeronautical use case is, however, more related to having two (or more) possibly different wireless links and to use them to provide more reliable and available IPv6 based data transfer than it would be possible using just one link.

The desire to have an IP based solution comes mainly from the fact that there is already a plethora of proprietary or legacy solutions in place that have become difficult to manage over time.

The ratio header/payload is certainly a concern, although the situation is not as bad as in the IOT case. Aeronautical links like LDACS provide in the order of 500 kbit/s up to a few Mbit/s. Satellite links for air traffic guidance are similar.

Thomas

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 16 Jan 2020 10:48:10 +0000

When frame use becomes a concern, we have approaches at the IETF to enable compression of IPv6. This is done at 6lo and LPWAN depending on how constrained the link is.

We could certainly push a deft on LDACS at 6lo. This is orthogonal to RAW. RAW is concerned by forwarding decisions based on the immediate state of the link not by the way IP is encoded in the packet.

Regards,

Pascal

Le 16 janv. 2020 à 09:55, "[email-masked]" <[email-masked]> a écrit :

Thomas