Subject: [Raw] Some comments on draft-pthubert-raw-architecture-05

From: Lou Berger <[email-masked]>
Date: Sun, 7 Mar 2021 17:56:56 -0500

Hi Pascal/Authors,

I have a some comments on the current draft - I mentioned these at the 
last WG session but have been remiss in sending them to the list, my 
apologies!

I really have two top level comments (detailed comments can wait until 
these are sorted):

1) The document could use some further alignment with the WG 
charter/direction.  We talked last year [1] about the document having 
some pre-WG text and it would be aligned with WG scope/charter,  I think 
it has improved, but still as work to go.

An example of this is the Abstract.  That's pretty easy to fix, e.g., 
the following, which is taken from the Charter, could be added ad as the 
abstract and the first paragraph of the Intro section:

     Reliable and Available Wireless (RAW) provides for high
     reliability and availability for IP connectivity over a
     wireless medium. The wireless medium presents significant
     challenges to achieve deterministic properties such as low
     packet error rate, bounded consecutive losses, and bounded
     latency. This document defines the RAW Architecture.  It
     builds on the DetNet Architecture and discusses specific
     challenges and technology considerations needed to deliver
     DetNet service utilizing scheduled wireless segments and
     other media, e.g., frequency/time-sharing physical media
     resources with stochastic traffic.

But really this comment should be applied generally.

2) A somewhat related comment is that as an architecture document, the 
document cover the full scope of the RAW problem space and leave room 
for all types of wireless networks and integration/optimization 
approaches.  For example, as I understand it, RAW's scope covers 
technologies where the IETF has zero control over the technology and can 
only operate across a  'user' network interface, e.g., one standardized 
by the IEEE, as well as technologies where the IETF has significant 
freedom to define a customized and an IP-integrated control solution, 
e.g., 6TiSCH.

As I read it, parts of the document are very focused on the latter, 
i.e., certain types of wireless networks and a specific integrated 
optimization approach, without allowing for the former.  To me it seems 
you really have two (valid) documents in one here.  The first is a 
foundation for the RAW architecture document, the second is the basis 
for a framework document for RAW networks whose radio layer and the IP 
layer control/management is fully integrated.  If you split this work 
into two documents, I think we can have the Architectural foundation for 
multiple solutions frameworks, where your integrated framework is one 
and another can be based on the cooperative layered architecture like 
the one I mentioned in [1] (e.g., as discussed RFC5623, RFC7926 or many 
other teas documents, and could leverage DLEP).

What do you think? If you agree to the split, I'm happy to help with the 
architecture document, although I also don't want to be the one to hold 
up progress.

Thank you!

Lou

[1] https://mailarchive.ietf.org/arch/msg/raw/TYq4ZL3RZXRkUedOVCdivNGYKOs/

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 8 Mar 2021 10:55:37 +0000

Hello Lou:

Many thanks for the timely mail. I hope you can attend RAW today:
 
> I have a some comments on the current draft - I mentioned these at the last
> WG session but have been remiss in sending them to the list, my apologies!
> 
> I really have two top level comments (detailed comments can wait until these
> are sorted):
> 

> charter/direction.  We talked last year [1] about the document having some
> pre-WG text and it would be aligned with WG scope/charter,  I think it has
> improved, but still as work to go.
> 
> An example of this is the Abstract.  That's pretty easy to fix, e.g., the
> following, which is taken from the Charter, could be added ad as the abstract
> and the first paragraph of the Intro section:
> 

I made this the abstract

> But really this comment should be applied generally.

Well, we'll have to be specific. Let's work together on this. The charter was updated by IESG from what we proposed at the BoF but I did not get a sense that the fundamentals had changed. 
Certainly if there is  a contradiction we need to fix it. 

> document cover the full scope of the RAW problem space and leave room for
> all types of wireless networks and integration/optimization approaches.  For
> example, as I understand it, RAW's scope covers technologies where the IETF
> has zero control over the technology and can only operate across a  'user'
> network interface, e.g., one standardized by the IEEE, as well as technologies
> where the IETF has significant freedom to define a customized and an IP-
> integrated control solution, e.g., 6TiSCH.
> 

Yes

> As I read it, parts of the document are very focused on the latter, i.e., certain
> types of wireless networks and a specific integrated optimization approach,
> without allowing for the former.  

That was not the intention. The former is the main application for now. The intention is an over the (L2) top operation that brings dynamics / per packet control to the DetNet Service Layer to enable a better use of the radio diversity.

> To me it seems you really have two (valid)
> documents in one here.  The first is a foundation for the RAW architecture
> document, the second is the basis for a framework document for RAW
> networks whose radio layer and the IP layer control/management is fully
> integrated.  If you split this work into two documents, I think we can have the
> Architectural foundation for multiple solutions frameworks, where your
> integrated framework is one and another can be based on the cooperative
> layered architecture like the one I mentioned in [1] (e.g., as discussed
> RFC5623, RFC7926 or many other teas documents, and could leverage DLEP).

Looks like a great idea, need chair/AD approval since the charter reads "Architecture/Framework Aspects for a Wireless Network" as a single entity.
And yes, the intention is certainly to leverage DLEP.

> architecture document, although I also don't want to be the one to hold up
> progress.

For now I published a quick refresher that does not do the split yet -we'll discuss it today - and adds you as co-author, so you can contribute whether we split or not.
Also: you have a pending invite on the github repo https://github.com/raw-wg/raw-architecture/invitations, please let me know if it does not work for you.

Keep safe, Lou.

Pascal

> 
> Thank you!
> 
> Lou
> 
> [1]
> https://mailarchive.ietf.org/arch/msg/raw/TYq4ZL3RZXRkUedOVCdivNGYKOs
> /
> 
> 
> --
> RAW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw

---

From: Lou Berger <[email-masked]>
Date: Mon, 8 Mar 2021 11:49:20 +0000

Hi  Pascal,

Thank you for the message. it sounds like we are aligned in principle now we just have to work out the details :-)

I'm not so concerned about splitting documents. I think the important thing is getting the text written and then letting the chairs run the wg process.  If we decide to split these individual documents they can always ask us to merge them as, foreign preparation for bring, a working group docs.

With respect to being a co-author, thank you for the offer. If I contribute sufficiently I will be glad to join, and I do hope to contribute time permitting.

See you soon. (Although I do plan on being in two different wgs in the first session - which is easier when we're virtual...)

Lou

----------

>> integrated control solution, e.g., 6TiSCH.

Thanks!