Subject: Re: [Raw] I-D Action: draft-ietf-raw-ldacs-07.txt

From: Waqar Zia <[email-masked]>
Date: Wed, 24 Mar 2021 08:07:26 +0000

Dear authors, all,

What I am struggling to understand from the draft is: where exactly are all the other details (e.g., physical level, link level) specified? Is it the reference "ICAO SARPs Annex 10 Vol. III from 2018"? I think less likely since ICAO to my understanding does not specify physical layer aspects? Are there publicly accessible specs? There is a brief section on Physical layer etc. in the draft but it should cite this reference. Without those, I am struggling to understand the whole picture; any help in this regard would be greatly appreciated!

Thanks,
Waqar.

Dr. Waqar Zia
Qualcomm CDMA Technologies
O: +49 89 614 694 0031
------------------------------------------------------------------------
Qualcomm CDMA Technologies GmbH
Anzinger Str. 13, 81671 Muenchen
Amtsgericht München, HRB 133031
Geschäftsführer: Daniel Philip Welch

This message may contain information which is confidential or privileged.
If you are not the intended recipient, please advise the sender immediately by reply e-mail and delete this message and any attachments without retaining a copy. Thank you.

Qualcomm CDMA Technologies GmbH has taken every reasonable precautions to ensure that any attachments to this e-mail has been swept for viruses.
However, we cannot accept liability for any damage sustained as a result of software viruses and would advise that you carry out your own virus checks before opening any attachment.

> -----Original Message-----
> From: RAW <[email-masked]> On Behalf Of [email-masked]
> Sent: 17 February 2021 15:44
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Raw] I-D Action: draft-ietf-raw-ldacs-07.txt
>
> -------------------------------------------------------------------------
> CAUTION: This email originated from outside of the organization.
> -------------------------------------------------------------------------
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Reliable and Available Wireless WG of the IETF.
>
>         Title           : L-band Digital Aeronautical Communications System (LDACS)
>         Authors         : Nils Maeurer
>                           Thomas Graeupl
>                           Corinna Schmitt
> Filename        : draft-ietf-raw-ldacs-07.txt
> Pages           : 37
> Date            : 2021-02-17
>
> Abstract:
>    This document provides an overview of the architecture of the L-band
>    Digital Aeronautical Communications System (LDACS), which provides a
>    secure, scalable and spectrum efficient terrestrial data link for
>    civil aviation.  LDACS is a scheduled, reliable multi-application
>    cellular broadband system with support for IPv6.  LDACS SHALL provide
>    a data link for IP network-based aircraft guidance.  High reliability
>    and availability for IP connectivity over LDACS are therefore
>    essential.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-raw-ldacs/
>
> There is also an HTML version available at:
> https://www.ietf.org/archive/id/draft-ietf-raw-ldacs-07.html
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-raw-ldacs-07
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
> --
> RAW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw

---

From: <[email-masked]>
Date: Wed, 24 Mar 2021 15:13:30 +0000

Hi Waqar,

Thanks for reaching out.
The current LDACS specification is written within the framework of the Single European Sky ATM Research (SESAR) project.
You can find more about that on the official LDACS website https://www.ldacs.com/, which also hosts the current version of the LDACS specification
(https://www.ldacs.com/wp-content/uploads/2013/12/SESAR2020_PJ14_D3_3_030_LDACS_AG_Specification_00_02_02-1_0.pdf).
We have integrated that source in v07 of our document as
[GRA2019]  Graeupl, T., Rihacek, C., and B. Haindl, "LDACS A/G
              Specification", SESAR2020 PJ14-02-01 D3.3.030 , 2019.
However, we will make sure to point to that source and web-address more clearly In the upcoming update of our working document.

Best,
Nils Mäurer

------------------------
Deutsches Zentrum für Luft- und Raumfahrt e.V. (DLR)
German Aerospace Center
Institut für Kommunikation und Navigation | Nachrichtensysteme | Oberpfaffenhofen | 82234 Wessling | Deutschland
 
Nils Mäurer, M. Sc. | Cybersecurity für Aeronautische Kommunikation
Telefon +49 8153 28-2484
[email-masked] 
https://www.nils-maeurer.de 

-----Ursprüngliche Nachricht-----
Von: Waqar Zia <[email-masked]> 
Gesendet: Mittwoch, 24. März 2021 09:07
An: [email-masked]; Mäurer, Nils <[email-masked]>
Betreff: RE: [Raw] I-D Action: draft-ietf-raw-ldacs-07.txt

Dear authors, all,

Thanks,
Waqar.

Dr. Waqar Zia

---

From: <[email-masked]>
Date: Thu, 25 Mar 2021 07:24:46 +0000

Waqar,
I am the current editor of the LDACS A/G specification. Please consider the specification a living document that is further developed. The current plan is to use the SESAR Specification document as input for an official ICAO standard to published towards the end of 2022. 

Since the specification is a work in progress it may contain errors or omissions. If you have comments, they are obviously welcome. Much of the specification has already been validated in flight trials and the lab. Unfortunately these publications are not yet public. We are working on this.

As Nils already mentioned, you can get the current specification at https://www.ldacs.com/publications-and-links/#post-Specifications . I have just updated it to reflect some recent changes.

Thomas

--------------------------
Deutsches Zentrum für Luft- und Raumfahrt e.V. (DLR)
German Aerospace Center
Institute of Communications and Navigation | Oberpfaffenhofen | 82234 Wessling | Germany
 
Dr. Thomas Gräupl
Telephone +49 8153 28 4218 | [email-masked]
www.DLR.de

-----Ursprüngliche Nachricht-----
Von: RAW <[email-masked]> Im Auftrag von [email-masked]
Gesendet: Mittwoch, 24. März 2021 16:14
An: [email-masked]; [email-masked]
Betreff: Re: [Raw] I-D Action: draft-ietf-raw-ldacs-07.txt

Hi Waqar,

Thanks for reaching out.
The current LDACS specification is written within the framework of the Single European Sky ATM Research (SESAR) project.
You can find more about that on the official LDACS website https://www.ldacs.com/, which also hosts the current version of the LDACS specification (https://www.ldacs.com/wp-content/uploads/2013/12/SESAR2020_PJ14_D3_3_030_LDACS_AG_Specification_00_02_02-1_0.pdf).
We have integrated that source in v07 of our document as [GRA2019]  Graeupl, T., Rihacek, C., and B. Haindl, "LDACS A/G
              Specification", SESAR2020 PJ14-02-01 D3.3.030 , 2019.
However, we will make sure to point to that source and web-address more clearly In the upcoming update of our working document.

Best,
Nils Mäurer

------------------------
Deutsches Zentrum für Luft- und Raumfahrt e.V. (DLR) German Aerospace Center Institut für Kommunikation und Navigation | Nachrichtensysteme | Oberpfaffenhofen | 82234 Wessling | Deutschland
 
Nils Mäurer, M. Sc. | Cybersecurity für Aeronautische Kommunikation Telefon +49 8153 28-2484 [email-masked] https://www.nils-maeurer.de 

-----Ursprüngliche Nachricht-----
Von: Waqar Zia <[email-masked]> 
Gesendet: Mittwoch, 24. März 2021 09:07
An: [email-masked]; Mäurer, Nils <[email-masked]>
Betreff: RE: [Raw] I-D Action: draft-ietf-raw-ldacs-07.txt

Dear authors, all,

Thanks,
Waqar.

Dr. Waqar Zia