Subject: RE: Optional CRCs ( was [rddp] Marker Interval )

From: [email-masked]
Date: Tue, 25 Feb 2003 09:25:52 -0500

> Isn't SCTP CRC protection required per chunk?

Actually, it's per packet (in the SCTP common header), as Caitlin has
pointed out.  SCTP did not have a checksum that needed to be preserved,
in contrast to TCP.  The IPS WG considered the TCP alternate checksum
mechanism in RFC 1146 as a means of using a CRC to replace the TCP
checksum, but that mechanism is undeployable in practice due to what
it breaks, even though it would have been a cleaner solution in principle.

> The reason to have a CRC for 
> MPA is to provide data integrity below DDP/RDMA  / ULP which has been 
> demonstrated as a concern during the development of iSCSI.  Do we really 
> need to go back through the entire IPS debate as to why CRCs are good 
> things here or accept that a CRC at or above the transport but below 
> DDP/RDMA  / ULP is a good thing?

We don't need to go back through that debate, because the question
isn't about "good to implement" - it's about "mandatory to use", which
is a very different issue.  CRCs are optional for iSCSI, and NFS (another
important client for RDDP) has never needed CRCs, as the TCP checksum
has been adequate for its purposes (yes, a CRC would be an improvement).

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Tue, 25 Feb 2003 10:04:37 -0600

On 2/25/03, [email-masked] wrote:

>We don't need to go back through that debate, because the
>question isn't about "good to implement" - it's about
>"mandatory to use", which is a very different issue.  CRCs
>are optional for iSCSI, and NFS (another important client
>for RDDP) has never needed CRCs, as the TCP checksum has
>been adequate for its purposes (yes, a CRC would be an
>improvement).

Purely subjective observation here, but it struck me that
the strongest champions of RDDP having at *least* a 32 bit
CRC were those with heavy NFS experience.

Perhaps the feeling is that whether or not NFS *required* a
CRC, it truly always needed it.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp