Subject: [rddp] FW: I-D ACTION:draft-williams-iwarp-ift-01.txt

From: [email-masked]
Date: Wed, 19 Feb 2003 21:11:13 -0500

FYI, although this contains an initial adaption exchange mechanism,
I did not put Jim up to including one.

Thanks, --David

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, February 19, 2003 10:05 AM
Subject: I-D ACTION:draft-williams-iwarp-ift-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: iWARP Framing for TCP
	Author(s)	: J. Williams
	Filename	: draft-williams-iwarp-ift-01.txt
	Pages		: 10
	Date		: 2003-2-18
	
A framing protocol is defined for DDP over TCP that is fully
compliant with applicable TCP RFCs and fully interoperable with
existing TCP implementations.  This protocol is being offered as
an alternative to to the proposal offered in [MPA].
The protocol offers to two things, definition of the DDP record
boundaries within the TCP stream, and added data integrity 
by means of added CRC protection.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-williams-iwarp-ift-01.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-williams-iwarp-ift-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-williams-iwarp-ift-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

Date: Wed, 19 Feb 2003 21:13:31 -0500

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 20 Feb 2003 21:19:29 -0600

>   8.2  Overwrite checks
>
> Before speculative placement is done, the RDDP
> implementation MUST insure that no previously placed data
> is overwritten.  This is necessary to insure that if the
> speculative placement is being done in error, that the
> error is recoverable.
>
> This implies that the RDDP implementation must track what
> portions of a buffer have been written at any time, or if
> the RDDP implementation loses track, then do no further
> speculative placements in that buffer.
>
> If an in-order placement would overwrite a previously
> done speculative placement, then that in-order placement
> should be done and the preceding speculative placement
> regarded as invalid, and needs to be re-done in-order.

What is the definition of "previously"?

Since the ULP last enabled the use of that memory?

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 20 Feb 2003 21:48:17 -0600

I still prefer the original MPA draft, but the explanations
on early placement in Section 8 are excellent. I'd encourage
portions to be incorporated into the MPA draft even if no
other IFT features are adopted.

I have one question. If periodic markers are in use, can
they be viewed as a reliable indication of the location of
the RDDP PDU (combined with the other fields beig valid)?

Caitlin Bestler