Subject: Re: [rddp] Reality Check: Avoiding confusion on MPA TCP use

From: "Talpey, Thomas" <[email-masked]>
Date: Fri, 21 Feb 2003 08:16:22 -0500

At 12:48 PM 2/19/2003, [email-masked] wrote:
>   The third model is by negotiation of MPA transition by the ULP
>   using octet stream messages to accomplish a ULP specific
>   <MPA Hello>, <MPA Hello ACK>, <MPA ACK> three way exchange.
>...
>In addition, this sort of exchange would also provide a means of
>making the current 512-byte fixed marker interval variable, which
>is probably going to be needed to seriously deal with unmodified
>TCP stacks (e.g., are 16 syscalls or other send events/descriptors
>really reasonable to send an 8k DDP data block?).

I've been resisting the urge to complete the proposal I made
on "tunable marker intervals", but I do want to inject something
here.

It's not necessary to exchange a 3-way hello handshake to
provide for maker tuning. Because the markers in each
direction are independent, and are processed only by the
receiver, it is trivially easy to simply exchange them without
any negotiation or acknowledgement.

In a nutshell, each peer would initiate its MPA level exchange
with a marker containing the interval required by its receiver.
If 0, no markers are to be inserted. Sends can proceed in either
direction immediately upon receipt of the initial marker.

I believe the upper layer which invoked MPA is responsible for
ensuring its recognition by the peer, and not its designers having
to engage in exploration whether the pattern of all-0's, all-1's or
the ascii string "MPA!" is adequate protection.

Tom. 

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 21 Feb 2003 09:27:18 -0600

On 2/21/03, Talpey, Thomas wrote:

>I've been resisting the urge to complete the proposal I
>made on "tunable marker intervals", but I do want to
>inject something here.
>
>receiver, it is trivially easy to simply exchange them
>without any negotiation or acknowledgement.
>
>In a nutshell, each peer would initiate its MPA level
>exchange with a marker containing the interval required by
>its receiver. If 0, no markers are to be inserted. Sends
>can proceed in either direction immediately upon receipt
>of the initial marker.
>
>I believe the upper layer which invoked MPA is responsible
>for ensuring its recognition by the peer, and not its
>designers having to engage in exploration whether the
>pattern of all-0's, all-1's or the ascii string "MPA!" is
>adequate protection.
>

I'd go even farther.

The marker interval, like all other protocol details, is a
shared assumption. The ULP peers have an amazing wide
variety of ways to establish that shared assumption: a
pre-MPA mode handshake, system configuration, shared header
files and/or protocol specifications.

If this assumption was in error, it will quickly be
determined whether or not there is "confirmation" message.
And there are already sufficient safeguards to guarantee
that only the ULP in question (who is a party to the faulty
assumption) is at risk.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp