Subject: [rddp] IFT-01 - SP (Speculative Placement) Flag

From: "Williams, Jim" <[email-masked]>
Date: Mon, 24 Feb 2003 10:46:29 -0500

> It does not add value from what you have described here.
> 
> Mike

Let me try to frame this discussion a bit.

The goal of speculative placement is to achieve the following.

    Allow the receiver to do direct placement without markers
    or guaranteed alignment.  This is done not by absolutely
    insuring that the receiver can identify DDP headers, but
    rather by allowing the receiver to get it right almost
    all the time, but providing a mechanism to "fix up" any
    damage done by getting it wrong on rare occasions.  The
    "fix up" would be transparent to the ULP.

    The objective of the above is to allow the benefits of
    direct placement even when the sender is an unmodified
    TCP stack, and without requiring such a stack to incur 
    the overhead of inserting markers.

    Clean and performant interoperability with existing TCP
    implementations is an area where the MPA proposal is
    clearly deficient.  SP is an effort to explore 
    solutions to this.

Having said that, I believe the proposal for speculative 
placement outlined in the draft comes up short in some ways.
So I don't want to defend it as _THE_ solution the problem.
I did feel it was worth putting on the table for discussion,
though.

But this discussion may be uninteresting to those the
feel performant interoperability with existing TCP is
not a goal.
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Mon, 24 Feb 2003 10:16:53 -0600

>feel performant interoperability with existing TCP is

Let me take a stab at this.

Speculative Placement is a method that allows DDP Segments
to be found within out-of-order TCP segments without
requiring the use of markers.

Many practices can make the probability of finding the DDP
Segment quickly very high: aligning at the transmit side,
and long stretches where the DDP segments are all the
maximum size.

However, none of these methods are perfect. Therefore if
this technique is to be used, it is vital that any
previously delivered payload be protected from accidental
overwrite.

Speculative placement should only be used when ALL exposed
buffers have had NO deliveries since they were enabled.
(i.e., the ULP is invalidating the STag with *each*
untagged message).

Is my analysis of the applicability/intent correct?

Any form of variable marker interval can lead to situations
where speculative placement is a valuable MAY to be included
in the draft.

There is still a substantial question in my mind as to
whether the value of variable marker interval justifies
their complexity.

I believe everyone agrees that markers are ugly. But there
seems to be varying opinion on whether they are an
impediment to software implemntations and/or implemntations
that attempt to optimize conventional TCP streams at the
same time.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp