Subject: RE: [rddp] Optimized Processing not necessarily Hardware Optimize d

From: "Larsen, Roy K" <[email-masked]>
Date: Fri, 11 Apr 2003 11:02:02 -0700

> At the speeds we are envisioning supporting, payload
> validity checking is not a specialized requirement of
> storage applications being imposed upon everyone else.
> The question is more whether the handful of appliations that
> do not need it should be able to impose it being variable.
>
> I believe the impact on the applications that can live
> with data loss is very slight, in addition to those
> applications representing a small portion of total
> network usage.

Pardon my naiveté, but should I conclude from this CRC thread that it is
generally accepted within the IETF community that TCP is no longer
considered a reliable protocol and it (as well as all applications that
depend on its reliability) will become increasingly irrelevant as network
speeds increase?  If so, why would we want to spend any time integrating
RDMA with an obsolete protocol?  If the tsvwg wants to keep TCP relevant,
shouldn't they be the group addressing data integrity?

Roy
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 11 Apr 2003 15:49:06 -0500

On 4/11/03, Larsen, Roy K wrote:

>Pardon my naiveté, but should I conclude from this CRC
>thread that it is generally accepted within the IETF
>community that TCP is no longer considered a reliable
>protocol and it (as well as all applications that depend
>on its reliability) will become increasingly irrelevant as
>network speeds increase?  If so, why would we want to
>spend any time integrating RDMA with an obsolete protocol?
> If the tsvwg wants to keep TCP relevant, shouldn't they
>be the group addressing data integrity?

That solution would be called SCTP, which has a CRC-32c.

I see no need to define "TCP-2" when it would merely
be a single-streamed single-homed subset of SCTP.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp