Subject: [rddp] STag invalidation

From: [email-masked]
Date: Sun, 13 Apr 2003 15:53:20 -0400

WG Chair hat off:

> Without header checking *any* address that is open to *any*
> STag valid within the Protection Domain is targettable by an
> incorrect (and unchecked) DDP header. To be safe,
> applications would have to very actively invalidate STags
> after every received message.

An application that cares about data integrity and does not fully
trust its senders (there are lots of examples, as this is likely to
be the case for anything other than a tightly integrated cluster)
is likely to want to invalidate the STag after each received message
in order to avoid attacks based on a remote overwrite
after some application validity check has been made on the received
data.  See Section 4.1 of the DDP and RDMA Concerns draft.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Sun, 13 Apr 2003 16:54:57 -0500

> data.  See Section 4.1 of the DDP and RDMA Concerns draft.

If you don't trust a client, it is really only necessary to protect work done
for other clients from meddling. If an untrusted client wants to sabotage
work done on their behalf, well let them.

Creating a Protection Domain for each client is more than enough to ensure
that clients cannot interfere with other clients (and standard application layer
security).

The original point is that without header protection, an error within a
session can invalidate work done for that session -- unless almost
draconian measures of STag invalidation are undertaken. That would
*include* having no more than one operation pending at a time.

 -- 
Caitlin Bestler <[email-masked]>
Ï`òœÐÏ`òœÐÏ`T  q@Ä. ýò\@`ƒ`p\{h¡¿ò(Ä@H¤ýòœÐÄ
ïzKïO0xÄ   gggRp
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp