Subject: [rddp] Fw: IPS: Adaptec IPR Notice

From: "Julian Satran" <[email-masked]>
Date: Fri, 18 Apr 2003 10:36:40 +0300

David Black, senior technologist at EMC Corp. (NYSE: EMC - message board) 
who co-chairs the IETF IP Storage working group, says the Adaptec claims 
appear to not be applicable to all implementations.
He says they "may be applicable to people who are building seriously 
hot-rodded hardware." He adds that Adaptec's patent application could also 
potentially affect implementations of standards being developed by the 
IETF's Remote Direct Data Placement (RDDP) working group. RDDP refers to 
the ability to place data directly from a network adapter into application 
buffers, without intensive CPU usage.

Considering the attached you may want to look at the details of our 
earlier presenation and judge what (if any) patent apply.
The technique we presented is to be considered public domain knowledge,

Julo
----- Forwarded by Julian Satran/Haifa/IBM on 18/04/03 10:23 -----

Julian Satran/Haifa/IBM
18/04/03 09:39

To
"Sperry, Todd" <[email-masked]>
cc
Dafna Sheinwald, Ilan Shimony/Haifa/IBM@IBMIL, HRL IP 
Department/Haifa/IBM@IBMIL
Subject
Re: IPS:  Adaptec IPR Notice

For what it is worth - a team from IBM has documented such a technique in 
an open presentation to the RDMA consortium (publisdhed also on the forum) 
several months ago and a paper was forwarded to a conference and a 
journal. This is publicly available knowledge.  IBM has made not patent 
claims on it and I will make it soon available on my site.

The presentation to the RDMA forum is still a working paper of the 
consortium. The extend to which the two techniques are similar or not is 
for you to judge.

Julo

"Sperry, Todd" <[email-masked]> 
Sent by: [email-masked]
17/04/03 20:30

To
[email-masked]
cc
"'Elizabeth G. Rodriguez'" <[email-masked]>, 
"[email-masked]'" <[email-masked]>, "Sperry, Todd" 
<[email-masked]>
Subject
IPS:  Adaptec IPR Notice

Adaptec has made a patent application that may relate to the
work underway in the IPS working group, specifically to the
work derived from draft-ietf-ips-iscsi-20.txt.  This patent application 
describes a method and process for calculating a CRC on data 
received out of order without having to store and assemble the data.

If any patents are issued to Adaptec with claims that are necessary 
for practicing this standard, any party will be able to obtain the right 
to implement, use and distribute the technology or works when 
implementing,
using or distributing technology based upon the specific specification
under openly specified, reasonable, non-discriminatory terms.

Requests may be sent to:

                 Adaptec Legal Department
                 691 South Milpitas Boulevard
                 Milpitas, Ca. 95035

                 Phone:  (408) 957-1718
                 Email:   [email-masked]

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 18 Apr 2003 11:18:32 -0500

>
>Adaptec has made a patent application that may relate to
>the work underway in the IPS working group, specifically
>to the work derived from draft-ietf-ips-iscsi-20.txt. 
>This patent application describes a method and process for
>calculating a CRC on data received out of order without
>having to store and assemble the data.
>
I'm curious as to what is being claimed as novel here. The
fact that XOR operations are commutative has been known for
some time, and that for a CRC upon any fixed sized block
that each bit in the final CRC is an XOR of a subset of
the source bits.

But more to the point. Where is this applicable to rddp?
I can only think of one case where data arrives out of order
that is subject to a CRC, and that would be when an MPA
FULPDU has been delivered both out-of-order and unaligned.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp