Subject: RE: [rddp] WG chair on buffer exhaustion

From: "Shah, Hemal" <[email-masked]>
Date: Wed, 23 Jul 2003 13:16:38 -0700

See my comments below.

Hemal

-----Original Message-----
From: Caitlin Bestler [mailto:[email-masked]] 
Sent: Tuesday, July 22, 2003 10:42 PM
To: [email-masked]
Subject: Re: [rddp] WG chair on buffer exhaustion

On Tuesday, July 22, 2003, at 07:52 PM, [email-masked] wrote:

> If this class of mechanism is needed, that sort of delay may
> be ok.  The determining factors will be the level and nature
> of protection of the shared untagged receive resources from
> exhaustion that is necessary, and "necessary" will probably
> be in the sense of "available to the ULP" (i.e., "MUST implement",
> not "MUST use").

Which suggests that the obvious set of options to consider are:

- MUST support hard or soft limits. MAY support both.
- MUST support hard limits. MAY support soft.
- MUST support soft limits. MAY support hard.
- MUST support hard and soft limits (but not necessarily
   both limits on any single stream).
[hvs] I think for all of the above options it makes sense to have only
one limit (hard or soft) on any single stream. Your last option seems to
suggest that for the first three options, one can have hard, or soft, or
both limits specified per DDP stream. [hvs]

My initial hunch is to favor the first or the last option,
with a slight preference for the last one.
[hvs] I am in favor of the option below (close to your option 3):
RDMAP/DDP implementation MUST support soft limit. RDMAP/DDP
implementation MAY support hard limit. Only one limit can be specified
per RDMAP/DDP stream.
My second preference will be your option 4. [hvs} 

Caitlin Bestler - [email-masked] - http://asomi.com/

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Wed, 23 Jul 2003 15:21:27 -0500

> both limits specified per DDP stream. [hvs]

Agreed. With any of the options, the implementation should
only be expected to support one limit on any stream.
Checking a soft-limit and *then* a hard-limit would be
too complex for a MUST or even a SHOULD.

--------------------