Subject: RE: [rddp] Some Minimal end-to-end Buffer Rules Required

From: [email-masked]
Date: Thu, 17 Jul 2003 08:30:02 -0600

In addition to Paul's note, it is also important to realize that the needs of any application working efficiently over the internet are different than the needs when working over Infiniband. Infiniband networks can generally be counted on to be small and are built with devices designed with the very low latency desired for IPC interactions. Round trip delays are therefore tiny compared to those on the Internet. Therefore, on an Infiniband network the round trip delays in requesting and receiving additional credits will not significantly affect performance. That can not be said for systems operating over internets.

Pat

-----Original Message-----
From: Culley, Paul [mailto:[email-masked]]
Sent: Thursday, July 17, 2003 2:23 AM
To: Caitlin Bestler; John Hufferd
Cc: [email-masked]
Subject: RE: [rddp] Some Minimal end-to-end Buffer Rules Required

> -----Original Message-----
> From: Caitlin Bestler [mailto:[email-masked]] 
> Sent: Wednesday, July 16, 2003 9:10 AM
> To: John Hufferd
> Cc: [email-masked]
> Subject: Re: [rddp] Some Minimal end-to-end Buffer Rules Required
> 
> 
Deleted...
> 
> Then these applications do not work over InfiniBand? You have
> a credit limit over IB RC, and it is even less flexible than 
> what you can do with iWARP.
> 
Actually these applications (that occasionally send more messages than
normally credited) could work quite well on IB because IB supports
automatic flow control for the RC mode receive queue buffers.  In the
"normal" case, the flow control is not invoked, everything flows
smoothly.  In the exceptional case when too many messages need to be
sent, IB backs up the messages at the sender (in the Send Queue).

Paul C.

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 17 Jul 2003 09:41:52 -0500

On Thursday, July 17, 2003, [email-masked] wrote:

>In addition to Paul's note, it is also important to realize that the 
>needs of any application working efficiently over the internet are 
>different than the needs when working over Infiniband. Infiniband 
>networks can generally be counted on to be small and are built with 
>devices designed with the very low latency desired for IPC interactions. 
>Round trip delays are therefore tiny compared to those on the Internet. 
>Therefore, on an Infiniband network the round trip delays in requesting 
>and receiving additional credits will not significantly affect 
>performance. That can not be said for systems operating over internets.

Good point, not only would an extra message be required, it would be
slightly flaky in its effectiveness as well.