Subject: [rddp] Number of MPA Req/Reply exchanges

From: "Michael C. Cambria" <[email-masked]>
Date: Thu, 03 Feb 2005 10:17:23 -0500

My reading of the MPA draft doesn't rule out the possibility of several 
MPA Request/Reply exchanges.  Is this the intent?

There are 2 cases.

When the Initiator receives the MPA Reply Frame with the R bit set (e.g. 
private data wasn't acceptable to ULP) the connection remains open.  The 
ULP may close TCP or use the connection for other purposes.  Can this 
other purpose be yet another MPA setup attempt?

Likewise, if the R bit is 0, the [Initiator] implementation SHOULD enter 
full MPA/DDP operation.  This text doesn't rule out the Initiator 
remaining in TCP stream mode and sending another MPA Request Frame.  For 
example, the responders private data wasn't acceptable.

Regards,
MikeC

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Caitlin Bestler" <[email-masked]>
Date: Thu, 3 Feb 2005 08:09:23 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Michael C. Cambria
> Sent: Thursday, February 03, 2005 7:17 AM
> To: [email-masked]
> Subject: [rddp] Number of MPA Req/Reply exchanges
> 
> 
> My reading of the MPA draft doesn't rule out the possibility 
> of several MPA Request/Reply exchanges.  Is this the intent?
> 
> There are 2 cases.
> 
> private data wasn't acceptable to ULP) the connection remains 
> open.  The ULP may close TCP or use the connection for other 
> purposes.  Can this other purpose be yet another MPA setup attempt?
> 

Yes, that would be legitimate. However, it is highly likely
that the remote peer that has just indicated that it did not
want to talk with you has already closed the TCP connection.

If there is a need to engage in multiple rounds of proposed
RDMA connections and responses then this should probably be
explicitly stated in the ULP-specific protocol. Without such
guidance the passive side is unlikely to leave the connection
open just in case you intend to try again.

In fact I'd bet that the number of implementations doing so
right now would be zero.

> Likewise, if the R bit is 0, the [Initiator] implementation 
> SHOULD enter full MPA/DDP operation.  This text doesn't rule 
> out the Initiator remaining in TCP stream mode and sending 
> another MPA Request Frame.  For example, the responders 
> private data wasn't acceptable.
> 

If the responder's private data wasn't acceptable the initiator
side is expected to terminate the connection.