Subject: [rddp] Whither the RDDP WG

From: [email-masked]
Date: Tue, 11 Oct 2005 17:05:35 -0400

All of the remaining RDDP WG drafts have now been submitted
to the ADs/IESG for publication as RFCs.  Congratulations
and thanks to everyone who contributed!

The next thing to be done is consult with Area Directors
about other work for the WG to undertake.  I don't know
of any at this time, but suggestions can be sent to the
mailing list.

In the absence of additional work items, I would expect
that the RDDP WG will be concluded (terminated) sometime
after the IETF Vancouver meeting week in November (reminder:
No RDDP meeting in Vancouver).  The mailing list will
remain active regardless to deal with any issues that
arise in getting the RDDP drafts through to IESG approval.

Thanks,
--David (RDDP WG chair)
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Caitlin Bestler" <[email-masked]>
Date: Thu, 13 Oct 2005 08:56:30 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jim Pinkerton
> Sent: Wednesday, October 12, 2005 6:45 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [rddp] Whither the RDDP WG
> 
> 
> I would suggest that we let the work group remain idle for a 
> year or so, and then re-convene on the next round of 
> innovation. Areas of interest
> include:
> 
> - extending the protocol to support atomics
> - extending the protocol to support concepts of collective 
> operations (aka MPI).
> - extending the protocol after iSCSI/NFS work is done and we 
> better understand the bottlenecks that they encountered so 
> that we can go for a version 2 of this protocol. 
> 
> One of the things that is worthwhile pointing out is the RDMA 
> Read creates huge opportunities for new innovation 
> (generically fetch&op).
> Atomics are obvious. I expect other areas will come up as 
> applications begin to better understand this new paradigm.
> 

And RDMAP/DDP as protocols are very well structured for
extensibility.  The are more then enough unused opcodes
and even more unused queue numbers. The model of sending
an untagged message to a special queue number should
allow for easy protocol extension.

---

From: "Jim Pinkerton" <[email-masked]>
Date: Wed, 19 Oct 2005 18:04:31 -0700

My main concerns in waiting was 1) give everyone a rest and 2) give the
market time to stabilize - constantly "improving" specs can actually
stop deployment.

Jim

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Caitlin Bestler
> Sent: Thursday, October 13, 2005 8:57 AM
> To: [email-masked]

---

From: "Caitlin Bestler" <[email-masked]>
Date: Thu, 20 Oct 2005 08:26:24 -0700

> From: Jim Pinkerton [mailto:[email-masked]] 
> Sent: Wednesday, October 19, 2005 6:05 PM
> To: Caitlin Bestler; [email-masked]
> My main concerns in waiting was 1) give everyone a rest and 
> 2) give the market time to stabilize - constantly "improving" 
> specs can actually stop deployment.
> 
> 
I agree that should be considered. I was merely pointing out
that the protocols, on a technical basis, can be easily extended
in ways that have no impact on existing implementations (other
than the risk of confusion you cite).

I also agree that there's nothing in the "enhancement queue" that
really calls for drafter to be burning the midnight oil.