Subject: [regext] WG I-Ds in the IANA EPP Extensions Registry

From: Gustavo Lozano <[email-masked]>
Date: Wed, 12 Oct 2016 22:39:09 +0000

Hello colleagues,
 
The gTLD base registry agreement requires Registries to provide and update
the relevant documentation of all the EPP Objects and Extensions supported
to ICANN prior to deployment. Currently, in order to comply with this
provision, Registries upload their documentation through a portal maintained
by ICANN.
 
The proposal for the new version of this portal is to periodically download
the EPP extensions registry
(http://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml
<http://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml> )
allowing the registry to select entries from the IANA Registry. In other
words, the EPP extension must be registered in the IANA EPP Registry in
order to comply with this contractual provision.
 
Several Registries have implemented EPP extensions described in WG I-Ds that
are not registered in the IANA EPP registry. Is it appropriate to register a
*WG* I-D in the IANA EPP Registry or should the author wait until the I-D
becomes an RFC? Should it be a requirement to register the EPP extension in
the IANA EPP registry shortly after becoming a WG item?
 
Thank you for your feedback.
 
Regards,
Gustavo

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 13 Oct 2016 10:59:56 +0000

From: regext [mailto:[email-masked]] On Behalf Of Gustavo Lozano
Sent: Wednesday, October 12, 2016 6:39 PM
To: [email-masked]
Subject: [regext] WG I-Ds in the IANA EPP Extensions Registry

Hello colleagues,

The gTLD base registry agreement requires Registries to provide and update the relevant documentation of all the EPP Objects and Extensions supported to ICANN prior to deployment. Currently, in order to comply with this provision, Registries upload their documentation through a portal maintained by ICANN.

The proposal for the new version of this portal is to periodically download the EPP extensions registry (http://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml) allowing the registry to select entries from the IANA Registry. In other words, the EPP extension must be registered in the IANA EPP Registry in order to comply with this contractual provision.

Several Registries have implemented EPP extensions described in WG I-Ds that are not registered in the IANA EPP registry. Is it appropriate to register a *WG* I-D in the IANA EPP Registry or should the author wait until the I-D becomes an RFC? Should it be a requirement to register the EPP extension in the IANA EPP registry shortly after becoming a WG item?

[SAH] I believe it is more appropriate for an extension that is being developed through the IETF process to be registered only after it has been approved for publication as an RFC. Internet-Drafts are not guaranteed to be published as RFCs, and the specifications they describe can change before they are ultimately approved for RFC publication.

Scott

---

From: Ulrich Wisser <[email-masked]>
Date: Thu, 13 Oct 2016 11:17:12 +0000

Why wouldn't it be sufficient for ICANN if the extensions were just
submitted to the registry (without going through the WG)?
We did this with the .SE extensions.

/Ulrich

Hollenbeck, Scott <[email-masked]> schrieb am Do., 13. Okt. 2016
um 13:01 Uhr:

> *From:* regext [mailto:[email-masked]] *On Behalf Of *Gustavo
> Lozano
> *Sent:* Wednesday, October 12, 2016 6:39 PM
> *To:* [email-masked]
> *Subject:* [regext] WG I-Ds in the IANA EPP Extensions Registry
>
>
>
> Hello colleagues,
>
>
>
> provision, Registries upload their documentation through a portal
> maintained by ICANN.
>
>
>
> The proposal for the new version of this portal is to periodically
> download the EPP extensions registry (
> http://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml)
> Several Registries have implemented EPP extensions described in WG I-Ds
> that are not registered in the IANA EPP registry. Is it appropriate to
> register a *WG* I-D in the IANA EPP Registry or should the author wait
> until the I-D becomes an RFC? Should it be a requirement to register the
> EPP extension in the IANA EPP registry shortly after becoming a WG item?
>
>
>
> [SAH] I believe it is more appropriate for an extension that is being
> developed through the IETF process to be registered only after it has been
> approved for publication as an RFC. Internet-Drafts are not guaranteed to
> be published as RFCs, and the specifications they describe can change
> before they are ultimately approved for RFC publication.
>
>
>
> Scott
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext
>
-- 
Ulrich Wisser
[email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 13 Oct 2016 11:30:36 +0000

From: Ulrich Wisser [mailto:[email-masked]]
Sent: Thursday, October 13, 2016 7:17 AM
To: Hollenbeck, Scott; Gustavo Lozano; [email-masked]
Subject: Re: [regext] WG I-Ds in the IANA EPP Extensions Registry

Why wouldn't it be sufficient for ICANN if the extensions were just submitted to the registry (without going through the WG)?
We did this with the .SE extensions.

[SAH] It could be done this way if the extensions/registration requests meet the requirements described in RFC 7451.

Scott

---

From: Gustavo Lozano <[email-masked]>
Date: Thu, 13 Oct 2016 16:56:04 +0000

Yes, it is sufficient if the extension is submitted to the IANA Registry.

My question is about the I-Ds that are going through the IETF process. For
example, Registries that have currently implemented
draft-ietf-regext-epp-fees. If it¹s not appropriate to register those (I-Ds
going through the IETF process) in the IANA EPP extension Registry, we will
need to support the old method of manually uploading the documentation
through the portal. If the uploading mechanism is not supported, the
Registries will be required to use the IANA EPP extension registry, and as a
result, the IANA EPP Registry will be used more.

Regards,
Gustavo

From:  Ulrich Wisser <[email-masked]>
Date:  Thursday, October 13, 2016 at 04:17
To:  "Hollenbeck, Scott" <[email-masked]>, Gustavo Lozano
<[email-masked]>, "[email-masked]" <[email-masked]>
Subject:  Re: [regext] WG I-Ds in the IANA EPP Extensions Registry

> Why wouldn't it be sufficient for ICANN if the extensions were just submitted
> to the registry (without going through the WG)?
> Hollenbeck, Scott <[email-masked]> schrieb am Do., 13. Okt. 2016 um
> 13:01 Uhr:
>> the relevant documentation of all the EPP Objects and Extensions supported to
>> ICANN prior to deployment. Currently, in order to comply with this provision,
>> Registries upload their documentation through a portal maintained by ICANN.
>> 
>>  
>> 
>> (http://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml[iana.org
>> ] 
>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.iana.org_assignments
>> _epp-2Dextensions_epp-2Dextensions.xhtml&d=DQMFaQ&c=FmY1u3PJp6wrcrwll3mSVzgfk
>> bPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=j_g0CPoOfa
>> yy8JPCenR549u2iepTER9Ir4G4S_m42Og&s=FUbx2HNpnion4HnWAMsqqG7IThJLIpW73vy7WtY7_
>> ds&e=> ) allowing the registry to select entries from the IANA Registry. In
>> other words, the EPP extension must be registered in the IANA EPP Registry in
>> approved for publication as an RFC. Internet-Drafts are not guaranteed to be
>> published as RFCs, and the specifications they describe can change before
>> they are ultimately approved for RFC publication.
>> 
>>  
>> 
>> Scott
>> https://www.ietf.org/mailman/listinfo/regext[ietf.org]
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_li
>> stinfo_regext&d=DQMFaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=Vbweci
>> UcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=j_g0CPoOfayy8JPCenR549u2iepTER9Ir4G4S
>> _m42Og&s=_xQjrMPQuVbjr6nwlSzgOs2dJFrFWmrggSifbvXwfug&e=>
> -- 
> Ulrich Wisser 
> [email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 13 Oct 2016 17:01:25 +0000

From: Gustavo Lozano [mailto:[email-masked]] 
Sent: Thursday, October 13, 2016 12:56 PM
To: Ulrich Wisser; Hollenbeck, Scott; [email-masked]
Subject: Re: [regext] WG I-Ds in the IANA EPP Extensions Registry

draft-ietf-regext-epp-fees. If it's not appropriate to register those (I-Ds

[SAH] The normal process for items to be added to a registry as part of an
IANA action identified in an Internet-Draft is for the action to be
completed when the document is approved for publication as an RFC. I
explained why in my earlier response - Internet-Drafts are not stable and do
not represent community consensus.

Scott