Subject: Re: [regext] Interest in Drafts?

From: Antoin Verschuren <[email-masked]>
Date: Tue, 7 Feb 2017 12:55:09 +0100

Dear working group,

Scott has sent this question to the mailinglist almost a month ago, and so far there has not been one reaction.

The chairs believe that the RDAP drafts Scott suggested fall within the charter of this working group, as RDAP extensions are part of our charter.
But we do need sufficient participation for review for us to take documents onboard.
That’s not only true for these documents, but for all documents already in our charter.
When we rechartered, we had sufficient voiced support for review of documents, but it seems not all subjects share the same interest over time.
No interest in a specific solution also needs advise on why it’s not needed or a bad idea.
So I have a number of questions for you:

1. Do we have any volunteers to review these RDAP documents?

For us to do a good job in progressing existing and adopting new documents, we need reviewers and expert advise.
We realize that this is a small working group and most of us only concentrate on issues at hand we encounter ourselves.
For us to take on RDAP documents since we rechartered, I have the following questions:

2. Could we identify the organizations that have or are implementing RDAP so we can motivate them in participating if they don’t already?

3. Could we make a list of implementations, published/intended policy proposals and RDAP toolkits?

3. If you are aware of RDAP implementers or policy reviewers not aware of this working group, could you please motivate them in participating?

It’s needles to say that by the time your organization needs to implement the products of this working group, the time to complain about improper design has passed, and we hope you can convince your staff and management that the time to invest in proper design is now, before you start implementing at scale.

If we fail do do proper review within this working group, the risk is that the early adopters will make individual submissions for the protocol adjustments they need without consulting the needs of others in this field for the future, and would give us much more work afterwards to restore, or even failure of or criticism on our industry diversity.

Regards,

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

Op 12 jan. 2017, om 19:36 heeft Hollenbeck, Scott <[email-masked]> het volgende geschreven:

> Is anyone interested in reviewing a pair of drafts that I shared on-list a few weeks ago? Both address gaps in RDAP functionality and could actually be useful in production environments:
> 
> https://datatracker.ietf.org/doc/draft-fregly-regext-rdap-search-regex/
> 
> https://datatracker.ietf.org/doc/draft-hollenbeck-regext-rdap-object-tag/
> 
> My team has working prototypes up and running and we are very interested in your feedback. If there's interest we'd like to ask the WG to consider them for adoption.
> 
> Scott
> 
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Andrew Newton <[email-masked]>
Date: Wed, 8 Feb 2017 09:27:14 -0500

> 1. Do we have any volunteers to review these RDAP documents?

I've actually reviewed one of them already, and I can review the other.

> 3. If you are aware of RDAP implementers or policy reviewers not aware of this working group, could you please motivate them in participating?

I thought a lot of this information was already collected in the
RegOps workshops. Maybe we should ask them for it.

-andy

---

From: Mario Loffredo <[email-masked]>
Date: Fri, 10 Feb 2017 12:57:34 +0100

> 2. Could we identify the organizations that have or are implementing RDAP so we can motivate them in participating if they don’t already?
At nic.it we have developed a RDAP server prototype implementing both 
search-regex and object-tag extensions.
We are currently working on authentication and access levels.
The prototype implements also other extensions about search queries that 
we would like to propose to the working group for a feedback and a 
possible standardization.
At the moment the prototype is not accessible but we really hope it will 
be in a short time.
Anyway we can show it in a demo.

Mario

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39 050 3153497
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 10 Feb 2017 12:37:29 +0000

Mario, please send me the details of your implementations when you're ready. I'll add them to the implementation status sections of the drafts.

Scott

From: regext [mailto:[email-masked]] On Behalf Of Mario Loffredo
Sent: Friday, February 10, 2017 6:58 AM
To: Antoin Verschuren <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [regext] Interest in Drafts?

   Dear working group,

   The chairs believe that the RDAP drafts Scott suggested fall within the charter of this working group, as RDAP extensions are part of our charter.
   But we do need sufficient participation for review for us to take documents onboard.
   That's not only true for these documents, but for all documents already in our charter.
   When we rechartered, we had sufficient voiced support for review of documents, but it seems not all subjects share the same interest over time.
   No interest in a specific solution also needs advise on why it's not needed or a bad idea.
   So I have a number of questions for you:

   2. Could we identify the organizations that have or are implementing RDAP so we can motivate them in participating if they don't already?

   At nic.it we have developed a RDAP server prototype implementing both search-regex and object-tag extensions.
   We are currently working on authentication and access levels.
   The prototype implements also other extensions about search queries that we would like to propose to the working group for a feedback and a possible standardization.
   At the moment the prototype is not accessible but we really hope it will be in a short time.
   Anyway we can show it in a demo.

   Mario

   It's needles to say that by the time your organization needs to implement the products of this working group, the time to complain about improper design has passed, and we hope you can convince your staff and management that the time to invest in proper design is now, before you start implementing at scale.

   Regards,

   - --
   Antoin Verschuren

   Op 12 jan. 2017, om 19:36 heeft Hollenbeck, Scott <[email-masked]><mailto:[email-masked]> het volgende geschreven:

      Scott

      _______________________________________________
      regext mailing list
      [email-masked]<mailto:[email-masked]>
      https://www.ietf.org/mailman/listinfo/regext

   _______________________________________________
   regext mailing list
   [email-masked]<mailto:[email-masked]>
   https://www.ietf.org/mailman/listinfo/regext

E-Mail: [email-masked]<mailto:[email-masked]>