Subject: [regext] RDAP Search Using Regular Expressions

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 20 Jul 2017 07:45:17 +0000

As mentioned at the mic on Tuesday, I'd like to ask one more time if anyone has any interest in extending RDAP search functionality to use regular expressions. The draft proposal can be found here:

https://datatracker.ietf.org/doc/draft-fregly-regext-rdap-search-regex/

If there's no interest we'll just let this expire (until people realize that core search functionality is incomplete and something better really is needed :(). If anyone wants to see it continue, and possibly be brought into this group for adoption, please say so.

Scott

---

From: Mario Loffredo <[email-masked]>
Date: Thu, 20 Jul 2017 13:39:21 +0200

Il 20/07/2017 09:45, Hollenbeck, Scott ha scritto:
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

I think that every functionality aiming at improving the precision of a 
search and minimizing the size of a response should be considered. 
Search-regex has this goal.

According to my experience, search-regex can be more efficient if it is 
not used alone but in combination with other functionality restricting 
the number of results (e.g. filtering conditions) but its efficiency 
depends also from other factors: how regex is implemented by the DBMS 
supporting the RDAP server, how regex is written.

In my opinion, RDAP should provide more search functionality than it 
does now and each server should be free to implement it and/or to allow 
it according to the user access level.

Mario

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39 050 3153497
Web: http://www.iit.cnr.it/mario.loffredo

---

From: Dmitry Kohmanyuk <[email-masked]>
Date: Thu, 20 Jul 2017 14:49:06 +0200

> https://datatracker.ietf.org/doc/draft-fregly-regext-rdap-search-regex/

As I (silently) said by raising my hand on Tuesday I am interested in this (.UA ccTLD).

This being said, the good thing about regexps is that there are so many varieties to choose from, so we have to be careful.

> If there's no interest we'll just let this expire (until people realize that core search functionality is incomplete and something better really is needed :(). If anyone wants to see it continue, a…

What is needed for this to happen?

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 20 Jul 2017 14:18:54 +0000

> -----Original Message-----
> From: Dmitry Kohmanyuk [mailto:[email-masked]]
> Sent: Thursday, July 20, 2017 8:49 AM
> To: Hollenbeck, Scott <[email-masked]>
> Cc: [email-masked]
> Subject: [EXTERNAL] Re: [regext] RDAP Search Using Regular Expressions
>
> > As mentioned at the mic on Tuesday, I'd like to ask one more time if
> anyone has any interest in extending RDAP search functionality to use
> regular expressions. The draft proposal can be found here:
> >
> This being said, the good thing about regexps is that there are so many
> varieties to choose from, so we have to be careful.

This is precisely why we referenced a very specific POSIX version and we touch on the issue in Section 6. POSIX may or may not be a good choice. We're open to feedback.

> > If there's no interest we'll just let this expire (until people realize
> that core search functionality is incomplete and something better really
> is needed :(). If anyone wants to see it continue, and possibly be brought
> into this group for adoption, please say so.
> >
>

What would be helpful is implementation feedback. If folks decide to implement the spec, please let me know and we'll work with you to update the document to include information about your implementation. It doesn't really go away if it expires, and we can always bring it back very quickly with an update.

Scott