Subject: Re: [regext] TLD Phase Discovery

From: "Gould, James" <[email-masked]>
Date: Mon, 14 Aug 2017 18:27:13 +0000

Thomas,

As a co-author of Launch Phase Mapping going back 5 years and the one that added the “Domain names may be made available only in unique launch phases, whilst remaining unavailable for concurrent launch phases” language to the draft, I’m aware of the intent.  Wil and Gavin can also weigh in on the intent.  The intent was for the launch phases to be associated with the TLD (or zone), where there may be a policy for launch phases that differentiates the availability of domain names.  It was never intended or foreseen that a launch phase would be used to group a set of domain names as a form of fee classification.  We can agree to disagree on this topic. 

Back to the question about adding support for a Phase Available Check Form to draft-ietf-regext-launchphase.  You believe that it is needed and I believe that the existing draft meets the intended needs.  I would like to hear from the registrars and registries in support for adding this feature or to keep the draft as is.  Please share your thoughts publicly on the list or privately.  

Thanks,
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/> 

On 8/14/17, 8:34 AM, "regext on behalf of Thomas Corte" <[email-masked] on behalf of [email-masked]> wrote:

    James,
    
    On 2017-08-11 19:27, Gould, James wrote:
    
    > launch phases are not meant to be a method of grouping domain
    > names like premium domain names.
    
    Says who? As I pointed out in previous e-mails, the launch phase
    extension spec's wording
    
      "Domain names may be made available
       only in unique launch phases, whilst remaining unavailable for
       concurrent launch phases."
    
    clearly suggests otherwise.
    
    Aside from premium domain names, there are other examples where such a
    grouping may be necessary, such as when phases are used to introduce new
    IDN tables, or to make certain names available only to certain eligible
    registrants when a TLD is first launched.
    Determining the right phase for a name with a single EPP command should
    be possible in such scenarios.
    
    > I view overlapping launch phases as
    > a corner case that is already handled by
    > draft-ietf-regext-launchphase.
    
    It is, but obviously not in a way that's satisfactory for registrars or
    registries. Trial-and-error probing for the right phase isn't a solution
    I'd deem suitable.
    
    Best regards,
    
    Thomas
    
    -- 
    TANGO REGISTRY SERVICES® is a product of:
    Knipp Medien und Kommunikation GmbH
    Technologiepark                             Phone: +49 231 9703-222
    Martin-Schmeisser-Weg 9                       Fax: +49 231 9703-200
    D-44227 Dortmund                       E-Mail: [email-masked]
    Germany
    
    _______________________________________________
    regext mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/regext

---

From: Gavin Brown <[email-masked]>
Date: Tue, 15 Aug 2017 14:42:20 +0100

> As a co-author of Launch Phase Mapping going back 5 years and the one that added the “Domain names may be made available only in unique launch phases, whilst remaining unavailable for concurrent la…

I agree with Jim. The Launch Phase was not designed to deal with premium
names: I would not have created the fee extension if it were.

G.

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 18 Aug 2017 16:51:09 +0200

Hi all,

In order to achieve progress, I’m trying to summarize the discussion:

1. Most folks agree there may be a need for phase discovery.
When there are multiple phases for registration, and there are real world examples for that, being able to discover the phase a domain is viable in through an availability check is at least "handy”, to avoid trial and error or out of bound discovery processes. This may be true for other EPP "knobs” as well though.

2. This need only arises in corner cases though.
We’re not talking millions of domain names here. If we are, then there may be something wrong with the registry policy being too complex, and not the registration process.

3. The Launchphase draft and it’s check command was not meant to address this need.
The launchphase process only describes how to do things once you know what you want to do.
Can I conclude that the Launchphase draft should proceed as is?

4. The major demand for phase discovery is to discover the correct fee.
I understand this business wise. You want to present your customer the correct fee during registration.
But this one bugs me a little bit. <chair hat off>
While I understand that a special launch phase may be accompanied with a different fee because of potential special handling, this should not be a differentiator to group fees imho though.
A (launch) phase is meant to differentiate in a different allocation policy, like preference or limitation in registrants, equal distribution, respect for trademarks or other policy related allocation.
When trying to discover a phase based on it’s fee, it feels like you are trying to ignore the policy as the true differentiator, almost saying the policy doesn’t matter, and for the right fee, we will try to comply to or even ignore the policy in stead of the intent of first complying to the policy and then care for the extra fee. </chair hat off>
The question therefor is if the Fee document will be able to solve this?

The major question for the chairs now is if we can proceed with the Launchphase document.
The chairs believe that there is majority consensus to not change the Launchphase document.
If not, we would like to hear that before the end of next week so we can proceed that document to the IESG.

The second question then is if there is a need to change the Fee document to accommodate the use case Thomas needs.
Or that it needs a more generic phase discovery like the suggestion for a Registry Mapping document.
We expect that this will be discussed during the interim meeting next wednsesday.

Please comment if any of my conclusions on the consensus is incorrect.

Regards,

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

---

From: "Gould, James" <[email-masked]>
Date: Fri, 18 Aug 2017 17:56:29 +0000

Antoin,

Thanks for summarizing the points.  I provide feedback inline below.
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On 8/18/17, 10:51 AM, "regext on behalf of Antoin Verschuren" <[email-masked] on behalf of [email-masked]> wrote:

    Hi all,

JG- draft-ietf-regext-launchphase supports determining the availability of a domain in a specified phase currently via the Availability Check Form.  I believe more generic discovery is handled better by an object mapping of the TLD (zone) like the Registry Mapping.  

JG-I view overlapping launch phases as a corner case, but draft-ietf-regext-launchphase already does support overlapping launch phases.

JG-Yes

JG-I don’t believe that a launch phase should be a replacement for a fee classification.  I’m not sure whether the registry fee extension will be able to solve the use of launch phases as a form of fee classifications.  I believe it’s best to consider how to handle overlapping fee classifications in support of premium domain names with the registry fee extension.  What is defined now should meet the need.

    
JG-I believe that the fee classifications and the fee information returned by the registry fee extension should be the basis for clients to make fee decisions and for the servers to apply fee policies.  Generic discovery of TLD (zone) level policies and features, including current and future launch phases, is best suited for an extension like the Registry Mapping.   

    Regards,
    
    - --
    Antoin Verschuren