Subject: [regext] I-D Action: draft-ietf-regext-rdap-object-tag-00.txt

From: [email-masked]
Date: Tue, 16 Jan 2018 05:49:54 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions WG of the IETF.

        Title           : Registration Data Access Protocol (RDAP) Object Tagging
        Authors         : Scott Hollenbeck
                          Andrew Lee Newton
	Filename        : draft-ietf-regext-rdap-object-tag-00.txt
	Pages           : 12
	Date            : 2018-01-16

Abstract:
   The Registration Data Access Protocol (RDAP) includes a method that
   can be used to identify the authoritative server for processing
   domain name, IP address, and autonomous system number queries.  The
   method does not describe how to identify the authoritative server for
   processing other RDAP query types, such as entity queries.  This
   limitation exists because the identifiers associated with these query
   types are typically unstructured.  This document describes an
   operational practice that can be used to add structure to RDAP
   identifiers that makes it possible to identify the authoritative
   server for additional RDAP queries.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-rdap-object-tag/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-regext-rdap-object-tag-00
https://datatracker.ietf.org/doc/html/draft-ietf-regext-rdap-object-tag-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 16 Jan 2018 13:58:45 +0000

> -----Original Message-----
> From: regext [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Tuesday, January 16, 2018 8:50 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [EXTERNAL] [regext] I-D Action: draft-ietf-regext-rdap-object-
> tag-00.txt
>
>

Please note that this document describes a recommendation for a best current practice to support bootstrapping of entity queries - it isn't a protocol proposal. The idea is to add structure to entities in much the same way that information containing in domain names can be used to bootstrap domain queries.

The registry described in the document is not an extension or modification of the registry used for domains. Consider what's there a proposal for discussion. If it makes more sense to revise the structure of the registry used for domain queries, we can explore that option and see if it makes more sense.

The registry question is the only one I currently have enqueued for working group discussion. Please review the document and share your comments with the list. If we don't identify any other significant issues this one may be able to move through quickly since the practice it describes is basically one that is already being used by at least some of the RIRs.

Scott