Subject: [regext] Regain of interest in RDAP tiered access?

From: Patrick Mevzek <[email-masked]>
Date: Fri, 27 Apr 2018 05:12:14 +0200

Hello,

As you may be aware, ICANN discussed with WP29 on issues related to GDPR and whois.
Among the set of documents exchanged there is this timeline:
https://www.icann.org/en/system/files/files/gdpr-timeline-implement-action-plan-20apr18-en.pdf

Besides the time frame goals exposed that I let you judge by yourself
(it remains to be seen how European regulators will allow exceptions on their
dates published 2 years ago),
I see specific mention of layered access for RDAP, which is refreshing after
so many years of blind views on this by governing parties.

This also may mean more (expedited?) work to conduct in this working group to deliver solutions for proper RDAP layered access :-)

And Scott's drafts and experiments are probably very good starting points.

Let the festivities begin!

-- 
  Patrick Mevzek
  [email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 27 Apr 2018 10:59:54 +0000

> -----Original Message-----
> From: regext [mailto:[email-masked]] On Behalf Of Patrick Mevzek
> Sent: Thursday, April 26, 2018 11:12 PM
> To: [email-masked]
> Subject: [EXTERNAL] [regext] Regain of interest in RDAP tiered access?
>
> Hello,
>
> Besides the time frame goals exposed that I let you judge by yourself (it
> remains to be seen how European regulators will allow exceptions on their
> dates published 2 years ago), I see specific mention of layered access for
> RDAP, which is refreshing after so many years of blind views on this by
> governing parties.
>
> This also may mean more (expedited?) work to conduct in this working group
> to deliver solutions for proper RDAP layered access :-)
>

Thanks for the plug, Patrick.  With the most recent document update I think I have a functionally complete solution described and it may be time to consider WG adoption of the draft. There's still policy information needed to finish the query purpose details, but hopefully that situation will clear up as people are forced to deal with this issue in the near future.

Scott

---

From: George Michaelson <[email-masked]>
Date: Mon, 30 Apr 2018 08:14:31 +1000

I support adoption of this draft. There is a compelling story around
the need for identified client access to RDAP in names and numbers,
and therefore a clear need for a standard. federated access is going
to be needed for LEA access.

We have a significant number of registries in deployment worldwide,
and it is very likely the community of users want us to coordinate a
mechanism to identify them and provide appropriate differentiated
access to data which otherwise we're being forced to turn dark, in
both name and number registries.

-George

On Fri, Apr 27, 2018 at 8:59 PM, Hollenbeck, Scott
<[email-masked]> wrote:
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext