Subject: [Revampers] IETF Website revamp: Community Review Committee

From: Russ Housley <[email-masked]>
Date: Wed, 15 Mar 2017 11:53:16 -0400

Dear Members of the www.IETF.org website revamp Community Review Committee,

As you may know, I have recently taken over from Joe Hildebrand as the designated projected manager for the www.ietf.org website revamp. We are just about finished with the development phase of the project, and we are move towards community review and, eventually, deployment. To that end, I would like to provide a brief update on:
	• the status of the project,
	• plans for gathering review and input--particularly from the IETF community,
	• a timeline for moving the revamped site to production, and
	• a proposal for the ongoing improvement and evolution of the website.

The IAOC project page (https://iaoc.ietf.org/projects.html) will be updated shortly to include this information as well.

This project has been ongoing for some time. The plan as proposed foresees finishing initial build, incorporating feedback, and cutting over to production in about 7 weeks. Additional rounds of development are expected to take place later this year to address non-critical suggestions for improvement.  In addition to maintenance, ongoing input and feedback will be solicited to continue evolving the website.

A key part of the review process includes a conversation with this group to preview the revamped site in action, and gather input on how to validate that the site meets the statement of work requirements and the needs of the key audiences.

I would like to find a time on 21 March to have a virtual meeting.  Please fill out the poll to help select a time:

	http://doodle.com/poll/iawkgrharemxqm9w

As part of that meeting, we’ll review the current status of the site, cover the statement of work requirements, and discuss what other steps might be needed to continue moving toward production deployment.

We’ll record the session, as we have for previous Community Review Committee gatherings, and we’ll share notes and other information after the call to gather further input.

Sincerely,
Russ Housley

= = = = = = = = = =

www.ietf.org Website Revamp Update
2017-03-13

RROJECT STATUS

The www.ietf.org website revamp project was undertaken per the Scope of Work (SOW) (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf), which was developed by the IAOC Technology Management Committee with IETF community review and input.

In addition to being shaped by the project goals, key audiences (IETF participants, potential IETF participants, and non-participants) were interviewed to understand how a revamped IETF website could best serve them. The Community Review Committee (CRC) provided guidance to translate the goals and audience requirements into website design. The IETF Tools team created an interface that allows the www.ietf.org website to incorporate information about Working Groups, people, RFCs, and Internet-Drafts directly from the IETF Datatracker.

The IETF community was given a preview of, and solicited for input on, the site design around IETF 93. A further update was provided in June 2016 (https://www.ietf.org/blog/2016/06/www-ietf-org-revamp-update/). Since then, the revamped design has been implemented on a development server provided by the selected vendor (Torchbox, https://www.torchbox.com) using an open source content management system (Wagtail, https://www.wagtail.io). This design is currently running on an Secretariat-controlled server at https://www7.ietf.org (with restricted access).

Final bug fixing has taken longer than initially expected. However, during this time a significant amount of content has been loaded into the revamped website. Some work does remain to fine tune and complete the content transfer and fix a few final bugs found in the page templates. To help ensure consistent content, an editorial plan has been developed for the top pages of the revamped website; see
https://docs.google.com/spreadsheets/d/1LCk9Fn2kdeJPNPg5z5yIDmHs8KM_HEKbDS4k2PVLNSo/edit?usp=sharing

A key requirement of the SOW is URL continuity to ensure well-known resources are reachable at their current (probably bookmarked) web location. This has not been implemented yet. Appropriate methods for doing so will be determined in coordination with the Secretariat and IETF Tools teams as part of moving the revamped site to production. They will be implemented when the revamped site is switched to production.

TESTING AND ROLLOUT

To test the design and gather information about how it might be improved, a plan to gather feedback has been developed. The plan matches the goals of the SOW and includes a) sharing the site with the entire IETF community prior to IETF 98, and b) gathering input from key groups. A timeline is available; see
https://docs.google.com/spreadsheets/d/11t9A2Vfa0MVsADSZUTrm_y_7i8T2_mnh_Nk0tTKWZfI/edit

Key elements include:
   • Reviewing with the Community Review Committee;
   • Checking in with key IETF groups (Education & Mentoring directorate, Tools team, etc.);
   • Gathering focused feedback from key audiences outside the IETF community, and
   • Engaging with the IETF community through various means.

For IETF community input, online workshops similar to those conducted for the IASA 2.0 discussion are proposed. Additionally, we propose holding office hours (a table near the IETF registration desk) during IETF 98. The goal of both of these approaches is to engage the community in ways that promote dialog and allow for conversation. And, of course, the site will be shared via the usual mailing lists (and hopefully a blog entry).

Feedback will be encouraged via Github (https://github.com/ietf/www.ietf.org/issues).  This provides a method for prompting specific information about issues when the are submitted, making assignments for resolution where appropriate, and tracking progress and completion of a each raised issue. A feedback email address will also be provided in the hope that this project will not generate too much traffic on [email-masked].

TIMELINE FOR MOVING TO PRODUCTION

The proposed timeline anticipates moving to production by the first week of May 2017, pending a go/no-go decision the preceding week. This includes several rounds of “bug fixing”, which will address both content and functionality. As noted above, a key step in the move to production will be to implement URL continuity for identified items. It is important to note also that--while we anticipate all important content will be transitioned to the revamped site before cut over--even after cut over, all the content from the current website will saved should it be needed.

ONGOING IMPROVEMENT AND EVOLUTION

The 2017 budget anticipates further evolution and development of the website. It also anticipates the regular maintenance of software. There will be close coordination with the IETF Tools team to ensure ongoing improved coordination with the Datatracker and other tools. Possibilities for enhancing and improving the website further should be considered as we begin planning for 2018.

---

From: Russ Housley <[email-masked]>
Date: Mon, 20 Mar 2017 11:19:53 -0400

I assume that everyone is busy getting ready for Chicago.  Only one of you has answered the Doodle poll.  So, I suggest that we reschedule for after Chicago.

At Chicago, there will be office hours when people can see an overview of the new website design.  The intent is to make the site more friendly to mobile devices and make it understandable by people that want to learn about the IETF but have never been to a meeting.  Of course, we need to continue to meet all of the needs of IETF participants as well.  Please take an opportunity to see the new design in Chicago.  This will make the call after Chicago more fruitful.

Thanks,
  Russ

> On Mar 15, 2017, at 11:53 AM, Russ Housley <[email-masked]> wrote:
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 23 Mar 2017 11:52:30 -0400

Since only one of you responded to the doodle poll last week, I want to confirm that you recall volunteering to be part of the community review committee for the revamped website.  It has been a long time.  Please respond to me and Greg Wood (not the list) with one of these responses:

	- Yes, I can still help.

	- No, I no longer have the cycles to help.

Thanks,
  Russ

On 3/20/17 10:19 AM, Russ Housley wrote:
> _______________________________________________
> Revampers mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/revampers