Subject: Re: [rfc-i] Fwd: Re: Old Errata

From: Brian E Carpenter <[email-masked]>
Date: Wed, 14 Sep 2016 14:35:06 +1200

Hi Heather,
On 14/09/2016 07:32, Heather Flanagan wrote:
> Hi Brian,
> 
> In terms of how having unhandled errata reflect on the reputation of the RFC Series, yes, this is an RFC Editor issue. That said, we do not have the necessary information to make the necessary judgements on technical errata. That must come from the authors, the WGs, or the stream approving bodies as appropriate. 

Agreed. It's just that if nobody pushes, nothing will happen.

> The RFC Editor does take responsibility for the editorial errata; that’s a relatively recent change in the last two years or so.
> 
> As for the old Legacy RFCs, those now have pointers to either the specific groups as requested by the IESG or the IESG as a whole on their info pages.

Yes, but I still wonder what prevents a brief Last Call to the community
proposing to change *all* the UNKNOWNs to HISTORIC.

(Also, I doubt if many people will be writing to the IESG about RFC6. :-)

Regards
    Brian

> 
> -Heather
> 
> On September 12, 2016 at 12:58:21 PM, Brian E Carpenter ([email-masked]) wrote:
> So, I don't want to upset the IETF list, but it seems to me that unhandled errata  
> should be primarily an RFC Editor issue, not an IETF issue, even if most of them  
> need to be resolved by the IETF stream.  
> 
> Certainly the backlog is a Bad Thing, but I agree with John's final comment  
> below.  
> 
> (The large number of RFCs in status Unknown is a similar problem to which John's  
> comment also applies.)  
> 
> Brian  
> 
> -------- Forwarded Message --------  
> Subject: Re: Old Errata  
> Date: Mon, 12 Sep 2016 13:35:49 -0400  
> From: John C Klensin <[email-masked]>  
> To: Loa Andersson <[email-masked]>, Yoav Nir <[email-masked]>, IETF Discussion Mailing List <[email-masked]>  
> 
> 
> 
> --On Monday, September 12, 2016 11:56 +0200 Loa Andersson  
> <[email-masked]> wrote:  
> 
>> Yoar,  
>>  
>> I looked at this - to see if I missed something - and the  
>> picture that  
>> comes over is  
>>  
>> Year number of errata working group  
>> 2005 1 tewg  
>> 2010 5 nsfv4  
>> 2011 1 nsfv4  
>> 2012 1 nsfv4  
>> 2013 11 Legacy (gen), Poisson (gen), krb-wg  
>> (sec),  
>> mext (int), nsfv4, non-wg (sec) x  
>> 2,  
>> keyprov(sec) behave (tsv), non-wg  
>> (gen),  
>> dane (sec)  
>> 2014 35 many wg's  
>> 2015 57 many wg's  
>> 2016 114 many wg's  
>>  
>> I think there are one problem here that need to have some type  
>> of management action. The tewg, nsfv4 and of the wg's with  
>> errata from 2013 only dane is still active.  
> 
>> The ADs might have to point to someone to resolve the (oldest)  
>> errata. Or errata that belong to closed wg's.  
> 
> As former co-chair of one of the WGs listed, I don't remember  
> ever having been told about this  
> (https://www.rfc-editor.org/errata_search.php?eid=3752). If I  
> had been, or were able to comment on the erratum now (there does  
> not appear to be any way in the system for me to do that), I  
> would have said that using an erratum to change (not actually  
> correct, because it was correct when the RFC was published) an  
> email address would rank fairly high on the "pointless" scale...  
> at least until we turn RFCs from archival to living documents or  
> invent a magical mechanism that warns anyone opening an RFC that  
> there are relevant errata.... even if the copy of the RFC they  
> open was copied from the archive years ago onto a machine that  
> is not connected to the Internet.  
> 
> Part of the point is that our Status and Type categories are  
> really not up to the job (something that has been discussed  
> extensively in the past with, AFAIK, no resolution). Given the  
> current categories, just leaving some documents in "Reported"  
> forever might be the right disposition. If we are going to use  
> errata to make minor technical changes, then we probably should  
> have a Status of "Sure, but there needs to be another way to  
> notify people about this issue", maybe with an appropriate  
> Action number in that tracker. It is also tempting to suggest  
> that the "Type" for this kind of erratum should be "smells of  
> dead fish": certainly it is not "Editorial" because the RFC was  
> absolutely correct --technically, operationally, and  
> editorially-- when written.  
> 
> Seems to me that just keeping an alias or link until a few years  
> after the relevant RFC becomes obsolete would be a lot less  
> trouble.  
> 
> I doubt this is the only case -- the errata filing system  
> doesn't have a great track record for S/N ratio and I, at least,  
> would much prefer to have ADs paying attention to WGs and  
> processing of current documents rather than studying the errata  
> files looking for loose ends.  
> 
> john  
> 
> 
> 
> .  
> 
> _______________________________________________  
> rfc-interest mailing list  
> [email-masked]  
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest  
> -- 
> Heather Flanagan
> RFC Series Editor
> 

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 14 Sep 2016 14:19:23 +0000

One problem I see is that there’s essentially only a single ping to the IESG or RFC Editor, with no subsequent follow up. Things get stale when that initial ping gets lost or ignored. This might be an action item for the RFC Editor to enhance the pinging mechanism.

I’m really glad that the editorial errata are now being taken care of by the RFC Editor; having the IESG spend time on those always troubled me.

For the older Errata regarding RFCs that have become obsolete, an “overtaken by other events” might be an appropriate response.

However, for still active protocol RFCs, someone trying to implement the protocol really would be served by having responses. Is an erratum saying that “an ABNF production is wrong” correct or not? Right now, the developer will be forced to make a decision that may or may not be proper.

I’m not saying that it is the IESG that has to make these determinations – delegation of responsibility can be a useful tool, after all.

                Tony

From: rfc-interest <[email-masked]> on behalf of Heather Flanagan <[email-masked]>
Date: Tuesday, September 13, 2016 at 3:32 PM
To: RFC Interest <[email-masked]>, Brian E Carpenter <[email-masked]>
Subject: Re: [rfc-i] Fwd: Re: Old Errata

In terms of how having unhandled errata reflect on the reputation of the RFC Series, yes, this is an RFC Editor issue. That said, we do not have the necessary information to make the necessary judgements on technical errata. That must come from the authors, the WGs, or the stream approving bodies as appropriate. The RFC Editor does take responsibility for the editorial errata; that’s a relatively recent change in the last two years or so.

On September 12, 2016 at 12:58:21 PM, Brian E Carpenter ([email-masked]<mailto:[email-masked]>) wrote:
So, I don't want to upset the IETF list, but it seems to me that unhandled errata
should be primarily an RFC Editor issue, not an IETF issue, even if most of them
need to be resolved by the IETF stream.

-------- Forwarded Message --------

john

---

From: Joe Touch <[email-masked]>
Date: Wed, 14 Sep 2016 11:54:24 -0700

Hi, all,

On 9/14/2016 7:19 AM, HANSEN, TONY L wrote:
>
> One problem I see is that there’s essentially only a single ping to
> the IESG or RFC Editor, with no subsequent follow up. Things get stale
> when that initial ping gets lost or ignored. This might be an action
> item for the RFC Editor to enhance the pinging mechanism.
>
>  
>
> I’m really glad that the editorial errata are now being taken care of
> by the RFC Editor; having the IESG spend time on those always troubled me.
>
>  
>
> For the older Errata regarding RFCs that have become obsolete, an
> “overtaken by other events” might be an appropriate response.
>

It may still be useful to confirm those as errata, rather than letting
them sit idle. Even "old" RFCs can have errors - especially because
they're often used as examples for new RFCs.

Here's an example: I reported an errata for RFC4130 back in July of this
year, based on that RFC using examples that included port numbers from
the assignable range that were not assigned to the services described
(i.e., the examples should have used ephemeral ports).

Although I appreciate that few are likely to care, all RFCs serve as
prior art and so errata issued against them should be addressed in a
timely manner, IMO.

Joe