Subject: [rfc-i] Non-contiguous URL numbers in text format

From: Jeffrey Yasskin <[email-masked]>
Date: Mon, 28 Aug 2017 15:39:28 -0700

Hi RFC folks,

If this isn't the right place to report a bug with xml2rfc, please
point me toward the right place. I found you via
https://xml2rfc.tools.ietf.org/experimental.html.

The attached XML (generated via kramdown-rfc2629 from the attached
markdown) produces URLs [1] and [3], but not [2]. The three links are:

<t><eref target="https://example.com/link1">Link 1</eref></t>
<t><eref target="https://example.com/link2">https://example.com/link2</eref></t>
<t><eref target="mailto:[email-masked]">[email-masked]</eref></t>

And from that `xml2rfc test.xml` generates the following text:

1.  Introduction

   Link 1 [1]

   https://example.com/link2

   [email-masked] [3]

2.  References

2.1.  URIs

   [1] https://example.com/link1

   [3] mailto:[email-masked]

Jeffrey
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Jeffrey Yasskin <[email-masked]>
Date: Mon, 28 Aug 2017 16:43:01 -0700

Here's another example where similar links actually cause the citations to
fail to match:

...
    <note title="Note to Readers">
<t>The source code and issues list for this draft can be found
in <eref target="https://github.com/org/repo">https://github.com/org/repo
</eref>.</t>
    </note>
  </front>
  <middle>
<section anchor="introduction" title="Introduction">
<t><eref target="https://this.is.2.in/the/body/but/1/in/the/refs/
">Misnumbered</eref></t>
...

Produces:

1.  Introduction

   Misnumbered [2]

2.  References

2.1.  URIs

   [1] https://this.is.2.in/the/body/but/1/in/the/refs/

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 29 Aug 2017 02:34:33 +0000

Please file a trac issue at https://trac.tools.ietf.org/tools/xml2rfc/trac/

Be sure to attach your files to the ticket.

Thank you.

                Tony Hansen

From: rfc-interest <[email-masked]> on behalf of Jeffrey Yasskin <[email-masked]>
Date: Monday, August 28, 2017 at 7:43 PM
To: "[email-masked]" <[email-masked]>
Subject: Re: [rfc-i] Non-contiguous URL numbers in text format

Here's another example where similar links actually cause the citations to fail to match:

...
    <note title="Note to Readers">
<t>The source code and issues list for this draft can be found
in <eref target="https://github.com/org/repo<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_org_repo&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=pcEMGZj2CB3k7rMiMQWtAkXnfRuihsKMdhlyxQSZ0jg&e=>">https://github.com/org/repo<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_org_repo&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=pcEMGZj2CB3k7rMiMQWtAkXnfRuihsKMdhlyxQSZ0jg&e=></eref>.</t>
    </note>
  </front>
  <middle>
<section anchor="introduction" title="Introduction">
<t><eref target="https://this.is.2.in/the/body/but/1/in/the/refs/<https://urldefense.proofpoint.com/v2/url?u=https-3A__this.is.2.in_the_body_but_1_in_the_refs_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=LIwECDJqgYbuLanAwWZgNK_sWniCB7xHgbZCFQ7U0tc&e=>">Misnumbered</eref></t>
...

Produces:

1.  Introduction

   Misnumbered [2]

2.  References

2.1.  URIs

   [1] https://this.is.2.in/the/body/but/1/in/the/refs/<https://urldefense.proofpoint.com/v2/url?u=https-3A__this.is.2.in_the_body_but_1_in_the_refs_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=LIwECDJqgYbuLanAwWZgNK_sWniCB7xHgbZCFQ7U0tc&e=>

On Mon, Aug 28, 2017 at 3:39 PM, Jeffrey Yasskin <[email-masked]<mailto:[email-masked]>> wrote:
Hi RFC folks,

If this isn't the right place to report a bug with xml2rfc, please
point me toward the right place. I found you via
https://xml2rfc.tools.ietf.org/experimental.html<https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_experimental.html&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=s6yP5xbUmn3xzSpPv6E51KxEMOmLXgXZI2vkBhkywJI&e=>.

<t><eref target="https://example.com/link1<https://urldefense.proofpoint.com/v2/url?u=https-3A__example.com_link1&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=_qDtyTlsbPcEcar2a1GwMXTt59JUBp-D6BbQQeapbXA&e=>">Link 1</eref></t>
<t><eref target="https://example.com/link2<https://urldefense.proofpoint.com/v2/url?u=https-3A__example.com_link2&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=XOLwedyamYUgo-K4_km49A6-pMP0RjJ2LiTulPwT1Nk&e=>">https://example.com/link2<https://urldefense.proofpoint.com/v2/url?u=https-3A__example.com_link2&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=XOLwedyamYUgo-K4_km49A6-pMP0RjJ2LiTulPwT1Nk&e=></eref></t>
<t><eref target="mailto:[email-masked]<mailto:[email-masked]>">[email-masked]<mailto:[email-masked]></eref></t>

1.  Introduction

   Link 1 [1]

   https://example.com/link2<https://urldefense.proofpoint.com/v2/url?u=https-3A__example.com_link2&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=XOLwedyamYUgo-K4_km49A6-pMP0RjJ2LiTulPwT1Nk&e=>

   [email-masked]<mailto:[email-masked]> [3]

2.  References

2.1.  URIs

   [1] https://example.com/link1<https://urldefense.proofpoint.com/v2/url?u=https-3A__example.com_link1&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=7NQAA4qnH-6xbDiCUBNhyH01Q8ZfjM8ZY6WIdFTHzXA&s=_qDtyTlsbPcEcar2a1GwMXTt59JUBp-D6BbQQeapbXA&e=>

   [3] mailto:[email-masked]<mailto:[email-masked]>

Jeffrey

---

From: Jeffrey Yasskin <[email-masked]>
Date: Mon, 28 Aug 2017 20:00:34 -0700

Done, thanks!

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/334
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/335
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/336

Jeffrey

On Mon, Aug 28, 2017 at 7:34 PM, HANSEN, TONY L <[email-masked]> wrote:
> in <eref
> target="https://github.com/org/repo">https://github.com/org/repo</eref>.</t>
>
>     </note>
>
>   </front>
>
>   <middle>
>
> <t><eref
> target="https://this.is.2.in/the/body/but/1/in/the/refs/">Misnumbered</eref></t>
>
> ...
>
>
>
>
>
> Produces:
>
>
>
> 1.  Introduction
>
>
>
>    Misnumbered [2]
>
>
>
> 2.  References
>
>
>
> 2.1.  URIs
>
>
>
> <t><eref
> target="https://example.com/link2">https://example.com/link2</eref></t>