Subject: [Rfc-markdown] Thanks to Paul Jones for his Docker container with mmark and xml2rfc

From: Dan York <[email-masked]>
Date: Wed, 2 Nov 2016 12:26:48 +0000

I just want to *THANKS* to Paul Jones for creating the Docker container with mmark and xml2rfc - https://github.com/paulej/rfctools - once you install it (and install Docker first, of course) it makes it so sweet to just write in markdown and then type "make" and... ta da... you get both the TXT and XML versions.

On Monday I was working to get a couple of drafts (or updates) in before the deadline and this made it so easy to create new versions.

Thanks, Paul!

Dan

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>
Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 02 Nov 2016 10:56:30 -0400

Dan,

I'm glad you found it useful, and hope others do, too.

I had several people talk to me about the challenges of getting both mmark and xml2rfc installed and configured properly. The Dockerfile shows its actually not so hard once you track down all the right dependencies. :) Since I do work on different machines and those dependencies vary by platform, I can speak from experience that it can be an exercise in frustration when you're just trying to write a document.

I thought the Docker approach would make my life easier and  Docker also cleans up nicely.

I welcome any improvements, forking, etc.

Paul

-------- Original Message --------
From: Dan York <[email-masked]>
Sent: November 2, 2016 8:26:48 AM EDT
To: "[email-masked]" <[email-masked]>
Subject: [Rfc-markdown] Thanks to Paul Jones for his Docker container with	mmark and xml2rfc

Thanks, Paul!

Dan

------------------------------------------------------------------------

_______________________________________________
Rfc-markdown mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rfc-markdown