Subject: [Rfc-markdown] Am I missing any tools for markdown -> RFC?

From: Dan York <[email-masked]>
Date: Sun, 10 Jun 2018 07:51:13 +0000

Hi,

I volunteered to give a brief presentation on Tuesday evening to a group of IETFers in Boston about using markdown to write RFCs. As part of that, I want to present the different tools people can use. Right now I am aware of:

- kramdown - https://github.com/cabo/kramdown-rfc2629

- mmark - https://github.com/miekg/mmark (and the companion Docker tool: https://github.com/paulej/rfctools )

- pandoc - https://www.rfc-editor.org/rfc/rfc7328.txt

- draftr -  https://ipv.sx/draftr/

I will also point out Martin’s excellent I-D template: https://github.com/martinthomson/i-d-template/<https://github.com/martinthomson/i-d-template/blob/master/README.md>

Are there any other tools you are aware of people using to convert markdown to RFCs?

On a related note, I am aware of this existing tutorial on kramdown:

https://www.ietf.org/about/participate/tutorials/process/writing-rfcs-and-internet-drafts-markdown-and-bit-yaml/

Are there other existing tutorials / presentations / slides out there to which I should point people?

Thanks,
Dan

P.S. This talk is part of a “IETF hub Boston” meeting that Alia Atlas has been organizing in our region. It won’t be recorded or streamed... but I may write an article / blog post about this when I am done.

--
Dan York
[email-masked]<mailto:[email-masked]>
+1-802-735-1624
skype:danyork
http://twitter.com/danyork

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 11 Jun 2018 10:04:16 -0400

Dan,

You can point people at https://xml2rfc.tools.ietf.org/experimental.html if
they would like to use the online tools rather than install them locally.

Unfortunately, I’m not going to be able to attend, a conflict came up. I
would be interested in seeing your slides, however.

Thanks,
Andy

On Sun, Jun 10, 2018 at 3:51 AM, Dan York <[email-masked]> wrote:

> Hi,
>
> I volunteered to give a brief presentation on Tuesday evening to a group
> of IETFers in Boston about using markdown to write RFCs. As part of that, I
> want to present the different tools people can use. Right now I am aware of:
>
> I will also point out Martin’s excellent I-D template: https://github.com/
> martinthomson/i-d-template/
> <https://github.com/martinthomson/i-d-template/blob/master/README.md>
>
> https://www.ietf.org/about/participate/tutorials/process/
> writing-rfcs-and-internet-drafts-markdown-and-bit-yaml/
>
> P.S. This talk is part of a “IETF hub Boston” meeting that Alia Atlas has
> been organizing in our region. It won’t be recorded or streamed... but I
> may write an article / blog post about this when I am done.
>
> --
> Dan York
> [email-masked]
> +1-802-735-1624
> skype:danyork
> _______________________________________________
> Rfc-markdown mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rfc-markdown
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 11 Jun 2018 16:22:36 +0200

Hi Dan,

Nice summary.

> - draftr -  https://ipv.sx/draftr/ 

This is running an old version of kramdown-rfc, so I cannot really recommend using it.

While not as spiffy as draftr,  https://xml2rfc.tools.ietf.org/experimental.html  is the Web interface to kramdown-rfc we can recommend at this time (as Andrew said).

Note that you can install kramdown-rfc and *not* install xml2rfc — then kramdown-rfc can do the XML to text conversion for you using the remote interface… (Obviously, it can’t if you haven’t installed it.)

(Maybe everyone who meets Richard in person can casually nag him to update the draftr Web site? ;-)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 11 Jun 2018 16:24:48 +0200

Oh, and maybe you should mention the asciidoc tool described in draft-ribose-asciirfc — this isn’t markdown, but it is in the same spirit, and the threshold may be smaller for people who already do asciidoc.

Grüße, Carsten