Subject: [Rfc-markdown] Are there situations where markdown does NOT work for creating I-D's?

From: Dan York <[email-masked]>
Date: Tue, 12 Jun 2018 13:38:50 +0000

One last question before my talk tonight...  have any of you found situations where markdown does NOT work for creating Internet Drafts?
Were there situations where you needed to use XML instead of markdown?  

Or can you now do everything in markdown (variants) that you can do in xml2rfc?

All the drafts I have written lately have been relatively simple, basic text, so markdown was fine.

Just trying to anticipate questions,
Dan

--
Dan York
Director, Content & Web Strategy, Internet Society
[email-masked]   +1-802-735-1624 
Jabber: [email-masked]  Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/

---

From: Julian Reschke <[email-masked]>
Date: Tue, 12 Jun 2018 15:46:10 +0200

On 2018-06-12 15:38, Dan York wrote:
> One last question before my talk tonight...  have any of you found 
> situations where markdown does NOT work for creating Internet Drafts?

It depends. The xml2rfc vocabulary can be extended (custom extensions, 
or V3), and one can use this stuff by running a preprocessor for plain 
text generation. kramdown-rfc2629 however can not produce these elements 
(yet).

Try to generate what we have in

   https://greenbytes.de/tech/webdav/rfc7230.html

and you'll see what I mean...

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 12 Jun 2018 16:33:11 +0200

> Were there situations where you needed to use XML instead of markdown?  

You can always insert snippets of XML into the markdown if that is needed (which is most often used for processing instructions).
You also get access to the attributes of XML elements using kramdown “IALs”.

> Or can you now do everything in markdown (variants) that you can do in xml2rfc?

Kramdown-rfc does not have support for certain elements, e.g. preludes/postludes of figures.
That is not a big problem for RFCXMLv2, as that doesn’t contain a lot of things that are useful beyond what’s obvious to do in markdown.
That will change a bit for RFCXMLv3.  Having your sources in markdown format is a great way to port them over to v3 without having to learn or change anything :-), but there will be new features in v3 (e.g., column/row spans in tables) that will require inventions beyond those that have been made for RFCXMLv2.  I have not done that work yet, so I can’t definitively say how the result will look like.

> All the drafts I have written lately have been relatively simple, basic text, so markdown was fine.

Same for me (and then, if it isn’t, I raise a feature request with the author of kramdown-rfc :-).

People like Julian use RFCXML as an element of a publishing pipeline — again, markdown can be a good initial format for something like that, but if your input to that publishing pipeline needs to be heavily marked up in the source, markdown doesn’t win you a lot.  But that is mostly relevant only for people who do document processing for a living or as a hobby…

Grüße, Carsten