Subject: [Rfc-markdown] Is xml2rfc.tools.ietf.org down? Can't reach it from IETF 103 network

From: Dan York <[email-masked]>
Date: Sun, 4 Nov 2018 11:27:35 +0000

Is xml2rfc.tools.ietf.org <https://xml2rfc.tools.ietf.org/> down?  

Here at IETF 103 in Bangkok, I've been getting timeouts when trying to run "kdrfc" from my laptop - and so I tried going to:

https://xml2rfc.tools.ietf.org/experimental.html

but found that I can't get to that URL - or to https://xml2rfc.tools.ietf.org/ at all.

If it is down, any estimate on when it might be back up?  (Trying to work on a draft right now.)

Thanks,
Dan

P.S. When I say I've been getting timeouts, the issue is that kdrfc is not able to pull down XML files into the local cache. Here is a recent error message:

$ kdrfc draft-york-wpack-website-publisher-use-case.md 
.refcache/reference.RFC.2119.xml: renewing (stale by 13.4 days)
*** execution expired while fetching https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.2119.xml
.refcache/reference.RFC.8174.xml: renewing (stale by 13.4 days)
*** execution expired while fetching https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.8174.xml
.refcache/reference.I-D.yasskin-webpackage-use-cases.xml: renewing (stale by 12.9 days)
*** execution expired while fetching https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.yasskin-webpackage-use-cases.xml
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/protocol.rb:158:in `rbuf_fill': Net::ReadTimeout (Net::ReadTimeout)
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/protocol.rb:136:in `readuntil'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/protocol.rb:146:in `readline'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http/response.rb:40:in `read_status_line'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http/response.rb:29:in `read_new'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http.rb:1437:in `block in transport_request'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http.rb:1434:in `catch'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http.rb:1434:in `transport_request'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http.rb:1407:in `request'
	from /Library/Ruby/Gems/2.3.0/gems/kramdown-rfc2629-1.2.9/bin/kdrfc:57:in `block in process_xml_remotely'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http.rb:853:in `start'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/net/http.rb:584:in `start'
	from /Library/Ruby/Gems/2.3.0/gems/kramdown-rfc2629-1.2.9/bin/kdrfc:55:in `process_xml_remotely'
	from /Library/Ruby/Gems/2.3.0/gems/kramdown-rfc2629-1.2.9/bin/kdrfc:41:in `rescue in process_xml_locally'
	from /Library/Ruby/Gems/2.3.0/gems/kramdown-rfc2629-1.2.9/bin/kdrfc:30:in `process_xml_locally'
	from /Library/Ruby/Gems/2.3.0/gems/kramdown-rfc2629-1.2.9/bin/kdrfc:24:in `process_xml'
	from /Library/Ruby/Gems/2.3.0/gems/kramdown-rfc2629-1.2.9/bin/kdrfc:110:in `<top (required)>'
	from /usr/local/bin/kdrfc:22:in `load'
	from /usr/local/bin/kdrfc:22:in `<main>'

--
Dan York
Director, Content & Web Strategy, Internet Society
[email-masked]   +1-802-735-1624 
Jabber: [email-masked]  Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/

---

From: Miek Gieben <[email-masked]>
Date: Sun, 4 Nov 2018 11:33:52 +0000

[ Quoting <[email-masked]> in "[Rfc-markdown] Is xml2rfc.tools.iet..." ]
>P.S. When I say I've been getting timeouts, the issue is that kdrfc is not able to pull down XML files into the local cache. Here is a recent error message:

Broken for me as well (from the UK)

Scientific error: doesn't load in browser

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 4 Nov 2018 18:38:48 +0700

Horrible Workaround:

KRAMDOWN_OFFLINE=yes kdrfc draft-york-wpack-website-publisher-use-case.md 

(Generates stubs for what it can’t find.)

Grüße, Carsten

> On Nov 4, 2018, at 18:27, Dan York <[email-masked]> wrote:
> 
> *** execution expired while fetching https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D..yasskin-webpackage-use-cases.xml

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 4 Nov 2018 19:08:47 +0700

>> *** execution expired while fetching https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D..yasskin-webpackage-use-cases.xml

Henrik just told me this now works again (at least if you fix the double dot :-)

Grüße, Carsten

---

From: Dan York <[email-masked]>
Date: Sun, 4 Nov 2018 13:48:33 +0000

Carsten,

> On Nov 4, 2018, at 7:08 PM, Carsten Bormann <[email-masked]> wrote:
> 
> Henrik just told me this now works again

And I can confirm that it work. Thanks for letting me know.

> (at least if you fix the double dot :-)

Ha!  I'm not quite sure how that got in there, since the text only has one dot. And I scrolled back up the shell history and don't see a double dot anywhere... so I must have somehow copied/pasted that incorrectly.

Thanks,
Dan