Subject: [Rift] FSM diagram in draft-ietf-rift-rift-02.txt

From: Bruno Rijsman <[email-masked]>
Date: Sun, 24 Jun 2018 11:39:27 -0700

It seems to me that using an embedded .dot file in an I-D for the FSM diagram is too much of a hurdle for most casual readers. Also, the diagram that graphviz produces is neither particular pretty nor easy to understand.

Here is a Github gist with an ASCII diagram if you would like to include one in the draft: https://gist.github.com/brunorijsman/b5105ed239835e00564fae13d61c484f <https://gist.github.com/brunorijsman/b5105ed239835e00564fae13d61c484f>

— Bruno

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 25 Jun 2018 09:36:54 -0700

Bruno, sure & thanks, lemme paste it in & give you some accolades ;-) I
just got tired of redrawing the stuff e'time I changed something ... Will
be in -03 draft after IETF ...

--- tony

On Sun, Jun 24, 2018 at 11:39 AM Bruno Rijsman <[email-masked]>
wrote:

> It seems to me that using an embedded .dot file in an I-D for the FSM
> diagram is too much of a hurdle for most casual readers. Also, the diagram
> that graphviz produces is neither particular pretty nor easy to understand.
>
> Here is a Github gist with an ASCII diagram if you would like to include
> one in the draft:
> https://gist.github.com/brunorijsman/b5105ed239835e00564fae13d61c484f
>
> — Bruno
> _______________________________________________
> RIFT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rift
>