Subject: [rmcat] Call for declarations of interest to submit a paper to Packet Video 2013

From: Michael Welzl <[email-masked]>
Date: Mon, 6 May 2013 15:51:21 +0200

Dear all,

Stein Gjessing and I are planning to arrange a special session dedicated to RMCAT at IEEE Packet Video 2013: http://pv2013.itec.aau.at

Our proposal for a special session, described below, has been tentatively accepted by the organizers of IEEE Packet Video 2013. It's not hard to see that this is indeed pretty RMCAT focused  :-)   For final acceptance of our session, we need to have a list of committed papers already at this stage. Hence, if the topic below is of interest to you, and you plan to submit a paper to this special session, please send us:
- authors
- title
- abstract
of that paper ***by next Monday (13 May)***.

The real deadline for paper submission would then be 10 June. Again, note that this is not a CFP yet, it's a pre-CFP-call-of-interest... in a way, informing us that you're planning to submit a paper is similar to registering a paper before submitting the full thing, I'd say.

Cheers,
Michael

***************************************************************************************************

Special session @ IEEE Packet Video 2013: LIVE - Low-latency Interactive VidEo

Several years ago, it was found that users do not like video quality fluctuations. At that time the predominant belief was that network rate fluctuations should be minimized, in order to reasonably interoperate with TCP in the network. This led to the creation of a number of so-called "TCP-friendly" congestion controls that exhibit a smoother sending rate than TCP, while avoiding to send more than a conformant TCP under similar conditions. TFRC is perhaps the best known example of such a congestion control mechanism.

A lot has happened since then:
- The notion of TCP-friendliness has received massive criticism; the widespread deployment of a more aggressive TCP variant, CUBIC, has not led to an Internet meltdown, making the case that diverging from strict TCP-friendliness is possible.
- Latency minimization has become a major goal, especially in the face of "bufferbloat": large delays from large buffers with simplistic FIFO-queue management.
- Codecs have improved; novel video codecs are able to adjust the data rate, but modern codecs may also produce variable bit rate transmissions with burstier packet flows than before.
- TFRC has been embedded in the DCCP protocol, which has probably never been used for anything other than experiments; instead of running over DCCP, RTP-based applications now contain proprietary congestion control mechanisms.

The emergence of the RTCWEB protocol suite for real-time communication between web browsers has renewed the interest in developing congestion control standards for real-time media. This time, however, the goal is to get things right: delay should be minimized, and standards should realize congestion control using RTP with RTCP signaling. The IETF "Real-time Media Congestion Avoidance Techniques" (RMCAT) group has been founded to address this need. New questions arise: what type of congestion controls do we need? How much feedback should we send? How do we make this work in multi-user scenarios, e.g. for video conferencing? What should be the API between a video codec and a new delay-based congestion controlled RTP stream? What is the quality that can be expected from the combination of a codec and congestion control mechanism, when we consider better metrics than plain PSNR?

Topics of interest include, but are not limited to:
- Congestion control algorithms for interactive real-time video: requirements, evaluation criteria, and mechanisms
- Necessary RTP/RTCP extensions
- Field experience with video codecs in a low-delay, real-time setting
- Interactions between applications and RTP flows
- Failing to meet real-time schedules: impact, techniques to detect, instrument or diagnose it

This activity is partially funded by the European Community under its Seventh Framework Programme through the Reducing Internet Transport Latency (RITE) project (ICT-317700).

---

From: Varun Singh <[email-masked]>
Date: Mon, 6 May 2013 19:39:31 +0300

Hi all,

Similar to Michael Welzl's session, we (Joerg, Colin and I) too have a
special session planned for WebRTC at IEEE Packet Video 2013. It is
WebRTC-related
but not congestion control. Hence, if the topic is of interest to you and
you'd plan to
submit a paper to the session, please send us:

- Title of the paper:
- Abstract:
- List of authors:
by next monday (13. May).

Note however, the actual deadline is 10. June

details follow:
----

WebRTC 2.0 (Special Session at IEEE PV 2013)

The standardization of version 1.0 of Web Real-Time Communications (WebRTC)
is
expected to complete by the end of the year; yet many technical and
especially
research challenges remain open -- and we expect new ones to arise with
deployment experience. With WebRTC and the accompanying APIs, application
developers have the opportunity to add new immersive features (gestures,
real-time communication, peer-to-peer) within their web applications. Apart
from the multimedia aspect, WebRTC permits sending data packets between the
peers using 'Data Channels', which opens the door for innovative apps and
new
research ideas.

The WebRTC API is low-level, which has given rise to many WebRTC Javascript
SDKs. These SDKs abstract (for the application developer) from the intricate
state-machine of the underlying media and network stack. However, the issues
the WebRTC application developers still have to deal with are related to
call
management, service performance and quality monitoring, and service
scalability. Consequently, the SDK providers have to deal with maintaining
interoperability with other WebRTC-capable endpoints, evolution of the
WebRTC
API and domain-specific frameworks and SDKs.

Mobile devices are a big market opportunity and challenge, WebRTC is no
exception. The wireless environment and mobility in general pose some
interesting problems: call setup, mobility, handover, etc. In general, the
WebRTC-enabled services and legacy services (SIP/XMPP-enabled, Skype) face
the
challenge of interoperability, especially since WebRTC does not standardize
a
signaling protocol. Lastly, Internet Service Providers (ISPs, both mobile
and
broadband) have to operate in the tension between present and future
services.
They need to be able to engineer their network in a way supportive for
transmitting the WebRTC flows at an unprecedented scale.

The objective of this special session is to bring together researchers and
practitioners in the area of real-time communications, multimedia systems,
transport protocols, broadband and mobile networks, and multimedia
applications to advance the state of research in real-time communication. We
solicit original contributions on advanced topics in web-based real-time
multimedia communications.

Topics of particular interest include, but are not limited to

- Mobile WebRTC
- Telepresence
- Architectures for Media Transport, Multiplexing, and Naming
- Identity Management and Security
- Operations and Management
- Understanding QoE and Performance of WebRTC
- WebRTC Applications
- Deployment Issues
- Non-media applications or Data Channels
- WebRTC and economy of scale.

------------------------------------------------------------------------------
Varun Singh,   Aalto University, [email-masked]
Jörg Ott,      Aalto University, [email-masked]
Colin Perkins, University of Glasgow, [email-masked]

On Mon, May 6, 2013 at 4:51 PM, Michael Welzl <[email-masked]> wrote:

> Dear all,
>
> Stein Gjessing and I are planning to arrange a special session dedicated
> to RMCAT at IEEE Packet Video 2013: http://pv2013.itec.aau.at
>
> Our proposal for a special session, described below, has been tentatively
> accepted by the organizers of IEEE Packet Video 2013. It's not hard to see
> that this is indeed pretty RMCAT focused  :-)   For final acceptance of our
> session, we need to have a list of committed papers already at this stage.
> Hence, if the topic below is of interest to you, and you plan to submit a
> paper to this special session, please send us:
> - authors
> - title
> - abstract
> The real deadline for paper submission would then be 10 June. Again, note
> that this is not a CFP yet, it's a pre-CFP-call-of-interest... in a way,
> informing us that you're planning to submit a paper is similar to
> registering a paper before submitting the full thing, I'd say.
>
> Cheers,
> Michael
>
>
-- 
http://www.netlab.tkk.fi/~varun/