Subject: [rmcat] Sprout - an algorithm worth checking out?

From: Harald Alvestrand <[email-masked]>
Date: Mon, 06 May 2013 14:01:00 +0200

I was pointed to this paper some time ago, but only found time to look 
at it today:

https://www.usenix.org/conference/nsdi13/stochastic-forecasts-achieve-high-throughput-and-low-delay-over-cellular-networks

 From the abstract:

" The key idea of Sprout is to adapt the sending rate to roughly match 
the current cellular network capacity while not overshooting it; by 
achieving this objective, Sprout can both maintain high throughput and 
avoid queuing delays in the network. To achieve this goal, Sprout models 
the cellular link using a Poisson process with an underlying rate which 
may change over time. Sprout models the evolution of the probability 
distribution on the underlying rate using Brownian motion, with which 
Sprout proposes a control protocol to determine the current transmission 
rate for an end-point. "

This seems to be very much within the scope of what RMCAT should be 
aiming for.

Apologies if it is a duplicate.

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Mon, 6 May 2013 14:08:33 +0200 (CEST)

Keith Winstein, the main author of the work, was also at the congestion control workshop last year and briefly mentioned his work there.

Keith maintains a Webpage, which contains more information about the project (including a video recording of his talk, source code, and data):

http://alfalfa.mit.edu/

Definitely workwhile to look at his approach or to reach out to him.

Ciao

Hannes

Gesendet: Montag, 06. Mai 2013 um 14:01 Uhr

Von: "Harald Alvestrand" <[email-masked]>

An: [email-masked]

Betreff: [rmcat] Sprout - an algorithm worth checking out?

I was pointed to this paper some time ago, but only found time to look at it today:

>From the abstract:

" The key idea of Sprout is to adapt the sending rate to roughly match the current cellular network capacity while not overshooting it; by achieving this objective, Sprout can both maintain high throughput and avoid queuing delays in the network. To achieve this goal, Sprout models the cellular link using a Poisson process with an underlying rate which may change over time. Sprout models the evolution of the probability distribution on the underlying rate using Brownian motion, with which Sprout proposes a control protocol to determine the current transmission rate for an end-point. "

This seems to be very much within the scope of what RMCAT should be aiming for.

---

From: Dan Weber <[email-masked]>
Date: Mon, 6 May 2013 09:01:37 -0600

I've been keeping in touch with Keith on this very topic.  Pretty sure he's
also a subscriber to this list.

Dan
On May 6, 2013 6:08 AM, "Hannes Tschofenig" <[email-masked]>
wrote:

> Keith Winstein, the main author of the work, was also at the congestion
> control workshop last year and briefly mentioned his work there.
> Keith maintains a Webpage, which contains more information about the
> project (including a video recording of his talk, source code, and data):
> http://alfalfa.mit.edu/
>
> *Gesendet:* Montag, 06. Mai 2013 um 14:01 Uhr
> *Von:* "Harald Alvestrand" <[email-masked]>
> *An:* [email-masked]
> *Betreff:* [rmcat] Sprout - an algorithm worth checking out?
> " The key idea of Sprout is to adapt the sending rate to roughly match the
> current cellular network capacity while not overshooting it; by achieving
> this objective, Sprout can both maintain high throughput and avoid queuing
> delays in the network. To achieve this goal, Sprout models the cellular
> link using a Poisson process with an underlying rate which may change over
> time. Sprout models the evolution of the probability distribution on the
> underlying rate using Brownian motion, with which Sprout proposes a control
> protocol to determine the current transmission rate for an end-point. "
>