Subject: [rmcat] Fwd: congestion control in WebRTC

From: manphis chen <[email-masked]>
Date: Thu, 13 Jun 2013 14:46:09 +0800

---------- Forwarded message ----------
From: manphis chen <[email-masked]>
Date: 2013/6/13
Subject: congestion control in WebRTC
To: [email-masked]

Dear all,

Recently I am investigating the feedback mechanism for rate control in
webrtc.

Does the receiver use RTCP to inform the sender about the information such
as available bandwidth, lossy ratio, .., etc.?

I saw the packet format by wireshark, and saw that there is extra
information appended on the SR (Sender Report) of RTCP, but wireshark
cannot recognize it.

Does anyone have the same experience?
Or is there any document describing the details of the feedback mechanism
or the format of the feedback packets in webrtc?

Many thanks

BRs
manphis

-- 
Wireless Communication and Mobile Computing Research Group Laboratory
TEL:(886)-2-23625336-448
Dept. of Computer Science and Information Engineering
National Taiwan University, Taipei, Taiwan

---

From: manphis chen <[email-masked]>
Date: Thu, 13 Jun 2013 14:44:33 +0800

Dear all,

Many thanks

BRs
manphis

---

From: Varun Singh <[email-masked]>
Date: Thu, 13 Jun 2013 12:05:46 +0300

Comments inline

> as available bandwidth, lossy ratio, .., etc.?

Currently, endpoints send RTCP RR and Chrome possibly sends REMB. Ask on
the discuss-webrtc mailing list.

> information appended on the SR (Sender Report) of RTCP, but wireshark
The SR is typically followed by an RR, SDES, AFAIR chrome also sends some
subset of RFC3611 XRBLOCK (voip stats if I remember correctly).

> or the format of the feedback packets in webrtc?
See http://tools.ietf.org/html/draft-ietf-rtcweb-rtp-usage for details on
RTP and RTCP features for WebRTC.

-- 
http://www.netlab.tkk.fi/~varun/

---

From: manphis chen <[email-masked]>
Date: Thu, 13 Jun 2013 18:45:19 +0800

Thanks for the reply.

I have another question.
Is "TMMBR" also appended to SR (or RR) for congestion control?

thanks

2013/6/13 Varun Singh <[email-masked]>

> Comments inline
>
>
> On Thu, Jun 13, 2013 at 9:44 AM, manphis chen <[email-masked]>wrote:
>
>>
>> Dear all,
>>
>> Does the receiver use RTCP to inform the sender about the information
>> such as available bandwidth, lossy ratio, .., etc.?
>>
>

---

From: Saverio Mascolo <[email-masked]>
Date: Sat, 15 Jun 2013 21:40:16 +0200

Dear all,

in the paper below you may find a description, based  on both the ietf
draft and  the code (indeed the draft is not completely clear) along with
an experimental evaluation of the google congestion control:

http://c3lab.poliba.it/images/0/07/Webrtc_cc-Fhcmn2013.pdf

All comments are welcome!

Thanks for the attention and best regards,
Saverio

-- 
Saverio Mascolo, Full Professor
Dipartimento di Elettrotecnica ed Elettronica
Politecnico di Bari
Via Orabona 4, 70125 Bari Italy
Tel. +39 080 5963621
Fax. +39 080 5963410
email:[email-masked]

http://c3lab.poliba.it

=================================
 This message may contain confidential and/or legally privileged
information.
  If you are not the intended recipient of the message, please destroy it.
 Any unauthorized dissemination, distribution, or copying of the material in
 this message, and any attachments to the message, is strictly forbidden.