Subject: [rmcat] Fwd: New Version Notification for draft-welzl-rmcat-coupled-cc-03.txt

From: Michael Welzl <[email-masked]>
Date: Wed, 7 May 2014 13:11:43 +0200

Dear all,

We have submitted an update of our coupled congestion control draft. This now includes the new algorithm which should reduce queuing delay and packet loss, as documented in http://safiquli.at.ifi.uio.no/paper/fse-tech-report.pdf

At this point, we'd really appreciate it if folks would take a look and comment   :-)

Cheers,
Michael

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-welzl-rmcat-coupled-cc-03.txt
> Date: 7. mai 2014 13:08:05 GMT+02:00
> To: Michael Welzl <[email-masked]>, "Safiqul Islam" <[email-masked]>, "Stein Gjessing" <[email-masked]>, "Michael Welzl" <[email-masked]>, Safiqul Islam <[email-masked]>, Stein Gjessing <[email-masked]>
> 
> 
> A new version of I-D, draft-welzl-rmcat-coupled-cc-03.txt
> has been successfully submitted by Michael Welzl and posted to the
> IETF repository.
> 
> Name:		draft-welzl-rmcat-coupled-cc
> Revision:	03
> Title:		Coupled congestion control for RTP media
> Document date:	2014-05-07
> Group:		Individual Submission
> Pages:		19
> URL:            http://www.ietf.org/internet-drafts/draft-welzl-rmcat-coupled-cc-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-welzl-rmcat-coupled-cc/
> Htmlized:       http://tools.ietf.org/html/draft-welzl-rmcat-coupled-cc-03
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-welzl-rmcat-coupled-cc-03
> 
> Abstract:
>   When multiple congestion controlled RTP sessions traverse the same
>   network bottleneck, it can be beneficial to combine their controls
>   such that the total on-the-wire behavior is improved.  This document
>   describes such a method for flows that have the same sender, in a way
>   that is as flexible and simple as possible while minimizing the
>   amount of changes needed to existing RTP applications.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Michael Welzl <[email-masked]>
Date: Thu, 22 May 2014 15:08:03 +0200

ping …

---

From: Dave Taht <[email-masked]>
Date: Thu, 22 May 2014 07:11:40 -0700

Is there some reason why you do not use "weighted fair queuing" as
analogous to "controllable fairness with prioritization" or cite any
of that liturature?

While being able to adjust the fairness dynamically is a good thing,
the root technique is wfq, in my reading.

re:

1 This (13 packet queue length) is based on the bandwidth
delay product (BDP). We repeated our tests with dif-
ferent queue lengths and found no significant differences.

What different queue lengths? Against what competing traffic?

On Wed, May 7, 2014 at 4:11 AM, Michael Welzl <[email-masked]> wrote:
> Dear all,
>
> We have submitted an update of our coupled congestion control draft. This
> now includes the new algorithm which should reduce queuing delay and packet
> loss, as documented in
> http://safiquli.at.ifi.uio.no/paper/fse-tech-report.pdf
>
> To: Michael Welzl <[email-masked]>, "Safiqul Islam"
> <[email-masked]>, "Stein Gjessing" <[email-masked]>, "Michael Welzl"
> <[email-masked]>, Safiqul Islam <[email-masked]>, Stein Gjessing
> <[email-masked]>
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-welzl-rmcat-coupled-cc-03.txt
> Status:
> https://datatracker.ietf.org/doc/draft-welzl-rmcat-coupled-cc/
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-welzl-rmcat-coupled-cc-03
>
> Abstract:

-- 
Dave Täht

NSFW: https://w2.eff.org/Censorship/Internet_censorship_bills/russell_0296_indecent.article

---

From: Michael Welzl <[email-masked]>
Date: Thu, 22 May 2014 18:50:38 +0200

Hey,

Thanks for that - glad see some interest at last!

In line:

> the root technique is wfq, in my reading.

Well, wfq is about assigning a flow its weighted portion of the total weight; this is what step (c) in our two active example algorithms does, and it's also what wfq does. We didn't cite wfq because we don't think of this as a scheduler, but since the active algorithm assigns rate updates to all flows whenever any flow updates its rate, it's really pretty much the same as a scheduler in fact.

That's all - no major other reasons. We can put a wfq citation in there if that makes you happy  :)

> What different queue lengths? Against what competing traffic?

I'll leave that for Safiqul to answer (he's got all the details).

Cheers,
Michael

---

From: Safiqul Islam <[email-masked]>
Date: Thu, 22 May 2014 20:34:14 +0200

Hello,

Thanks for your questions. 

Inline: 

> I'll leave that for Safiqul to answer (he's got all the details).

We ran our experiments while varying the queue lengths from half a BDP to one and a half a BDP in order to see if the effects were similar or not. Flows were competing with each other, and there was no cross-traffic. Since we saw no change, we didn't stretch to smaller or larger values because they didn't seem to have an effect on our algorithm (there will probably be lower and upper bounds where the congestion controllers don't properly work anymore, but that's then a specialty of the congestion controller, not our coupling algorithm).

Cheers,
Safiqul

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Fri, 23 May 2014 10:28:31 +0200

> We ran our experiments while varying the queue lengths from half a BDP to one and a half a BDP in order to see if the effects were similar or not. Flows were competing with each other, and there wa…

Hi Safiqul,

May I ask you which tools are you using to simulate changing conditions? 
I would like to run also some experiments on the new congestion algorithms.

Best regards
Sergio

---

From: Safiqul Islam <[email-masked]>
Date: Fri, 23 May 2014 13:46:37 +0200

Hello Sergio,

We used ns-2 for simulations, and changed the parameters according to our needs.

Regards,
Safiqul

On 23. mai 2014, at 10:28, Sergio Garcia Murillo <[email-masked]> wrote:

> May I ask you which tools are you using to simulate changing conditions? I would like to run also some experiments on the new congestion algorithms.
> 
> Best regards
> Sergio
>