Subject: [rmcat] WGLC comments on draft-ietf-rmcat-coupled-cc-03

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 8 Sep 2016 13:16:55 +0000

Hi

I have read through draft-ietf-rmcat-coupled-cc-03, just a few comments.

List of variables :
I find myself scrolling forth and back in the document I search for an explanation to all the variables, perhaps a dedicated list of variables and their meaning would be good ?

Section 5.3.1 :
My understanding here is that this algorithm does assume that the media coder will produce an output bitrate that is FSE_R. In reality the output rate from a video coder may be considerably lower than the target if for instance the image is more or less static. I guess that the means that bandwidth becomes unallocated or ? .
It seems like this "underutilization problem" is  discussed in Appendix B where the "desired rate" is mention, is this DR to be set equal to the video coder output rate ?

/Ingemar
==================================
Ingemar Johansson  M.Sc.
Master Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

  And we cannot reach any higher
If we can't deal with ordinary love
                 U2
==================================

---

From: Michael Welzl <[email-masked]>
Date: Fri, 9 Sep 2016 11:39:42 +0200

Hi Ingemar!

Thanks for reading our draft. Answers in line:

> On 08 Sep 2016, at 15:16, Ingemar Johansson S <[email-masked]> wrote:
> 
> Hi
>  

Agreed, we will do that.

> My understanding here is that this algorithm does assume that the media coder will produce an output bitrate that is FSE_R. In reality the output rate from a video coder may be considerably lower t…

Yes.

> It seems like this “underutilization problem” is  discussed in Appendix B where the “desired rate” is mention, is this DR to be set equal to the video coder output rate ?

Yes.

We wanted to deal with the case of a video coder sending less than allowed from the start; the "desired rate" was therefore a part of the main text from the beginning.
Later, upon request to simplify our algorithm, we moved it to the appendix.

We do think that this would be a good thing to address as the document moves to PS, so we suggest to insert, in section 7 ("Expected feedback from experiments"):
"Experiments should investigate cases where the media coder's output rate is below the rate that is calculated by the coupling algorithm (FSE_R in algorithms 1 and 2, section 5.3)."

Cheers,
Michael

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 15 Sep 2016 08:50:18 +0000

Hi

The suggested addition to section 7 sounds good.

Regards
/Ingemar

> -----Original Message-----
> From: Michael Welzl [mailto:[email-masked]]
> Sent: den 9 september 2016 11:40
> To: Ingemar Johansson S <[email-masked]>
> Cc: rmcat WG <[email-masked]>
> Subject: Re: [rmcat] WGLC comments on draft-ietf-rmcat-coupled-cc-03
> 
> Hi Ingemar!
> 
> > On 08 Sep 2016, at 15:16, Ingemar Johansson S
> <[email-masked]> wrote:
> >
> > Hi
> >
> > I find myself scrolling forth and back in the document I search for an
> explanation to all the variables, perhaps a dedicated list of variables and their
> meaning would be good ?
> 
> Agreed, we will do that.
> 
> 
> > Section 5.3.1 :
> > My understanding here is that this algorithm does assume that the media
> coder will produce an output bitrate that is FSE_R. In reality the output rate
> from a video coder may be considerably lower than the target if for instance
> the image is more or less static. I guess that the means that bandwidth
> becomes unallocated or ? .
> 
> Yes.
> 
> 
> > It seems like this "underutilization problem" is  discussed in Appendix B
> where the "desired rate" is mention, is this DR to be set equal to the video
> coder output rate ?
> 
> Yes.
> 
> We wanted to deal with the case of a video coder sending less than allowed
> from the start; the "desired rate" was therefore a part of the main text from
> the beginning.
> We do think that this would be a good thing to address as the document
> moves to PS, so we suggest to insert, in section 7 ("Expected feedback from
> experiments"):
> "Experiments should investigate cases where the media coder's output rate
> is below the rate that is calculated by the coupling algorithm (FSE_R in
> algorithms 1 and 2, section 5.3)."
> 
> Cheers,
> Michael