Subject: [rmcat] I-D Action: draft-ietf-rmcat-nada-03.txt

From: [email-masked]
Date: Sun, 18 Sep 2016 20:25:59 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the RTP Media Congestion Avoidance Techniques of the IETF.

        Title           : NADA: A Unified Congestion Control Scheme for Real-Time Media 
        Authors         : Xiaoqing Zhu
                          Rong Pan
                          Michael A. Ramalho
                          Sergio Mena de la Cruz
                          Paul E. Jones
                          Jiantao Fu
                          Stefano D'Aronco
                          Charles Ganzhorn
	Filename        : draft-ietf-rmcat-nada-03.txt
	Pages           : 26
	Date            : 2016-09-18

Abstract:
   This document describes NADA (network-assisted dynamic adaptation), a
   novel congestion control scheme for interactive real-time media
   applications, such as video conferencing.  In the proposed scheme,
   the sender regulates its sending rate based on either implicit or
   explicit congestion signaling, in a unified approach.  The scheme can
   benefit from explicit congestion notification (ECN) markings from
   network nodes.  It also maintains consistent sender behavior in the
   absence of such markings, by reacting to queuing delays and packet
   losses instead.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rmcat-nada/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-rmcat-nada-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rmcat-nada-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Mon, 19 Sep 2016 03:41:32 +0000

Hi Everyone, 

Here is an updated draft on NADA.  Main changes include: 

* Minor algorithm update in Sec. 4.2: more clear specification on when to apply the non-linear warping in Eq. (1); also a  slightly simplified non-linear warping function; 

* Corrected previous calculation errors in feedback message requirement (Sec 5.3) and example feedback overhead calculation (Sec. 6.3, second paragraph).  

* Added a new section (Sec 8) on suggested experiments. 

With the changes above, I believe the draft is ready for WGLC. As always, feedback from the WG is appreciated. 

BTW,  one additional change I would like to make at some point, but have deferred for now, is to realign terminology of this draft to the new framework document. Since some revisions are pending for the framework document, it might make sense to defer those changes till when the draft is close to final publication. Or, if the WG (or chairs) prefer that we align the terminologies (between NADA draft and framework document) now, I will be happy to push out a revision before WGLC.  Inputs?  

Thanks,
Xiaoqing

________________________________________
From: rmcat <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Sunday, September 18, 2016 10:25 PM
To: [email-masked]
Cc: [email-masked]
Subject: [rmcat] I-D Action: draft-ietf-rmcat-nada-03.txt

Abstract: