Subject: Re: [rmcat] WG last call: draft-ietf-rmcat-eval-criteria-07.txt

From: Colin Perkins <[email-masked]>
Date: Sat, 14 Jul 2018 13:40:01 +0200

[As an individual participant]

I’ve read this draft, and have some relatively minor, and primarily editorial, comments:

Section 3 begins “Each experiment is expected to…” but the draft hasn’t yet introduced the idea that there are some experiments that need to be completed. 
Rather than talk about “RMCAT proposals”, “RMCAT flows”, etc., discuss “proposed RTP congestion control algorithms”, “congestion controlled RTP flows”, and so on. The RFC will live longer than the RMCAT working group.
Section 3: bullet 10 should be rephrased for clarity.
Does Section 3.1 need to describe the precise format, or just the information to be logged? Does it matter that the file is CSV format?
Section 4.1: The introductory text only talks about high latency links, then gives examples covering a range of latencies. Expands remarks “, as well as low-latency links”
Section 4.2: might be appropriate to add some motivating remarks.
Section 4.3: add some remarks to motivate drop-tail?
Section 4.5.3: clarify if this recommended distribution applies to both sections 4.5.1 and 4.5.2.
Section 6.1: first paragraph ends mid-sentence.
Section 6.3: is it worth mentioning that QUIC flows use UDP, but are expected to have dynamics that look a lot like TCP, so don’t need to be explicitly included here?
Section 7: security needs to be discussed. Maybe point out denial-of-service issues due to lack of congestion control, or denial-of-service on the congestion controlled flow due to spoofing of control signals, and state that the candidate algorithms should consider. The only specific security issue I can think of the these criteria is checking that the algorithm works as expected in these cases.
Please spell-check the draft.

Cheers,
Colin

> On 20 Jun 2018, at 10:46, Colin Perkins <[email-masked]> wrote:
> 
> This is to announce a working group last call on “Evaluating Congestion Control for Interactive Real-time Media” (draft-ietf-rmcat-eval-criteria-07). 
> 
> Please send any final comments to the working group mailing list and the authors by 20 July 2018 (the date of the RMCAT session at IETF 102). If no substantive comments are received by that time, we intend to submit this draft to the IESG for publication as an Informational RFC.
> 
> Colin
> 
> 
> 
>> On 2 May 2018, at 11:52, Colin Perkins <[email-masked]> wrote:
>> 
>> Jörg – thanks for updating this draft!
>> 
>> Any comments from the group before we progress this?
>> 
>> Colin
>> 
>> 
>> 
>>> On 1 May 2018, at 19:57, [email-masked] wrote:
>>> 
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>> This draft is a work item of the RTP Media Congestion Avoidance Techniques WG of the IETF.
>>> 
>>>      Title           : Evaluating Congestion Control for Interactive Real-time Media
>>>      Authors         : Varun Singh
>>>                        Joerg Ott
>>>                        Stefan Holmer
>>> 	Filename        : draft-ietf-rmcat-eval-criteria-07.txt
>>> 	Pages           : 16
>>> 	Date            : 2018-05-01
>>> 
>>> Abstract:
>>> The Real-time Transport Protocol (RTP) is used to transmit media in
>>> telephony and video conferencing applications.  This document
>>> describes the guidelines to evaluate new congestion control
>>> algorithms for interactive point-to-point real-time media.
>>> 
>>> 
>>> The IETF datatracker status page for this draft is:
>>> https://datatracker.ietf.org/doc/draft-ietf-rmcat-eval-criteria/
>>> 
>>> There are also htmlized versions available at:
>>> https://tools.ietf.org/html/draft-ietf-rmcat-eval-criteria-07
>>> https://datatracker.ietf.org/doc/html/draft-ietf-rmcat-eval-criteria-07
>>> 
>>> A diff from the previous version is available at:
>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-rmcat-eval-criteria-07
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>> 
>> 
>> 
>> 
>> -- 
>> Colin Perkins
>> https://csperkins.org/
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Joerg Ott <[email-masked]>
Date: Mon, 16 Jul 2018 08:17:30 -0400

Hi Colin,

thank for the comments -- let me see if I manage to submit a revised
draft during this week.

Cheers,
Jörg

On 14.07.18 07:40, Colin Perkins wrote:
>   * Section 3 begins “Each experiment is expected to…” but the draft
>     hasn’t yet introduced the idea that there are some experiments that
>     need to be completed.
>   * Rather than talk about “RMCAT proposals”, “RMCAT flows”, etc.,
>     discuss “proposed RTP congestion control algorithms”, “congestion
>     controlled RTP flows”, and so on. The RFC will live longer than the
>     RMCAT working group.
>   * Section 3: bullet 10 should be rephrased for clarity.
>   * Does Section 3.1 need to describe the precise format, or just
>     the information to be logged? Does it matter that the file is CSV
>     format?
>   * Section 4.1: The introductory text only talks about high latency
>     links, then gives examples covering a range of latencies. Expands
>     remarks “, as well as low-latency links”
>   * Section 4.2: might be appropriate to add some motivating remarks.
>   * Section 4.3: add some remarks to motivate drop-tail?
>   * Section 4.5.3: clarify if this recommended distribution applies to
>     both sections 4.5.1 and 4.5.2.
>   * Section 6.1: first paragraph ends mid-sentence.
>   * Section 6.3: is it worth mentioning that QUIC flows use UDP, but
>     are expected to have dynamics that look a lot like TCP, so don’t
>     need to be explicitly included here?
>   * Section 7: security needs to be discussed. Maybe point out
>     denial-of-service issues due to lack of congestion control, or
>     denial-of-service on the congestion controlled flow due to spoofing
>     of control signals, and state that the candidate algorithms should
>     consider. The only specific security issue I can think of the these
>     criteria is checking that the algorithm works as expected in these
>     cases.
>   * Please spell-check the draft.
> 
> 
> Cheers,
> Colin
> 
> 
> 
>> On 20 Jun 2018, at 10:46, Colin Perkins <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> This is to announce a working group last call on “Evaluating 
>> Congestion Control for Interactive Real-time Media” 
>> (draft-ietf-rmcat-eval-criteria-07).
>>
>> Please send any final comments to the working group mailing list and 
>> the authors by 20 July 2018 (the date of the RMCAT session at IETF 
>> 102). If no substantive comments are received by that time, we intend 
>> to submit this draft to the IESG for publication as an Informational RFC.
>>
>> Colin
>>
>>
>>
>>> On 2 May 2018, at 11:52, Colin Perkins <[email-masked] 
>>> <mailto:[email-masked]>> wrote:
>>>
>>>> On 1 May 2018, at 19:57, [email-masked] 
>>>> <mailto:[email-masked]> wrote:
>>>>
>>>>