Subject: Re: [rmcat] WG last call: draft-ietf-rmcat-video-traffic-model-04

From: Fu Jiantao <[email-masked]>
Date: Thu, 12 Jul 2018 18:59:39 -0700

Hi,

  Some comments below:

  1. In Abstract

"

   The second model is trace-
   driven, and emulates the encoder output based on actual encoded video
   frame sizes from a high-resolution test sequence.

"

is that based on both encoded video frame interval and frame size?

2. In section 4, in the graph and description is misleading to me, the
synthetic video codec takes raw video frames, but not in realtime like real
video codec,  it's two steps process, the first step is to

 1) for statistic model, fitting from emperical data to get parameters

 2) for trace-based model, gather meta data like frame size, frame type etc

The first step is like pre-process, and the second step is to feed that
into the synthetic video codec in realtime.

3. In section 4. "Frame resolution XY", that is actually the target frame
resolution, right? this may also be affected by subscription from remote
receiver, for example when remote is a mobile client with a small screen.

- Jeromy

Colin Perkins <[email-masked]> 于2018年6月20日周三 上午1:49写道：

> This is to announce a working group last call on “Modeling Video Traffic
> Sources for RMCAT Evaluations” (draft-ietf-rmcat-video-traffic-model-04).
>
> Please send any final comments to the working group mailing list and the
> authors by 20 July 2018 (the date of the RMCAT session at IETF 102). If no
> substantive comments are received by that time, we intend to submit this
> draft to the IESG for publication as an Informational RFC.
>
> Colin (for the RMCAT chairs)
>
>
>
> --
> Colin Perkins
> https://csperkins.org/
>
>

---

From: Colin Perkins <[email-masked]>
Date: Sun, 15 Jul 2018 15:54:48 -0400

Thanks for the comments!

After reading it again, I’d also note that:

The draft talks about “RMCAT algorithms”, but should probably talk about “RTP congestion control algorithms”, since the final RFC will outlive the RMCAT working group.

The draft needs a security considerations section. I can’t of anything to include other than a statement about the importance of congestion control to stable operation of the network, and for RTP flows the importance of testing congestion control with realistic traffic.

Cheers,
Colin

> On 12 Jul 2018, at 21:59, Fu Jiantao <[email-masked]> wrote:
> 
> Hi, 
> 
>   Some comments below:
> 
>   1. In Abstract 
> 
> "
> 2. In section 4, in the graph and description is misleading to me, the synthetic video codec takes raw video frames, but not in realtime like real video codec,  it's two steps process, the first step is to 
> 
> The first step is like pre-process, and the second step is to feed that into the synthetic video codec in realtime.
> 
> 3. In section 4. "Frame resolution XY", that is actually the target frame resolution, right? this may also be affected by subscription from remote receiver, for example when remote is a mobile client with a small screen.
> 
> - Jeromy
> 
> Colin Perkins <[email-masked] <mailto:[email-masked]>> 于2018年6月20日周三 上午1:49写道：
> This is to announce a working group last call on “Modeling Video Traffic Sources for RMCAT Evaluations” (draft-ietf-rmcat-video-traffic-model-04). 
> 
> Please send any final comments to the working group mailing list and the authors by 20 July 2018 (the date of the RMCAT session at IETF 102). If no substantive comments are received by that time, we intend to submit this draft to the IESG for publication as an Informational RFC.
> 
> https://csperkins.org/ <https://csperkins.org/>
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Thu, 19 Jul 2018 22:50:24 +0000

Thanks, Colin, for your input. We have updated the draft to version -05 accordingly. Please see detailed responses below inline (tagged [XZ]).

Best,

Xiaoqing

________________________________
From: Colin Perkins <[email-masked]>
Sent: Sunday, July 15, 2018 2:54 PM
To: Fu Jiantao
Cc: rmcat WG; [email-masked]
Subject: Re: [rmcat] WG last call: draft-ietf-rmcat-video-traffic-model-04

Thanks for the comments!

After reading it again, I'd also note that:

The draft talks about "RMCAT algorithms", but should probably talk about "RTP congestion control algorithms", since the final RFC will outlive the RMCAT working group.

[XZ]  Good point. I've replaced the mention of RMCAT in the main text to "RTP congestion control algorithms.".   Not sure what to do with several of the references though.  For our own github code on "Syncodec" we can change the title later.  For the pointers to previous interim presentations: can we leave it as is?

[XZ]  These questions can probably be deferred till the draft is in shepherd mode?

The draft needs a security considerations section. I can't of anything to include other than a statement about the importance of congestion control to stable operation of the network, and for RTP flows the importance of testing congestion control with realistic traffic.

[XZ] Thanks for the suggestion. I've added on section with the wording below:

 It is important to evaluate RTP-based congestion control schemes
   using realistic traffic patterns, so as to ensure stable operations
   of the network.  Therefore, it is RECOMMENDED that candidate RTP-
   based congestion control algorithms be tested using the video traffic
   models presented in this draft before wide deployment over the
   Internet.?

Cheers,
Colin

On 12 Jul 2018, at 21:59, Fu Jiantao <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

  Some comments below:

  1. In Abstract

"

"

- Jeromy

Colin Perkins <[email-masked]<mailto:[email-masked]>> ?2018?6?20??? ??1:49??:
This is to announce a working group last call on "Modeling Video Traffic Sources for RMCAT Evaluations" (draft-ietf-rmcat-video-traffic-model-04).

--
Colin Perkins
https://csperkins.org/

--
Colin Perkins
https://csperkins.org/

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Thu, 19 Jul 2018 22:58:15 +0000

Hi Jeromy,

Many thanks for your review comments. We've updated the draft to version -05 accordingly. Please see detailed replies as below (tagged [XZ]).

Best,

Xiaoqing

________________________________
From: Fu Jiantao <[email-masked]>
Sent: Thursday, July 12, 2018 8:59 PM
To: Colin Perkins
Cc: rmcat WG; [email-masked]
Subject: Re: [rmcat] WG last call: draft-ietf-rmcat-video-traffic-model-04

Hi,

  Some comments below:

  1. In Abstract

"

"

[XZ]  We've double checked both our detailed description for in Section 6 as well as the corresponding code implementation. Both indicate that for the trace-based model the the frame intervals are fixed according to the target FPS.

[XZ] Thanks for pointing this out. Agree that the original figure is misleading in showing "raw video frame" as input to the synthetic source. I've revised it to remove the "raw video frames" so that the figure depicts how the synthetic video traffic source interacts with other modules at the sender, in online operations.

[XZ] To keep the terminologies consistent, I've revised the text throughout to refer to the synthetic video traffic source as "synthetic video source" instead of "synthetic video encoder."

[XZ] Good point. I've updated the text to "Target frame resolution XY". Have also revised the description for that bullet item to also include destination device size as another factor influencing the frame resolution.

- Jeromy

--
Colin Perkins
https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Fri, 20 Jul 2018 12:20:26 -0400

Thanks - this all looks good.
Colin

> On 19 Jul 2018, at 18:50, Xiaoqing Zhu (xiaoqzhu) <xiaoqzhu=[email-masked]> wrote:
> 
> Thanks, Colin, for your input. We have updated the draft to version -05 accordingly.Please see detailed responses below inline (tagged [XZ]).
> 
> Best,
> Xiaoqing
> 
> From: Colin Perkins <[email-masked] <mailto:[email-masked]>>
> Cc: rmcat WG; [email-masked] <mailto:[email-masked]>
>    Internet.​
>> On 12 Jul 2018, at 21:59, Fu Jiantao <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi, 
>> 
>>   Some comments below:
>> 
>>   1. In Abstract 
>> 
>> "

-- 
Colin Perkins
https://csperkins.org/