Subject: Re: [rmcat] Ongoing working group last calls

From: Zaheduzzaman Sarker <[email-masked]>
Date: Fri, 7 Sep 2018 06:55:33 +0000

Hi chairs,

Regarding dtaft-rmcat-eval-test-06, we have received comments from algorithm developers who has used this draft to present results to the working group. Do you think that is enough? 

I am working on updating the draft to address the comments received, will submit a new version soon.

BR
Zahed

On 2018-08-06, 17:52, "rmcat on behalf of Colin Perkins" <[email-masked] on behalf of [email-masked]> wrote:

    RMCAT working group,
    
    As noted at the meeting in Montreal, the following drafts are in working group last call:
    
    - draft-ietf-rmcat-eval-criteria-07
    - draft-ietf-rmcat-eval-test-06
    - draft-ietf-rmcat-video-traffic-model-04
    
    All three working group last calls were due to conclude at that meeting, but we have not yet received sufficient reviews of these drafts to do so. 
    
    If we are to progress these drafts, we need additional reviews from working group members. Please, do read the drafts. If you have no comments and think the drafts are ready to progress, then please send a note to that effect. If you have comments, please do send them to the list.
    
    Thanks,
    Colin (as WG co-chair)

    -- 
    Colin Perkins
    https://csperkins.org/

---

From: "Holland, Jake" <[email-masked]>
Date: Tue, 11 Sep 2018 13:42:21 +0000

Hi, and sorry for the late response.

I think these are all basically fine, and I support progressing them, with minor edits. Sorry for the delayed response.

Major issues:
video-traffic-model: I noticed this is missing a security considerations section.

Minor issues:
In both eval-test and eval-criteria:
Stating that you didn't discuss security is not the same as discussing security.

The security considerations section says:
"Security issues have not been discussed in this memo."

It might be better to use a slightly different phrasing, such as:
"This document introduces no new security issues."

It might also be appropriate to add something like this in the eval-test security considerations:

"This document describes tests intended to run in a controlled lab environment. It's important to take appropriate caution to avoid leaking non-responsive traffic from unproven congestion avoidance techniques onto the open internet, otherwise the traffic may be interpreted by networks as an attack that may result in sanctions against the operator."

I also have a few other very minor editorial comments. I raise them in order to draw some focus to them, in case you have simple ideas on how to rephrase them, not because I think they require fixing in order to progress.

These are not objections, just observations of where I noticed anything that caused me any confusion. Accordingly, feel free and invited to fix them according to your best judgement, or to ignore them if you think that easy alternatives are equally confusing:

video-traffic-model:
- 5.2 and 7: the use of the word "transient" sometimes as a named flow state, sometimes as an adjective, and sometimes (as "transients") as an event that happens during a named flow state is a bit jarring. I think it's possible to figure out which is which from context, but it gave me a few moments of confusion, and might be helpful to remove the use where it's an adjective, and maybe be more clear about calling it a transient state, or a transient event.

eval-test:
- Abstract: The opening sentence is borderline on grammar, I think it probably could use an "and" after the comma.
- Abstract: The 2nd sentence is maybe better with just "test cases" instead of "the test cases", since the cases provided are not meant to be exhaustive.

Regards,
Jake

On 2018-08-06, 08:52, "Colin Perkins" <[email-masked]> wrote:

    RMCAT working group,

    

    Thanks,
    Colin (as WG co-chair)

    -- 
    Colin Perkins
    https://csperkins.org/

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Tue, 11 Sep 2018 14:17:45 +0000

Thanks Jake for your review of eval-test.

I intend to update the security consideration of the eval-test draft in the next revision with following -

" The evaluations of the test cases are intended to run in a controlled
   lab environment.  Hence, the applications, simulators and network
   nodes should be well-behaved and should not impact the desire
   results.  In case the evaluations are not done in a controlled
   environment, the security considerations in
   [I-D.ietf-rmcat-eval-criteria] and the relevant congestion control
   algorithms apply. It's important to take appropriate caution to avoid leaking non-responsive traffic from unproven congestion avoidance techniques onto the open internet."

BR

Zahed
On 2018-09-11, 15:43, "rmcat on behalf of Holland, Jake" <[email-masked] on behalf of jholland=[email-masked]> wrote:

    
    Major issues:
    
    Minor issues:

    

    
    
    video-traffic-model:
    
    eval-test:

    Regards,
    Jake

        RMCAT working group,

        

        Thanks,
        Colin (as WG co-chair)

        -- 
        Colin Perkins
        https://csperkins.org/

---

From: "Holland, Jake" <[email-masked]>
Date: Wed, 12 Sep 2018 18:15:26 +0000

Thanks Zahed, that works for me.

With one nit:
desire->desired

-Jake

On 2018-09-11, 07:18, "Zaheduzzaman Sarker" <[email-masked]> wrote:

    
    
    BR
    
    Zahed

        
        Major issues:
        
        Minor issues:

        

        
        
        video-traffic-model:
        
        eval-test:

        Regards,
        Jake

            RMCAT working group,

            

            Thanks,
            Colin (as WG co-chair)

            -- 
            Colin Perkins
            https://csperkins.org/