Subject: [rmcat] SCReAM GStreamer plugin

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 7 Feb 2019 12:16:32 +0000

Hi

A little info around the progress of SCReAM (RFC8298). 

The news is that there is now a SCReAM GStreamer plugin up and running. So
far the plugin is somewhat tied to the use of x264enc as the bitrate is set
via the “bitrate” property (vp8enc use “target-bitrate” for the same
property). The plugin is also sofar only for one media (video) and in
addition some clean-up is necessary to do away  with possible memory leaks.

A short test with a Logitech USB camera and two Ubuntu laptops give a camera
to eye latency of ~130ms.

The code for this plugin may be released later on depending on the interest.

/Ingemar

==================================

Ingemar Johansson  M.Sc. 

Master Researcher

Ericsson Research

Network Protocols & E2E Performance

Labratoriegränd 11

971 28, Luleå, Sweden

Phone +46-1071 43042

SMS/MMS +46-73 078 3289

[email-masked]

www.ericsson.com

   You never know what worse luck 

    your bad luck has saved you from

                   Cormac McCarty

==================================

---

From: Colin Perkins <[email-masked]>
Date: Thu, 7 Feb 2019 23:05:14 +0000

Hi Ingemar,

Thanks for the update – that’s good to hear. Would you expect to have performance results to discuss in Prague, or is that too early and still in the debugging phase?

Cheers,
Colin

> On 7 Feb 2019, at 12:16, Ingemar Johansson S <[email-masked]> wrote:
> 
> Hi
>  
> The news is that there is now a SCReAM GStreamer plugin up and running. So far the plugin is somewhat tied to the use of x264enc as the bitrate is set via the “bitrate” property (vp8enc use “target-bitrate” for the same property). The plugin is also sofar only for one media (video) and in addition some clean-up is necessary to do away  with possible memory leaks.
> A short test with a Logitech USB camera and two Ubuntu laptops give a camera to eye latency of ~130ms.
>  
> [email-masked] <mailto:[email-masked]>
> www.ericsson.com <http://www.ericsson.com/>
>  

-- 
Colin Perkins
https://csperkins.org/

---

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 8 Feb 2019 12:02:43 +0000

Hi

I would say that the code is stable enough to run atleast some of the wireline testcases when time permits. 

I don’t believe that I will attend IETF in a physical form but I guess that it is perhaps possible to make the presentation remotely?.

/Ingemar

From: Colin Perkins <[email-masked]> 
Sent: den 8 februari 2019 00:05
To: Ingemar Johansson S <[email-masked]>
Cc: [email-masked]
Subject: Re: [rmcat] SCReAM GStreamer plugin

Hi Ingemar,

Cheers,

Colin

 

On 7 Feb 2019, at 12:16, Ingemar Johansson S <[email-masked] <mailto:[email-masked]> > wrote:

Hi

/Ingemar

Ingemar Johansson  M.Sc. 

Master Researcher

Ericsson Research

Labratoriegränd 11

971 28, Luleå, Sweden

Phone +46-1071 43042

SMS/MMS +46-73 078 3289

 <mailto:[email-masked]> [email-masked]

 <http://www.ericsson.com/> www.ericsson.com

                   Cormac McCarty

-- 
Colin Perkins
https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Fri, 8 Feb 2019 12:11:59 +0000

Hi Ingemar,

If you have results, a remote presentation is certainly possible. It should also be possible to engage with the hackathon remotely, if it’s useful to try to interoperate with other implementations.

Cheers,
Colin

> On 8 Feb 2019, at 12:02, Ingemar Johansson S <[email-masked]> wrote:
> 
> Hi
>  
> On 7 Feb 2019, at 12:16, Ingemar Johansson S <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi
>  
> https://csperkins.org/ <https://csperkins.org/>