Subject: [rmcat] WGLC on draft-ietf-avtcore-cc-feedback-message-05

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 5 Dec 2019 07:30:00 +0000

Hello, all!

As we discussed in Singapore, this is to announce a Working Group Last Call for draft-ietf-avtcore-cc-feedback-05.

Please review this document and send comments to the AVT mailing list by Thursday, December 19, 2019.

If you review the document and have nothing to add, please let the list know that as well.

Thank you!

Roni Even

AVTCore co-chair

---

From: "Roni Even (A)" <[email-masked]>
Date: Tue, 10 Dec 2019 12:52:52 +0000

Hi,

Some comments as individual

1. in section 10 the registration of the SDP ccfb attribute need also to include mux category

2. In section 4 it is says  "It has been shown  [I-D.ietf-rmcat-rtp-cc-feedback<https://tools.ietf.org/html/draft-ietf-avtcore-cc-feedback-message-05#ref-I-D.ietf-rmcat-rtp-cc-feedback>] that in most cases a per frame feedback is a reasonable assumption on how frequent the RTCP feedback messages can be transmitted." later in the section it talks about 50-200msec and say that a value in this range need to be negotiated.  Looking at rmcat-rtp-cc-feedback I got the impression that a report per frame is recommended.

3. A nit - please expand RTS at first occurrence, it is expanded a bit later

Roni Even

From: avt [mailto:[email-masked]] On Behalf Of Roni Even (A)
Sent: Thursday, December 05, 2019 9:30 AM
To: [email-masked]
Cc: [email-masked]
Subject: [AVTCORE] WGLC on draft-ietf-avtcore-cc-feedback-message-05

Hello, all!

Thank you!

Roni Even

AVTCore co-chair

---

From: Colin Perkins <[email-masked]>
Date: Thu, 12 Dec 2019 19:16:16 +0000

> On 10 Dec 2019, at 12:52, Roni Even (A) <[email-masked]> wrote:
> 
> Hi,
>  

That attribute is registered by draft-ietf-mmusic-sdp-mux-attributes, which include the mux category. This draft is registering a parameter within that attribute.

> 2. In section 4 it is says  “It has been shown  [I-D.ietf-rmcat-rtp-cc-feedback <https://tools.ietf.org/html/draft-ietf-avtcore-cc-feedback-message-05#ref-I-D.ietf-rmcat-rtp-cc-feedback>] that in most cases a per frame feedback is a reasonable assumption on how frequent the RTCP feedback messages can be transmitted.“ later in the section it talks about 50-200msec and say that a value in this range need to be negotiated.  Looking at rmcat-rtp-cc-feedback I got the impression that a report per frame is recommended. 

I rephrased the section to:

   There is a trade-off between speed and accuracy of reporting, and the
   overhead of the reports.  [I-D.ietf-rmcat-rtp-cc-feedback] discusses
   this trade-off, suggests desirable RTCP feedback rates, and provides
   guidance on how to configure the RTCP bandwidth fraction, etc., to
   make appropriate use of the reporting block described in this memo.
   Specifications for RTP congestion control algorithms can also provide
   guidance.

   It is generally understood that congestion control algorithms work
   better with more frequent feedback.  However, RTCP bandwidth and
   transmission rules put some upper limits on how frequently the RTCP
   feedback messages can be sent from an RTP receiver to the RTP sender.
   It has been shown [I-D.ietf-rmcat-rtp-cc-feedback] that in most cases
   sending feedback one per frame is an upper bound before the reporting
   overhead becomes excessive.  Analysis [feedback-requirements] has
   also shown that candidate congestion control algorithms can operate
   with less frequent feedback, using a feedback interval range of
   50-200ms.  Applications need to negotiate an appropriate feedback
   interval at session setup.

The draft-ietf-rmcat-rtp-cc-feedback is trying to show that per-frame feedback is possible, with acceptable overhead, but unless the codec can adapt on a per frame basis, it’s not clear that such frequent feedback is necessary. This version is intended to give bounds, and encourage people to draft draft-ietf-rmcat-rtp-cc-feedback, which will be expanded to give more discussion over time. Does this clarify?

> 3. A nit – please expand RTS at first occurrence, it is expanded a bit late

Fixed.

Let us know when you want us to submit the revised draft.
Colin

> Roni Even
>  
>  
> From: avt [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Roni Even (A)
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>

-- 
Colin Perkins
https://csperkins.org/

---

From: "Roni Even (A)" <[email-masked]>
Date: Sun, 15 Dec 2019 07:59:49 +0000

Hi Colin,
The proposed text for section 4 looks OK
Roni Even as individual

As for submitting an updated draft please wait for the end of the WGLC (end of this week)

Roni Even as co-chair of AVTCore WG

From: Colin Perkins [mailto:[email-masked]]
Sent: Thursday, December 12, 2019 9:16 PM
To: Roni Even (A)
Cc: [email-masked]; [email-masked]
Subject: Re: [rmcat] WGLC on draft-ietf-avtcore-cc-feedback-message-05

On 10 Dec 2019, at 12:52, Roni Even (A) <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

2. In section 4 it is says  “It has been shown  [I-D.ietf-rmcat-rtp-cc-feedback<https://tools.ietf.org/html/draft-ietf-avtcore-cc-feedback-message-05#ref-I-D.ietf-rmcat-rtp-cc-feedback>] that in most cases a per frame feedback is a reasonable assumption on how frequent the RTCP feedback messages can be transmitted.“ later in the section it talks about 50-200msec and say that a value in this range need to be negotiated.  Looking at rmcat-rtp-cc-feedback I got the impression that a report per frame is recommended.

Fixed.

Roni Even

From: avt [mailto:[email-masked]] On Behalf Of Roni Even (A)
Sent: Thursday, December 05, 2019 9:30 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [AVTCORE] WGLC on draft-ietf-avtcore-cc-feedback-message-05

Hello, all!

Thank you!

Roni Even
AVTCore co-chair

--
Colin Perkins
https://csperkins.org/

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 16 Dec 2019 07:07:43 +0000

Hi

One comment related to the feedback interval. Even though SCReAM manages relatively sparse feedback at moderate bitrates, I have observed that at high bitrates (50+ Mbps) the feedback interval needs to go down to ~2ms. 

50Mbps means ~4000 packets/s and with a 2ms feedback interval this means one feedback every 8 RTP packets which, I would say is in the same ballpark as QUIC and TCP. 

In other words the feedback rate is much higher than every frame.

It is possible to reduce the feedback frequency in SCReAM with an increased headroom for the congestion window and packet pacing, the drawback is however that the delay jitter can then increase.

Regards
Ingemar

From: Roni Even (A) <[email-masked]> 
Sent: den 15 december 2019 09:00
To: Colin Perkins <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [rmcat] WGLC on draft-ietf-avtcore-cc-feedback-message-05

Hi Colin,

Roni Even as individual

From: Colin Perkins [mailto:[email-masked]] 
Sent: Thursday, December 12, 2019 9:16 PM
To: Roni Even (A)
Cc: [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Subject: Re: [rmcat] WGLC on draft-ietf-avtcore-cc-feedback-message-05

On 10 Dec 2019, at 12:52, Roni Even (A) <[email-masked] <mailto:[email-masked]> > wrote:

Hi,

2. In section 4 it is says  “It has been shown  [ <https://tools.ietf.org/html/draft-ietf-avtcore-cc-feedback-message-05#ref-I-D.ietf-rmcat-rtp-cc-feedback> I-D.ietf-rmcat-rtp-cc-feedback] that in most cases a per frame feedback is a reasonable assumption on how frequent the RTCP feedback messages can be transmitted.“ later in the section it talks about 50-200msec and say that a value in this range need to be negotiated.  Looking at rmcat-rtp-cc-feedback I got the impression that a report per frame is recommended. 

   guidance.

Fixed.

Colin

 

Roni Even

From: avt [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Roni Even (A)
Sent: Thursday, December 05, 2019 9:30 AM
To:  <mailto:[email-masked]> [email-masked]
Cc:  <mailto:[email-masked]> [email-masked]
Subject: [AVTCORE] WGLC on draft-ietf-avtcore-cc-feedback-message-05

Hello, all!

 

Thank you!

Roni Even 

AVTCore co-chair

-- 
Colin Perkins
https://csperkins.org/