Subject: [Rmt] IPR statement in RFC 3450

From: Magnus Westerlund <[email-masked]>
Date: Thu, 22 Oct 2009 19:25:18 +0200

Hi,

In the IESG review Cullen raised the issue about the statement in RFC 3450:

7.  Intellectual Property Issues

   The IETF has been notified of intellectual property rights claimed in
   regard to some or all of the specification contained in this
   document.  For more information consult the online list of claimed
   rights.

This indicates that there should be an IPR disclosure regarding RFC
3450, and that likely also applies to draft-ietf-rmt-pi-alc-revised
also. Can anyone in the WG please shed some light on the statement and
if there should be a IPR disclosue also on draft-ietf-rmt-pi-alc-revised?

Thanks

Magnus Westerlund

IETF Transport Area Director
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Lars Eggert <[email-masked]>
Date: Thu, 22 Oct 2009 20:37:55 +0300

On 2009-10-22, at 20:25, Magnus Westerlund wrote:
> Can anyone in the WG please shed some light on the statement and

FWIW, the IETF IPR tracker comes up with no hits on IPR disclosures  
related to either RFC3450 or the ID it originated from (draft-ietf-rmt- 
pi-alc).

But since the ID is from 2000, I'm not sure how reliable IPR tracking  
was back then.

Lars

---

From: Lorenzo Vicisano <[email-masked]>
Date: Thu, 22 Oct 2009 11:02:10 -0700

Magnus,

I'll let Mark clarify this further, but my understanding is that the
IPR statement
in the draft is incorrect and that the is no IPR claim on this (or RFC 3450)
that we know of.

  Lorenzo

On Thu, Oct 22, 2009 at 10:25 AM, Magnus Westerlund
<[email-masked]> wrote:
> _______________________________________________
> Rmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rmt
>

---

From: "Watson, Mark" <[email-masked]>
Date: Thu, 22 Oct 2009 11:05:44 -0700

All,

I discussed this with Mike and Lorenzo.

First, our belief is that the statement in RFC3450 is incorrect: there was no IPR disclosure filed against RFC3450 and certainly there was no disclosure filed against RFC3450 by Digital Fountain.

Secondly, we do not believe Digital Fountain had any IPR that should have led to such a disclosure, either for RFC3450 or for the new ALC draft.

We do not know of any other IPR and so we believe the absence of any IPR disclosures in the IETF database is a correct reflection of the IPR situation for ALC (this belief obviously being much stronger for the specific case of Digital Fountain IPR).

As for the question of why the statement is there in RFC3450: the very early drafts, for example http://tools.ietf.org/html/draft-ietf-rmt-pi-alc-01, contained explicit notes about the existence of Digital Fountain IPR on FEC coding and congestion control technologies that were also being discussed in RMT. I think at that time it was probably not completely clear how the FEC coding and congestion control would evolve separately and in relation to ALC and so in the interests of complete openness this kind of explicit statement was included in these early drafts. It was later modified (for example in http://tools.ietf.org/html/draft-ietf-rmt-pi-alc-02) to say that "ALC may be used with congestion control and other protocols, ..., which have pending or granted patents" i.e. to caution readers that there may be IPR associated with things that might be used with ALC, but which are not required for ALC itself.

This cautionary statement was changed during the publication process to the standard boilerplate that is in the RFC and it is our guess (and no more, since this was all a long time ago) that this change was made in error.

It should be noted that as a result of a very recent WG decision, the new ALC draft does require support for Wave and Equation Based Rate Control, RFC3738, in which Digital Fountain did have IPR which is now owned by Qualcomm and that Qualcomm has filed an IPR disclosure for that RFC, here: https://datatracker.ietf.org/ipr/1182/, which promises royalty-free licenses to all implementors.

Regards,

Mark

On 10/22/09 10:25 AM, "Magnus Westerlund" <[email-masked]> wrote:

Hi,

Thanks

Magnus Westerlund

---

From: Lars Eggert <[email-masked]>
Date: Thu, 22 Oct 2009 21:06:39 +0300

Hi,

> in the draft is incorrect and that the is no IPR claim on this (or  

if this is correct, I'd be good if - for the record - someone filed an  
errate for RFC3450 that removes that section.

Lars

---

From: "Watson, Mark" <[email-masked]>
Date: Thu, 22 Oct 2009 18:06:37 -0700

Lars,

I agree that it would be good if someone filed an errata. However the only people who know for a fact whether or not the IETF was notified of any IPR are the IETF secretariat/RFC editors who inserted this text. It is possible (though admittedly unlikely) that the IETF was notified of some IPR by someone else and this lead to the note, but that for some reason the IPR database was not updated.

All I can say for certain is that Digital Fountain did not provide any such notification and that we have no reason to believe that anyone else did, but I couldn't be certain enough of that second thing to file the errata myself.

...Mark

On 10/22/09 11:06 AM, "Lars Eggert" <[email-masked]> wrote:

Hi,

Lars

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 22 Oct 2009 13:04:10 -0600

Thanks Mark

On Oct 22, 2009, at 12:05 PM, Watson, Mark wrote:

> First, our belief is that the statement in RFC3450 is incorrect:  
> there was no IPR disclosure filed against RFC3450 and certainly  
> there was no disclosure filed against RFC3450 by Digital Fountain.
>
> Secondly, we do not believe Digital Fountain had any IPR that should  
> have led to such a disclosure, either for RFC3450 or for the new ALC  
> draft.
>
> We do not know of any other IPR and so we believe the absence of any  
> IPR disclosures in the IETF database is a correct reflection of the  
> IPR situation for ALC (this belief obviously being much stronger for  
> the specific case of Digital Fountain IPR).
>
> As for the question of why the statement is there in RFC3450: the  
> very early drafts, for example http://tools.ietf.org/html/draft-ietf-rmt-pi-alc-01 
> , contained explicit notes about the existence of Digital Fountain  
> IPR on FEC coding and congestion control technologies that were also  
> being discussed in RMT. I think at that time it was probably not  
> completely clear how the FEC coding and congestion control would  
> evolve separately and in relation to ALC and so in the interests of  
> complete openness this kind of explicit statement was included in  
> these early drafts. It was later modified (for example in http://tools.ietf.org/html/draft-ietf-rmt-pi-alc-02) 
>  to say that “ALC may be used with congestion control and other  
> protocols, ..., which have pending or granted patents” i.e. to  
> caution readers that there may be IPR associated with things that  
> might be used with ALC, but which are not required for ALC itself.
>
> This cautionary statement was changed during the publication process  
> to the standard boilerplate that is in the RFC and it is our guess  
> (and no more, since this was all a long time ago) that this change  
> was made in error.
>
> It should be noted that as a result of a very recent WG decision,  
> the new ALC draft does require support for Wave and Equation Based  
> Rate Control, RFC3738, in which Digital Fountain did have IPR which  
> is now owned by Qualcomm and that Qualcomm has filed an IPR  
> disclosure for that RFC, here: https://datatracker.ietf.org/ipr/ 
> 1182/, which promises royalty-free licenses to all implementors.
>
> Regards,
>
> Mark
>
> On 10/22/09 10:25 AM, "Magnus Westerlund" <[email-masked] 
> > wrote:
>
> Hi,
>