Subject: Re: [Rmt] About Flute-revised open points

From: <[email-masked]>
Date: Sat, 9 Apr 2011 13:29:45 +0200

Error in previous message: long to byte change in xml is fine. (Other other way round could have been fatal). Cheers, Rod.

----- Original message -----
> Thanks for Dave's link, I'll check this out next week.
>
> Meanwhile...
>
> It seems like I am being painted a little like the outlier with last
> minute jitters. As Vincent kindly pointed out there are a few unresolved
> threads that have been running a long while. Mostly we simply haven't
> bothered to get them resolved. For each of those years. (And I must also
> personally appologise for not tracking LCT and ALC at each revision so
> as catch the greater than agreed impact on FLUTE before they went
> standards track. Of course we may well have had the same end result,
> just without the percenption of last minute issues). In spite of
> originally agreeing to maintain compatability where feasible, we're now
> stuck with some long term undiscolsed design decisions. Practically, we
> may have to embrace the unknown, but it's reasonable engineering to
> point out that our process has these black spots, whether communicated
> as last minute jitters or otherwise :)
>
> So as Magnus earlier suggested, I feel we need to be pragmatic with what
> we have. At the same time I feel we need a bit of design explanation
> where it exists as the rmt mailing list has been a close approximation
> to silent on these issues for most for this bis/revised era. (E.g. I
> hope I've overlooked the discussion or notification of non-backwards
> comatible changes prior to an updated ID appearing for LCT and ALC, and
> would be grateful to hear that this is so).
>
> Meanwhile, to Vincent's couple of points:
>
> 1. Yes, in RMT terms that's a recent email with responses awaiting
> conclusion, discussion or anything. The crux is what consitutes a
> compatibility breaking change (e.g. Graceful and non-harmful failure of
> an experimental implementation does not IMHO). And what is the list of
> these such changes? (Which I will turn to Dave's link for)
>
> 2. Yes, a disclosed design change. Again the critical thing is the
> comatibility (and the design logic). As far as I can tell there's just
> one fatal change (long to byte - for which I have not found any
> explanation). Otherwise and failures are graceful and happily compatible
> as said in the messages that were kindly linked by Vincent. I haven't
> had the opportunity to follow up the namespace specifics, but as Magnus
> originally pointed out, leaving 'example.com' was a goof - and thus
> obviously experimental FLUTE recievers are experienced at ignoring that
> part of the XML.
>
> For my part, I'll have a look at Dave's material in the near future and
> work with Jani to enhance the security provisions of FLUTE-SDP. Please
> point out if any of the other loose threads are pending a response from
> me.
>
> Cheers, Rod.
>
>
>
> ----- Original message -----
> > I agree with Magnus here.          I hope that Rod can review Vincent's
> > historical summary of the issues and provide consensus or comments to
> > help us resolve this.
> >
> >
> > Additionally, here is a link to the message that summarizes the
> > backwards incompatibility issues identified by Dave Harrington's AD
> > review of FLUTE:
> >
> >
> > http://www.ietf.org/mail-archive/web/rmt/current/msg01434.html
> >
> >
> >
> >
> >
> >
> >
> > best regards,
> >
> >
> >
> > Brian Adamson
> > [email-masked]<mailto:[email-masked]>
> >
> >
> >
> >
> >
> >
> >
> >
> > On Mar 31, 2011, at 11:01 AM, Magnus Westerlund wrote:
> >
> > > Hi,
> > >
> > > I think this is a good example of what I expect in this discussion.
> I
> > > think that a number of the changes has good reasons to their
> changes
> > > and
> > > that we are not likely to reverse the WG documents text. For the
> > > record
> > > I don't really remember the reasons for the designs in this schema
> and
> > > what the underlying 3GPP reasons are.
> > >
> > > I have no rapid need for an updated flute so I am willing to let
> this
> > > discussion go on for a while. Especially letting people try to dig
> up
> > > any more motivations. But the fact is that the WG spent 5+ years in
> > > producing this document. There are reasons why it looks like it
> does.
> > > Reversing that decision at the last minute seems dangerous and
> likely
> > > to
> > > cause more issues than actually bumping the version number.
> > >
> > > Cheers
> > >
> > > Magnus
> > >
> >
> >
> > Everybody,
> >
> > A follow-up to our long discussion during the meeting:
> >
> > 1- Concerning Flute version, the email that convinced
> > me of the necessity to move to version 2 is the
> > following one, from Mike, sent on Feb 7, 2011:
> >
> > http://www.ietf.org/mail-archive/web/rmt/current/msg01511.html
> >
> > 2- Concerning XML extensibility, after searching a little
> > bit better in my archives, I finally found the initial reasons.
> > See the following 3 emails (from June 2005):
> >
> > * The initial email (from Rod) explaining why 3GPP proposed
> > another schema:
> > http://www.ietf.org/mail-archive/web/rmt/current/msg00404.html
> >
> > * The answer from Magnus, with the 3GPP schema:
> > http://www.ietf.org/mail-archive/web/rmt/current/msg00477.html
> >
> > * Finally Rod's promise (yes!!!) to include this schema:
> > http://www.ietf.org/mail-archive/web/rmt/current/msg00482.html
> >
> > That's for the history. The question now is what do we want
> > to do?
> >
> > Vincent
> >
> >
> > > _______________________________________________
> > > Rmt mailing list
> > > [email-masked]<mailto:[email-masked]>
> > > https://www.ietf.org/mailman/listinfo/rmt
> > >
> >
> >
> > > --
> > >
> > > Magnus Westerlund
> > >
> > >
> ----------------------------------------------------------------------
> > > Multimedia Technologies, Ericsson Research EAB/TVM
> > >
> ----------------------------------------------------------------------
> > > Ericsson AB                                                          | Phone  +46 10 7148287
> > > Färögatan 6                                                          | Mobile +46 73 0949079
> > > SE-164 80 Stockholm, Sweden| mailto: [email-masked]<mailto:[email-masked]>
> > >
> ----------------------------------------------------------------------
> > > _______________________________________________
> > > Rmt mailing list
> > > [email-masked]<mailto:[email-masked]>
> > > https://www.ietf.org/mailman/listinfo/rmt
> > >
> > >
> >
> >
>
> <Attachment>  ATT00001..txt
>
>
>

<Attachment>  ATT00001..txt

---

From: "David Harrington" <[email-masked]>
Date: Wed, 13 Apr 2011 09:47:09 +0200

Hi,
 
I think it makes no difference whether it is byte-to-long or
long-to-byte.
If one implementation sends a long value to an implementation that
supports only byte, they do not interoperate.
Both ends need to agree or you lose interoperability.
If the specs differ, then you need a mechanism to determine which set
of rules are followed - a version#
 
dbh

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Saturday, April 09, 2011 1:30 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Rmt] About Flute-revised open points

Error in previous message: long to byte change in xml is fine. (Other
other way round could have been fatal). Cheers, Rod. 

----- Original message ----- 

> > [email-masked] 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 

> > > [email-masked] 

> > > Ericsson AB
| Phone  +46 10 7148287 
> > > Färögatan 6
| Mobile +46 73 0949079 
> > > SE-164 80 Stockholm, Sweden| mailto:
[email-masked] 

> > > [email-masked]

---

From: <[email-masked]>
Date: Wed, 13 Apr 2011 11:04:50 +0200

In theory, with the long to byte change problem may only occur with an experimental sender sending a >255 value to a revised receiver parsing only 8bit values. However, you would (generally) expect a revised receiver to reject the XML based on the namespace, or else understand that it is not a 'pure revised' receiver and adapt.

In practice the fec value in that field is spec'ed at 8bit and any number above 255 would not be a registered value, and so would be rejected by an experimental receiver too. (At the value-mapping stage rather than the XML parsing stage). I.e. An experimental sender will not pollute that field with values greater than would fit byte regardless of whether the receiver XML parser admits longs or only bytes.

Hence my suggestion that this "is fine". (Even if unaware why the change happened, I expect the design thinking took this "no harm in practice" aspect into account).

Did I make an error?

Cheers, Rod.

On 13.4.2011, at 10.47, "ext David Harrington" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I think it makes no difference whether it is byte-to-long or long-to-byte.
If one implementation sends a long value to an implementation that supports only byte, they do not interoperate.
Both ends need to agree or you lose interoperability.
If the specs differ, then you need a mechanism to determine which set of rules are followed - a version#

dbh

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Saturday, April 09, 2011 1:30 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Rmt] About Flute-revised open points

----- Original message -----
> > <http://www.ietf.org/mail-archive/web/rmt/current/msg01434.html> http://www.ietf.org/mail-archive/web/rmt/current/msg01434.html
> >
> >
> >
> >
> >
> >
> >
> > best regards,
> >
> >
> >
> > Brian Adamson
> > <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
> >
> >
> >
> >
> >
> >
> >
> >
> > <http://www.ietf.org/mail-archive/web/rmt/current/msg01511.html> http://www.ietf.org/mail-archive/web/rmt/current/msg01511.html
> >
> > <http://www.ietf.org/mail-archive/web/rmt/current/msg00404.html> http://www.ietf.org/mail-archive/web/rmt/current/msg00404.html
> >
> > <http://www.ietf.org/mail-archive/web/rmt/current/msg00477.html> http://www.ietf.org/mail-archive/web/rmt/current/msg00477.html
> >
> > <http://www.ietf.org/mail-archive/web/rmt/current/msg00482.html> http://www.ietf.org/mail-archive/web/rmt/current/msg00482.html
> >
> > > <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
> > > <https://www.ietf.org/mailman/listinfo/rmt> https://www.ietf.org/mailman/listinfo/rmt
> > >
> >
> >
> > > --
> > >
> > > Magnus Westerlund
> > >
> > >
> > > SE-164 80 Stockholm, Sweden| mailto: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
> > >
> > > <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
> > > <https://www.ietf.org/mailman/listinfo/rmt> https://www.ietf.org/mailman/listinfo/rmt
> > >
> > >
> >
> >
>