Subject: [rohc] question on END_MESSAGE instruction..

From: [email-masked]
Date: Wed, 13 Mar 2002 11:38:17 -0600

Hi,
    I think basic draft on END_MESSAGE instruction doesn't clearly specify how the %announcement_location parameter can be specified by the compressor, which uploads the bytecode. Well, the objective of the END_MESSAGE is to instruct the decompressor on the remote side to create a state and also modify application defined parameters. How does the compressor on one end can specify the address of the application defined parameters stored locally on the remote decompressor? 

-Narendra

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Thu, 14 Mar 2002 13:00:13 -0000

> Hi,
>     I think basic draft on END_MESSAGE instruction doesn't 
> clearly specify how the %announcement_location parameter can 
> be specified by the compressor, which uploads the bytecode. 
> Well, the objective of the END_MESSAGE is to instruct the 
> decompressor on the remote side to create a state and also 
> modify application defined parameters. How does the 
> compressor on one end can specify the address of the 
> application defined parameters stored locally on the remote 
> decompressor? 

Hi,

The compressor doesn't need to know exactly where the application-
defined parameters are stored at the remote endpoint. It can put the
announcement information anywhere it likes in the UDVM memory (as
long at it sets the %announcement_location operand to the correct
value). It's the job of the receiving endpoint to extract this
information from the UDVM memory and to overwrite the existing
application parameters if needed.

Note that for security purposes, the announcement information can
only overwrite the existing application-defined parameters once it
has been verified by the state handler.

Regards,

Richard