Subject: [rohc] UDVM User Guide

From: "Price, Richard" <[email-masked]>
Date: Wed, 6 Mar 2002 17:13:22 -0000

Hi,

Further to Carsten's email, I'd like to ask for some suggestions on topics for
the "UDVM User Guide".

The draft should cover any decisions that SigComp-05 leaves to particular
signalling applications or to implementers, and where some guidance on how to
make these decisions would be useful.

Some topics for the draft might be as follows:

1   How to fix values for the application-defined parameters
2   Ways to distinguish SigComp data from other types of data
3   Examples of how to initialize SigComp between two endpoints
4   How to implement an implicit ack scheme
5   Mnemonic language to help with writing UDVM bytecode
6   Compiling UDVM bytecode
7   Bytecode for example decompression algorithms

We already have some text for topics 1, 2, 5 and 7 (in fact we have two
different proposals for how topic 2 can be done).

For topic 3 we can probably take Zhigang's text on the subject and combine
it with an updated version of the message flow diagram from SigComp-04.

Any volunteers for the others?

Regards,

Richard

> -----Original Message-----
> From: Dr. Carsten Bormann [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 1:10 PM
> To: Miguel A. Garcia; [email-masked]
> Subject: RE: [rohc] Where is the pair operation figure in 
> Sigcomp-05 ??
> 
> 
> Miguel,
> 
> the figure in -04 is just one way of doing this.
> 
> You don't have to standardize the exact sequence of events -- do you need an
> announcement before you can send data?  Depends on your specific requirements.
> 
> So, in the process of minimizing the amount of contentious and unnecessary
> information in the document, the figure went away.
> 
> Actually, a lot of material went away, including the annexes.  We intend to
> use it to put together a "users guide to UDVM" document, which might become
> an informational RFC later.  Of course, further input to that document would
> be welcome.
> 
> Gruesse, Carsten
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
>

---

From: Adam Roach <[email-masked]>
Date: Wed, 6 Mar 2002 16:48:52 -0500

I'm working on an LZW implementation in mnemonic UDVM code,
but have been placed on a different assignment for the short
term. I will let you know if I complete it.

If anyone else would like to take up the task, I can send
you what I currently have (which is code complete, but absolutely
untested in any way and probably quite buggy).

/a

> From: Price, Richard [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 11:13 AM
> To: 'Dr. Carsten Bormann'; Miguel A. Garcia; 'Hans Hannu (EPL)';
> [email-masked]'; [email-masked]
> Subject: [rohc] UDVM User Guide
> 
> 
> Hi,
>