Subject: RE: [rohc] TCP/IP EPIC profile

From: "Hongbin Liao (Intl Staffing)" <[email-masked]>
Date: Thu, 14 Mar 2002 19:41:47 +0800

Hi, Mark
    I'am refining the EPIC TCP/IP profile these days. I am not so clear about the TCP options processing in the profile. The question is how EPIC handle multi-occurances TCP NOP options since we found, for at least two popular TCP/IP stack implementations, there are at least 3~4, or more, occurances of TCP NOP options in one TCP/IP packet when Timestamp and/or SACK options are used. Would u give some comments and/or examples on it?
 
Thanks!
Hongbin L.
14/03/2002

> -----Original Message-----
> From: West, Mark (ITN) [mailto:[email-masked]]
> Sent: Thursday, March 14, 2002 6:03 PM
> To: Per Synnergren (EPL)
> Cc: [email-masked]'
> Subject: Re: [rohc] TCP/IP EPIC profile
>
>
>
> While I don't pretend that it contains all the answers, you
> could have a
> look at
> http://search.ietf.org/internet-drafts/draft-west-tcpip-field-
> behavior-01.txt
>
> Certainly where there are correlations that I've missed, it would be
> good if folks could point these out...
>
> Having said that, I don't know of any studies of the strength of
> correlation or its effect on compression.  I suppose that's
> what we're
> in the process of doing at the moment?
>
> Cheers,
>
> Mark.
>
>
> Per Synnergren (EPL) wrote:
>
> > Hi all,
> >
> > 
> >
> > A question "out of the blue"...
> >
> > 
> >
> > Hongbin Liao wrote:
> >
> >     1. whether can TCP/IP EPIC profile correctly describe
> the behavior
> >     of TCP? Or, whether EPIC is powerful enough to describe the
> >     complicated behavior of TCP/IP?
> >
> >         In EPIC, fields are assumed to be independent from
> each other.
> >     Once each field's behaviors are described well, the
> whole protocol's
> >     behaviors are also well-studied. However, in practice,
> fields in a
> >     protocol may not behave independently completely from
> each other.
> >     There may be some connections (or causality) among
> several fields.
> >     For example, most TCP traffics only contain one-way traffic (WWW
> >     browsing, FTP downloading, etc.), i.e., only SEQ changes on the
> >     forward path (from server to client) and only ACK changes on the
> >     backward path (from client to server). The ACK on the
> forward path
> >     and SEQ on the backward path remain constant. However, in TCP/IP
> >     EPIC profile, the probabilities for SEQ and ACK are specified
> >     seperately:
> >
> >     It is obvious that knowledge about "TCP inter-field correlation"
> >     could be useful in order to increase the performance of
> the header
> >     compression. Has anyone heard of/or performed thorough
> studies of
> >     the cross-correlation between TCP-fields?
> >
> >     
> >
>
>
> --
> Mark A. West, Consultant Engineer
> Roke Manor Research Ltd., Romsey, Hants.  SO51 0ZN
> Phone +44 (0)1794 833311   Fax  +44 (0)1794 833433
>
> (Yes, I do know that my disclaimer is in an attachment.  And, no, I
> didn't ask for it to be that way)
>

---

From: "West, Mark (ITN)" <[email-masked]>
Date: Thu, 14 Mar 2002 22:14:22 +0000

Hongbin Liao (Intl Staffing) wrote:

> Hi, Mark
> 
>     I'am refining the EPIC TCP/IP profile these days. I am not so clear 
> about the TCP options processing in the profile. The question is how 
> EPIC handle multi-occurances TCP NOP options since we found, for at 
> least two popular TCP/IP stack implementations, there are at least 3~4, 
> or more, occurances of TCP NOP options in one TCP/IP packet when 
> Timestamp and/or SACK options are used. Would u give some comments 
> and/or examples on it?
> 

Add more NOP options to the LIST encoding.  And increase the 'presence' 
and 'order' meta-field sizes to accommodate the extra data required.

Cheers,

Mark.