Subject: RE: [rohc] SigComp assumptions about security

From: [email-masked]
Date: Fri, 15 Mar 2002 10:04:32 -0600

> The problem is that you can't even use state announcements 
> without some form of application security.

True. 

> Of course, in a closed environment, you can still use 
> pre-agreed state.

Yes, e.g. an enhanced IPCOMP for per-message compression.

Zhigang

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Fri, 15 Mar 2002 16:36:55 -0000

> Yes, e.g. an enhanced IPCOMP for per-message compression.

It would be interesting to see whether the UDVM bytecode is
now compact enough to give a performance win for a single
IP packet.

We've just finished the bytecode for the IPR-encumbered LZW
algorithm and it's 66 bytes in total. This could feasibly
give a good compression ratio even when downloading the code
on a per-packet basis, which would be particularly useful for
IPCOMP if the two communicating endpoints happened not to
support a common compression algorithm.

Regards,

Richard

---

From: [email-masked]
Date: Fri, 15 Mar 2002 11:00:00 -0600

Richard,

I'm not sure we are talking about the same thing here. 
By enhanced IPCOMP, I mean UDVM combined with pre-agreed
state. The state can contain both code and dictionary,
and does not need to be carried in each message. So,
it is per-message compression, but not stateless.

What you mentioned below is a real stateless case. It
will be interesting if you can provide compression
performance of the 66-byte LZW code. 

BR,
Zhigang

> -----Original Message-----
> From: ext Price, Richard [mailto:[email-masked]]
> Sent: March 15, 2002 10:37 AM
> To: Liu Zhigang.C (NRC/Dallas); [email-masked]; [email-masked]
> Subject: RE: [rohc] SigComp assumptions about security
> 
>