Subject: [rohc] OUTPUT instruction question re-stated.

From: [email-masked]
Date: Tue, 5 Mar 2002 18:18:26 -0600

Hi,
    I'm sorry for the confusion in my previous mail. This mail should explain my doubt clearly. In section 9.5.3 of Sigcomp-04.txt, OUTPUT Instruction,  it is noted that "each time the instruction(OUTPUT) is encountered it appends a byte string to the end of data previously passed to the dispatcher via the OUTPUT instruction"
  Can anyone explain me the reason for appending "current" byte string to the previous end of data. I thought the role of UDVM is to decompress the message and pass it to dispatcher. I would like to know who's the care-taker of constructing the decompressed message from segments (i.e is it UDVM or Dispatcher). 

-Thank You
Sincerely,
Narendra

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Wed, 6 Mar 2002 10:32:43 -0000

Hi,

Dividing the decompressed data into messages is the responsibility of
the dispatcher rather than the UDVM.

The reason for this behaviour is that the application might expect the
decompressed data to arrive either as distinct, bounded messages or as
a stream (depending on whether the transport layer is UDP or TCP).
However the UDVM does not have any knowledge of the transport layer, so
it always outputs uncompressed data as a stream.

If the application expects a stream of data then the dispatcher just
forwards the output of the UDVM directly to the application. However,
if the application needs to receive data as bounded messages then the
dispatcher is responsible for buffering the stream from the UDVM and
outputting it to the application one message at a time.

Regards,

Richard

P.S.  Older versions of the UDVM took the opposite approach - they
always outputted data as a set of bounded messages. However, this was
abandoned because it meant that the UDVM was needlessly buffering data
over a stream-based transport (adding extra delay and wasting valuable
UDVM memory).

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 12:18 AM
> To: [email-masked]
> Subject: [rohc] OUTPUT instruction question re-stated.
> 
> 
> Hi,
>     I'm sorry for the confusion in my previous mail. This 
> mail should explain my doubt clearly. In section 9.5.3 of 
> Sigcomp-04.txt, OUTPUT Instruction,  it is noted that "each 
> time the instruction(OUTPUT) is encountered it appends a byte 
> string to the end of data previously passed to the dispatcher 
> via the OUTPUT instruction"
>   Can anyone explain me the reason for appending "current" 
> byte string to the previous end of data. I thought the role 
> of UDVM is to decompress the message and pass it to 
> dispatcher. I would like to know who's the care-taker of 
> constructing the decompressed message from segments (i.e is 
> it UDVM or Dispatcher). 
> 
> -Thank You
> Sincerely,
> Narendra
> 
>   
> 
> 
>