Subject: RE: [rohc] Avoiding Shared Identifier (Sigcomp Extended -02)

From: "Hans Hannu (EPL)" <[email-masked]>
Date: Thu, 21 Mar 2002 23:23:04 +0100

> > Can't the 
> > decompressor2 calculate the shared identifier from the 
> > decompressed message and inform compressor2 about the new 
> > state which intun could use it if required. 
> 
> Yes, this is the way it is supposed to be done, and will be 
> explained in 
> more detail in SigComp-extended-03.

Hi, 

Sorry for the quick and short answer. 

A compressor should instruct its remote UDVM to calculate the
shared_id using the MD5 instruction, and then place the shared_id
at the announcement location. Then the shared_id would be passed
to the remote compressor by the END-MESSAGE instruction.

Richard Price, provided me with a UDVM code to the presentation for the
extended operation mechanisms. Richard, could you send that code to
the list?

BR
/Hans H

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Dr. Carsten Bormann" <[email-masked]>
Date: Thu, 21 Mar 2002 23:26:44 +0100

> extended operation mechanisms. Richard, could you send that code to

It might be better to do this when it's tested.

Gruesse, Carsten