Subject: [rohc] queries regarding ROHC

From: "Lalit Bhasin" <[email-masked]>
Date: Mon, 04 Mar 2002 13:53:57 +0500

Hi,
 I have got some basic queries regarding RFC 3095 (ROHC). I
 would be highly obliged if any one could give some directions
 regrding  these.
 
 1. The RFC doesn't mentions anything about when the decompressor 
 should initiate the mode transition. mainly, on what conditions
 the decompressor should transit between O-mode and R-mode. Is this
 being triggered by external entity.
 
 2. In case of IPv4-IPv4 tunneling, if the RND and RND2 flags are 
 0 (i.e, IP-ID is a function of SN), how should the decompressor send 
 the offset encoded bits for outer IP-ID in type 0,1 or 2 packets.
 
 3. In RTP TimeStamp Encoding, it is not clear how the compressor 
 determines the TIME STRIDE.

Regards,
Lalit

---

From: "Lars-Erik Jonsson (EPL)" <[email-masked]>
Date: Mon, 4 Mar 2002 12:15:05 +0100

>  being triggered by external entity.

This is an implementation issue, and therefore not defined in the
RFC. 

Rgds,
/L-E

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lalit Bhasin" <[email-masked]>
Date: Wed, 06 Mar 2002 17:22:39 +0500

Lars,
  Ok, agreed the first query is the implementation issue. I don't feel 
that other two queries can be implementation issues. I am reproducing 
the other queries for your convenience.

1. In case of IPv4-IPv4 tunneling, if the RND and RND2 flags are 
  0 (i.e, IP-ID is a function of SN), how should the compressor send 
  the offset encoded bits for outer IP-ID in type 0,1 or 2 packets.

2. How is the TIME_STRIDE calculated for the Timer based compression.

Regds,
Lalit 

----- Original Message -----
From: "Lars-Erik Jonsson (EPL)" <[email-masked]>
Date: Monday, March 4, 2002 4:45 pm
Subject: RE: [rohc] queries regarding ROHC

> />