Subject: RE: [rohc] TCP/IP EPIC profile

From: "Qian Zhang" <[email-masked]>
Date: Thu, 14 Mar 2002 19:51:09 +0800

Hi all, 

> > [Mark]
> > Ok, see my discussion above for one way to support such a flag.
> >
> > Also, consider the following fragment of EPIC-speak...
> >
> > A_and_B = AB_1(50%) | AB_2(50%)
> >
> > AB_1 = XXXX
> >         YYYY
> >
> > AB_2 = PPPP
> >         QQQQ
> >
> > which says that if A is encoded as XXXX then B is encoded as
> > YYYY (and
> > this happens 50% of the time), but if A is encoded as PPPP then B is
> > encoded as QQQQ (and this happens 50% of the time).
> >
> [Hongbin]
> Great idea! Such a simple format is really what we need! However, you
need
> 'otherwise' to simply the enumeration of all possible, however,
ignorable
> (from the point of overall performance) combinations of encodings of
these
> fields (there may exist {A:XXXX B:QQQQ} or {A:PPPP B:YYYY}).
> 

Yes, the extension for supporting correlation can really enhance the
expression ability of EPIC-LITE. For ROHC-TCP case, we can combine
bulk-data-co, bulk-ack-co, interactive-co to a more intuitionistic
representation.

Since this group wants to use EPIC-LITE as a "generic compressed format
generator" for use in ROHC profile standardization, it would be better
that EPIC-LITE can provide more convenience and intuitionistic way for
developers to write the profile.

BR,
Qian

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "West, Mark (ITN)" <[email-masked]>
Date: Thu, 14 Mar 2002 22:29:36 +0000

> bulk-data-co, bulk-ack-co, interactive-co to a more intuitionistic

No, the above approach cannot usefully encode the flow behaviour in this 
way.

There are different types of correlation, where the probability 
distribution is:
- random, but known
- stable, but unknown

Something like the 'marker bit + timestamp' of the RTP profile fall into 
the former category -- you can think about putting a rough probability 
on the marker bit being set.
This is notated as the 'A_and_B' example above.

However, the TCP flow behaviour is a higher level dependency which 
should remain stable for the duration of the flow (or for significant 
proportions of the flow).
This uses the FORMAT construction.

-- 
Mark A. West, Consultant Engineer
Roke Manor Research Ltd., Romsey, Hants.  SO51 0ZN
Phone +44 (0)1794 833311   Fax  +44 (0)1794 833433

(Yes, I do know that my disclaimer is in an attachment.  And, no, I 
didn't ask for it to be that way)