Subject: RE: [rohc] rohc over xxx?

From: "Lars-Erik Jonsson (EPL)" <[email-masked]>
Date: Mon, 4 Mar 2002 12:13:22 +0100

> [1]
> ROHC scheme discussed in the WG is said to be combined with 
> the layer 2 techniques.  So there will be a lot of rohc over
> xxx document in future, since layer 2 technologies are various.
> I saw from the webpage of this WG, and only found a 'rohc
> over ppp' draft.  Is there any work carried on
> to deal with other layer 2 techonologies?

We have defined "ROHC-over-PPP" to provide an example for
how to apply ROHC over a typical layer 2 protocol, but
also because PPP is an IETF protocol so it is "our" task
to define this. However, it is not our task to define
this for various other link technologies. Therefore, there
is no further ROHC work planned for this.

> [2]
> Are there some testing implementations?  Or testing results 
> of the scheme proposed in this WG?  

There have been 2 interop tests, and a third is planned to be
held in April this year. At these events, four different
implementations have been present so far.

> [3]
> How to deal with the handover in the mobile ip?  While the mobile node
> moving to another domain, how could the compression context in its old
> access router be moved to the new access router fast?

This is not within the scope (charter) of ROHC.

Cheers,
/Lars-Erik

--------------------------------------
Lars-Erik Jonsson
IETF ROHC WG Chair
E-mail: [email-masked]
Phone: +46 920 20 21 07
Home: +46 920 999 57

My opinions are my personal opinions and should not be considered
as the opinions of my employer, if not explicitly stated. 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Dr. Carsten Bormann" <[email-masked]>
Date: Mon, 4 Mar 2002 12:26:41 +0100

> This is not within the scope (charter) of ROHC.

Let me add that context transfer is being discussed in the SEAMOBY WG, e.g.:
draft-ietf-seamoby-context-transfer-problem-stat-04.txt
There actually was a document on header compression context transfer,
draft-kenward-seamoby-ct-rohc-reqs-00.txt,
but this has been lying dormant for a while.

Gruesse, Carsten

---

From: Wang Hui <[email-masked]>
Date: Tue, 5 Mar 2002 10:49:33 +0800 (CST)

Thanks for Lars-Erik's reply.

> implementations have been present so far.

Are the current implementations available for downloading?
Where can I get the further information about the implementations?
Many thanks in advance.

--
 Wang Hui
 IPv6 Tech. Research Team,
 InfoNet Lab, USTC
 http://mail.ustc.edu.cn/~whui
 Tel: +86-551-3603634