Subject: [rohc] byte_copy_right

From: [email-masked]
Date: Thu, 4 Apr 2002 14:22:07 -0600

What's the motivation behind byte_copy_right pointing to the address immediately following the end of udvm buffer?

Thank You,
Narendra

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Dr. Carsten Bormann" <[email-masked]>
Date: Fri, 5 Apr 2002 07:45:43 +0200

> What's the motivation behind byte_copy_right pointing to the
> address immediately following the end of udvm buffer?

Well, actually, it does not really matter how you delimit the area, so this
is pretty much a non-consequential change (but one that changes the bits
over the wire).
That said, using the address of the next byte avoids having to
compute/load/set something to an address minus one.

e.g.:

reserve circular_buffer (2048)
:end_of_circular_buffer

With the change, you can:
MULTILOAD(0, 2, circular_buffer, end_of_circular_buffer)

without address arithmetic acrobatics.
Since the address of the next byte is more likely to be a power of two, the
%-style operand optimizations are more likely to work.

More generally speaking, a curt (terse/brusque/blunt) answer would be
"because CS people just do it that way".

Gruesse, Carsten