Subject: RE: [rohc] sigcomp issue sugar-5/cabo-8

From: "Hans Hannu (EPL)" <[email-masked]>
Date: Mon, 22 Apr 2002 23:36:31 +0200

Hi,

With this still in my mind the discussion we have had seems to lead to the following proposed action.

Proposed action: Add STATE-FREE instruction

We need to make sure that the text about this instruction includes the following in some way.
(Cut from previous mails regarding this issue)

"STATE-FREE is simply to allow the compressor to say "I'm not going to use a state I created before"

1) check if the compressor has requested to create the state to be 
freed in the past. If not, invalid STATE_FREE, stop.
2) deduct the size of the freed state from the state_memory size for 
the compressor
3) decrement the counter associated with the freed state by 1. 
(Note, the counter of a state is incremented whenever a compressor 
requests to create a state that has already been created)
4) if the counter reaches 0, physically delete the state."

BR
/Hans H

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked] (Dr. Carsten Bormann)
Date: 23 Apr 2002 16:46:34 +0200

> freed in the past. If not, invalid STATE_FREE, stop.

Hmm, how do you check this in the presence of packet losses and
retransmissions?  Do you need to keep a history even after deletion?
If yes, what is the bound on the history?

It seems we must allow a STATE-FREE on anything.

> 2) deduct the size of the freed state from the state_memory size for 

This step, of course, is not executed if the state isn't still being
referenced (maybe you meant this by "stop").

> requests to create a state that has already been created)

Hmm, packet loss/retransmissions again.
The counter should only be increased if the state has newly entered
the set of state associated with this session/compartment.
Repeated STATE-CREATE for the same session/compartment should not count.

> 4) if the counter reaches 0, physically delete the state."

Gruesse, Carsten