Subject: [rohc] rohc query

From: Lalit Bhasin <[email-masked]>
Date: Thu, 11 Apr 2002 14:47:14 +0530

hi all,
      In case of  IPv4-IPv4 tunneling, if the RND and RND2 flags are 0,
how is the encoded IP-ID bits of the outer IPv4 header
sent in the type 0,1 and 2 packets. The base header of these packets
only carry the encoded IP-ID bits of inner IPv4 header.
thanks in advance..
Lalit

---

From: "Lee lik sun" <[email-masked]>
Date: Fri, 12 Apr 2002 09:20:25 +0800

Hi Lalit & all,

Please correct my understanding if i am wrong.

IF both RND & RND2 flags are 0.

encoded IP-ID bits of the inner IPv4 header can sent in the type 0,1 & 2.
But the IP-ID of the outer IPV4 header will have to be sent with an
extension 3
with the Outer IP header flag (ip2) set and the IP-ID is sent uncompressed
with I2
of the Outer IP header flag set.

thanks & regards
LEE lik sun

----- Original Message -----
From: Lalit Bhasin <[email-masked]>
To: <[email-masked]>
Sent: Thursday, April 11, 2002 5:17 PM
Subject: [rohc] rohc query

> only carry the encoded IP-ID bits of inner IPv4 header.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Lalit Bhasin <[email-masked]>
Date: Fri, 12 Apr 2002 15:33:50 +0530

Lee,
  Does that means that the outer IP-ID would be sent in uncompressed form
even if the
IP-ID is showing the sequential behaviour.
If this is the case, can't we assume that the outer IP-ID is behaving as
random
(ie assume that RND2 flag is set) and send it in the ROHC packet after the
extension. Thus the
extension 3 would not be used everytime in IPv4-Ipv4 tuneeling.
Regds,
Lalit Bhasin

--

*******************************
LALIT KUMAR BHASIN
WIPRO TECHNOLOGIES
GURGAON.
Ph. 0124-6398465-69 Ext 2019
    9810419594
********************************

---

From: Lalit Bhasin <[email-masked]>
Date: Fri, 12 Apr 2002 11:19:04 +0530

Lee,

--