Subject: [rohc] sigcomp -05: Multiload instruction

From: [email-masked]
Date: Tue, 2 Apr 2002 18:04:39 -0600

Does the Multiload instruction execution similar to COPY instruction when byte_copy_right is reached while loading the values? I mean does the next load  starts at byte_copy_left or the decompressor needs to fail as per section 7.3 " if a byte is read from an address beyond the overall memory size then decompression failure occurs"

Thanks,
Narendra

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Wed, 3 Apr 2002 12:25:28 +0100

Hi,

The MULTILOAD instruction ignores byte_copy_left and byte_copy_right.
In general they are only used when explicitly indicated in the draft;
instructions ignore them unless told to do otherwise.

Regards,

Richard

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]
> Sent: Wednesday, April 03, 2002 1:05 AM
> To: [email-masked]
> Subject: [rohc] sigcomp -05: Multiload instruction
> 
> 
> Does the Multiload instruction execution similar to COPY 
> instruction when byte_copy_right is reached while loading the 
> values? I mean does the next load  starts at byte_copy_left 
> or the decompressor needs to fail as per section 7.3 " if a 
> byte is read from an address beyond the overall memory size 
> then decompression failure occurs"
> 
> Thanks,
> Narendra
>