Subject: [rohc] RE: Some comments on draft-ietf-sipping-sigcomp-sip-dictionary-00.txt

From: [email-masked]
Date: Tue, 21 May 2002 11:02:47 -0500

> For example, you have Via, SIP, 2.0  and UDP all
> listed separately. However, you will almost always see the 
> following:
>  
> Via: SIP/2.0/UDP
> 
> all together in a message. You'll clearly get much better compression
> performance when the dictinonary represents coarser grained elements

Good point. I'm also wondering if you have grouped together the
strings that likely appear one SIP message, particularly INVITE.
Of course, you cannot do this favor for every message. But at
least for a few messages we think are critical. 

Zhigang

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 21 May 2002 12:21:20 -0400

> least for a few messages we think are critical.

Right. Another thing supporting the coarse grained approach - you get
the fine grained ones for free. Suppose the dictionary just has:

Via: SIP/2.0/UDP

with the 'V' at address 0, then the following tokens are all available:

token               address     len
----------------------------------
Via:                  0          4
SIP                   5          3
2.0                   9          3
UDP                  13          3
Via: SIP/2.0/UDP      0          16
SIP/2.0               5          7

Thats a pretty big "bang for the buck" in terms of memory usage. 

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com