Subject: RE: [rohc] Questions on draft-ietf-rohc-sigcomp-06.txt

From: Chan Kwang Mien <[email-masked]>
Date: Tue, 14 May 2002 08:44:50 +0800

Hi Narendra,

Thanks for your reply. i have further questions indicated by >>.

Am i right to say that both the State Handler at the receiver
>and the Compressor at the sender have to create the hash ?
>This is done so that when the compressor wants to access a
>state, it has to supply the state identifier to the UDVM. when
>the UDVM receives this state identifier, it
>passes the state identifier to the State Handler to access
>a particular state. Since the State Handler also has the state
>identifier, it can then verify if the state identifier is a
>valid one.
>
>ANS: Yes.

 >>  So it would mean that both the Compressor at the sender and the
State handler at receiver have to use the same algorithm to create the Hash
value. if not, interoperability may be a problem as the receiver and sender
may be from different implementation. the standard way to create
the state identifier is not stated in the draft.

>Is it required
>by the UDVM to ask the compressor to retransmit the corrupted
>compressed message ?
>
>ANS: Dispatcher invokes UDVM when it receives the sigcomp message. The 
>life of the UDVM then starts and ends with successful 
>decompression/unsuccessful decompression. UDVm has no knowledge of the 
>underlying transport and so, it cannot ask for retransmission.

 >> Can the UDVM use the Feedback mechanism stated in section 3.2 to inform 
the Compressor
of a CRC failure so that the compressor can take the necessary action like 
retransmitting the
corrupted compressed messages. however, that would also mean that the 
compressed messages
have to be numbered much like the sequence number in the TCP header.

regards,
Kwang Mien

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Sukanta Kumar Hazra <[email-masked]>
Date: Wed, 15 May 2002 10:41:23 +0800 (SGT)

Hi!

Replies inline.

> the state identifier is not stated in the draft.

SHA-1

> have to be numbered much like the sequence number in the TCP header.

If a message is corrupted during the compress/decompress cycle,
I am wondering, if the appliction will have a recovery mechanism. (Since  
SIP messages may be sent over UDP, thus, I would suspect that there is a  
recovery mechanism in the Application).

-- 
-----------------------------------------------------
Sukanta Kumar Hazra                
R&D Engineer (Networks Division)
Institute for Communications Research
(Formerly the Centre for Wireless Communications)
Tel   : +65 68709338               
Fax   : +65 67795441              
Email : [email-masked]    
-----------------------------------------------------