Subject: [rohc] Implementation question on extension type 3

From: "Lee lik sun" <[email-masked]>
Date: Fri, 10 May 2002 11:47:05 +0800

Hi all,

For compressed Header, there IP-ID (2 octets) after the extension if RND = 1
But in Extension Type 3, there is also the I flag which indicate the presence of IP_ID(2octets) in the extension.

My question is if the RND in the IP Flag in extension 3 is set to '1',
then should the IP-ID be sent in the extension or after the extension?
As for the Decompr, should there be different handling for extension 3 on the IP-ID?

Thanks in advance
LEE Lik Sun

---

From: Lalit Bhasin <[email-masked]>
Date: Fri, 10 May 2002 09:35:39 +0530

HI friend,
   The IP-ID field of the ext 3 is to be used when rnd flag is not set,
ie ipid behaviour is sequential and the ext 0/1/2 don't have sufficient
bits to send the compressed ipid (or even when ext3 is to be sent for
some updates)...the ipid would be send uncompressed in this case....
    If the rnd flag is set, the ip-id is always sent uncompressed after
the rohc packet.
br,
Lalit

Lee lik sun wrote:

> Hi all, For compressed Header, there IP-ID (2 octets) after the
> extension if RND = 1But in Extension Type 3, there is also the I flag
> which indicate the presence of IP_ID(2octets) in the extension. My
> question is if the RND in the IP Flag in extension 3 is set to
> '1',then should the IP-ID be sent in the extension or after the
> extension?As for the Decompr, should there be different handling for
> extension 3 on the IP-ID? Thanks in advanceLEE Lik Sun

--

*******************************
LALIT KUMAR BHASIN
WIPRO TECHNOLOGIES
GURGAON.
Ph. 0124-6398465-69 Ext 2019
    9810419594
********************************

---

From: Sukanta Kumar Hazra <[email-masked]>
Date: Fri, 10 May 2002 12:24:13 +0800 (SGT)

Hi!

My understanding is that IP-ID in ext3 is used when RND=0 in context 
however, there aren't enough bits available in the other header types to 
send the compressed IP-ID.

Regards,
Sukanta

-- 
-----------------------------------------------------
Sukanta Kumar Hazra                
R&D Engineer (Networks Division)
Institute for Communications Research
(Formerly the Centre for Wireless Communications)
Tel   : +65 68709338               
Fax   : +65 67795441              
Email : [email-masked]    
-----------------------------------------------------

> As for the Decompr, should there be different handling for extension 3 on the IP-ID?

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc