Subject: [rohc] resource (CID) reclamation

From: Alan Kennington <[email-masked]>
Date: Sun, 12 Jan 2003 18:31:53 +1030

How are CIDs reclaimed?

I've looked through RFC 3095 several times, but I can't
find the equivalent of a TCP "FIN" in the protocol.

It seems like if the compressor allocated a CID, then it is
allocated for life.
Is the only way to terminate a context the issuing of an IR packet
to establish a new context?
This, however, seems to create a new context.
Ideally there should be a fourth mode - non-existent mode - which
means that the CID is completely free.
This `non-existent mode' should ideally have a well-defined handshake protocol
for mode transition like the other modes.
But I see nothing like this.

With UDP packets, you never know when the context is really finished.
So I imagine you would time out a context after a long period of inactivity.
And if you run out of CIDs, I imagine you reclaim the most idle open CID.

If there is something in RFC 3095 which I have missed, please let me know.

Cheers,
Alan Kennington.

--------------------------------------------------------------------
    name: Dr. Alan Kennington
 website: http://www.topology.org/
    city: Adelaide, South Australia
  coords: 138.59 E, 34.88 S
timezone: UTC+1030 http://www.topology.org/site/timezone.html
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Sukanta Kumar Hazra <[email-masked]>
Date: Mon, 13 Jan 2003 00:07:01 +0800

> And if you run out of CIDs, I imagine you reclaim the most idle open CID.

Yes, that is the desired approach.

--
Sukanta