Subject: RE: [rohc] WG last-call for ROHC MIB and related documents

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Fri, 24 Jan 2003 10:06:14 +0100

I have once again reviewed the "Terminology and Examples"
document, which I am also the author of, and found the following
that should be corrected:

- Section 3.2, last sentence, should end "...channel concept is used,
  as defined above."

- Section 4.2, "Feedback Output", second line, should be: "...is
  sent from the decompressor through..." instead of "...is sent by
  the compressor through...", for correctness and consistency.

- Section 5, third paragraph, last sentence, "ROHC peers" is not
  defined in terminology, and not used clearly in the document,
  should be made consistent.

- Section 6.2, first sentence should read "This section...", instead
  of "This chapter...".

- Section 6.3, first sentence should read "This section...", instead
  of "This chapter...".

- Section 6.3, figure, lower left decompressor, upper left output
  should be labeled "DO", not "FO".

- Section 6.3, description of figure is not correct, on the upper
  two instances, the FI/PI and PO/FO connections have been switched,
  respectively, while the lower two instances have been horizontally
  mirrored. Last sentence of the last paragraph should thus be 
  rewritten to correctly reflect this.

- Section 9, last sentence of second paragraph, should say
  "...those in one separate ROHC framework module, and...", instead
  of "...those separately, and... 

/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: den 15 januari 2003 17:21
> To: ROHC WG
> Subject: [rohc] WG last-call for ROHC MIB and related documents
> 
> 
> ROHCers,
> 
> In Atlanta, we said we were going to have another re-spin of the ROHC
> MIB to include LLA.  This has now been available for nearly a month,
> and we believe the document has received enough review to issue the WG
> last-call.  Together with this goes the terminology and examples
> document as additional explanatory material that at some point is
> expected to become part of the ROHC draft standard.
> 
> Therefore, we are now issuing a WG last-call for the following two
> documents:
> 
>   draft-ietf-rohc-mib-rtp-05.txt
>       (for publication as Proposed Standard)
> 
>   draft-ietf-rohc-terminology-and-examples-01.txt
>       (for publication as Informational)
> 
> This is a regular two-week WG last-call.
> 
> Please direct WG last-call comments to the ROHC mailing list
> [email-masked] before Wed, 2003-01-29, 18:00 UTC.
> 
> Gruesse, Carsten
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Hans Hannu (EAB)" <[email-masked]>
Date: Fri, 24 Jan 2003 10:55:08 +0100

Hi,

I've reviewed the "Terminology and Examples" document and have the 
following comments:

- Section 2, page 4, paragraph "Co-located compressor/decompressor".  
What is the meaning with "pair" in paragraph "Co-located compressor/decompressor"? 
Is it the co-located compressor and decompressor that makes up the "pair", or does 
the "pair" correspond to the co-located compressor and decompressor at one end 
together with the co-located compressor and decompressor at the other end of the link?  

- Section 2, page 4, paragraph "Associated compressor/decompressor".
Remove second word of ROHC at line 5 (easier to couple the instances together), 
and make singular of ROHC compressor/ at line 7.
* Old
      "sent from the co-located ROHC compressor to the ROHC decompressor
      co-located with the compressor at the other end. When a co-located
      ROHC compressors/decompressor pair is connected for this purpose,
      they are said to be associated with each other."
* New
      "sent from the co-located ROHC compressor to the decompressor
      co-located with the compressor at the other end. When a co-located
      ROHC compressor/decompressor pair is connected for this purpose,
      they are said to be associated with each other."

- Section 2, page 5, paragraphs "Interspersed feedback" and 
"Piggybacked feedback".
The word "channel" is used at line 5 of both paragraphs, could perhaps be
changed to "ROHC channel"

- Section 3.2, page 7, last paragraph.
Consider changing
* Old 
     "channel definition is slightly enhanced for header compression by the
     definition of ROHC channels (section 5) and ROHC feedback channels"

* New 
     "channel definition is slightly enhanced for header compression by the
     definition of the ROHC channel (section 5) and the ROHC feedback channel"     

- Section 4.1, page 11, last paragraph.
The word "channel" is used at line 4, could perhaps be
changed to "ROHC channel"

- Section 5, page 13, third paragraph.
Perhaps one could define, "ROHC peers" in the terminology section.

BR
/Hans H

---

From: "Juergen Quittek" <[email-masked]>
Date: Tue, 28 Jan 2003 21:52:19 +0100

Dear ROHCers,

Here are my comments on 

    Juergen

General:
  The document is very good: it's clear and precise and
  is very useful for understanding ROHC integration into 
  networks.

General:
  The title "Terminology and Examples for MIB Modules and 
  Channel Mappings" addresses MIB modules. But without
  knowing the WG context of this document, a reader would
  not be able to find out what it has to do with MIB modules.
  Therefore, I suggest choosing a title that expresses the
  content of the document rather than the context that led
  to its creation, for example (adapted from Section 8,
  line 1-2:
    "Terminology and Concepts for Use in ROHC Network Integration"

General: 
  Figures are not numbered. Since there are many of them
  in the document, I suggest to number them and give them
  captions.
  
Section 2, Paragraph on "Co-located compressor/decompressor":
  line four talks about "the link" (and so doe the paragraph
  on "Associated compressor/decompressor". However, the term
  'link' is not introduced bevor. Therefore some ambuguity
  remains in the terminology section. Can we clarify this
  by a proper definition of the term 'link'?
  The beginning of section 3.1 has some text coming close
  to a definition of 'link'.

Section 4, first line:
  "For e.g. the purpose of" could perhaps be replaced by
  "For various purposes, such as"

Section 4, line 8:
  I suggest extending the sentence on N compressors and
  M decompressors: replace "are arbitrary numbers." by
  "are arbitrary numbers, and N+M is the number of instances
  present at the IP interface."

Section 7, paragraph 2, line 2:
  "(but normally limited on a per-channel basis)" could
  perhaps be repalced by "(but limited)".
  reasons: 
  - it is always limited, not just normally
  - we are anyway talking on a per-instance basis,
    and we have a one-to-one mapping to channels

Section 7, figure:
  The terms 'HC' and 'HD' used in the figure should be
  either changed or replaced.

Section 7, line 5:
  remove "state" (or alternatively remove "stream" in line 4.
  A packet stream relates to a context, not to a particular
  context state, because the state may change between
  packets.

Section 8, item 5, line 2:
  The sentence is hard to read. I suggest replacing
  "logical layer two channels available" by
  "available logical layer two channels".
-- 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Thu, 30 Jan 2003 14:28:46 +0100

Juergen and others,

Thanks for the review, all comments will be addressed in an update. 

>     "Terminology and Concepts for Use in ROHC Network Integration"

Carsten and I have discussed the title of this document several
times, and obviously it is hard to find a proper title. I think
the current title is ok, although I agree that the presence of
"MIB" in it might make it look relevant only for MIB's. I also
think the title proposed above, or variants of it, would be ok.
I do not have any strong opinions about this.

Any thoughts from others?

Rgds,
/L-E