Subject: RE: [rohc] Removing SCTP header compression from the ROHC charter

From: "West, Mark (ITN)" <[email-masked]>
Date: Fri, 17 Jan 2003 07:45:09 -0000

Hi all,

Just a couple of comments in passing...

My view is that SCTP compression is going to be done, sooner or later.  And rohc feels like a logical place to do it (but it would be nice if an SCTP activist could confirm, for example, that SCTP has a place in the mobile environment)...  In practice, I assume that the main point of the request is to solicit assertions that SCTP compression is necessary?  And I guess I'll have to leave that to others..!

Technically, it's not immediately clear to me what work *needs* to be done on SCTP header compression, at least in the short term.  After all, one of the questions has to be: can we re-use the approach being developed for TCP?  The obvious next step, I suppose, would be an equivalent of the TCP behaviour (sorry, 'behavior') draft?

Cheers,

Mark.

> -----Original Message-----
> From: Lars-Erik Jonsson (EAB) 
> [mailto:[email-masked]]
> Sent: 15 January 2003 15:38
> To: [email-masked]'
> Cc: [email-masked]'; [email-masked]'; Allison Mankin (E-mail)
> Subject: [rohc] Removing SCTP header compression from the ROHC charter
> 
> 
> ROHCers (cc sigtran & tsvwg),
> 
> The current ROHC WG charter has SCTP header compression listed as
> one of our work items.  When this item was added, activity within
> the ROHC WG was high, and the addition was made as a prediction of
> future expectations rather than an outcome of well justified
> immediate requirements.
> 
> Trying to fulfill this work item during the last year, we have
> repeatedly asked for contributions to SCTP header compression, but
> we have not received a single response.
> 
> Given that this work item was originally added without immediate
> market pull, and considering the lack of current interest in doing
> the work (or even having it done at all), we intend to remove SCTP
> header compression from the ROHC WG charter.  To keep it in the
> charter, justifications for developing SCTP header compression now
> would have to be presented, as well as industry support and
> commitments for doing the actual work.
> 
> Barring further input, we will send a request to the ADs by Jan 24,
> so please reply before this date if you believe SCTP header
> compression should be on the agenda now.
> 
> /Lars-Erik & Carsten
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Fri, 24 Jan 2003 10:13:01 -0000

> we have not received a single response.

We published a first version of an SCTP compression profile in
draft-west-sctp-epic-00.txt. This draft is based on the formal header
compression notation (see draft-ietf-rohc-formal-notation-00.txt),
so we intend to update the SCTP draft once the formal notation draft
is finalised.

> commitments for doing the actual work.

This work item is important because, unlike for TCP, there is currently
no published scheme for SCTP compression. This will hinder the
deployment of SCTP, particularly in the mobile environment.

Regarding the industry support, we're currently working on SCTP
compression at the moment in the form of the notation draft. Once this
work is done we'll publish an updated version of our SCTP profile.

> compression should be on the agenda now.

I believe that SCTP compression should remain on the ROHC charter.

Regards,

Richard