Subject: [rohc] Torture test - 2.4. SHA-1

From: "Lajos Zaccomer (ETH)" <[email-masked]>
Date: Fri, 17 Jan 2003 12:07:57 +0100

Hi,

The test of subject starts with 36480 available cpb (if defaut cycles_per_bit = 16 is used) in our implementation. I think it's all right, because the sigcomp message is 160 bytes long, thus available cpb = (1000 + 8 * 160) * 16 = 36480 < 66327 that the execution of the whole test costs. The result is decompression failure when trying to execute the 3rd SHA-1.
I suggest that this should also be corrected in the next draft that it could be executed with default cpb.

BR/Zacco
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Fri, 17 Jan 2003 14:42:58 -0000

Hi,

For this particular test we deliberately use more than the
default number of UDVM cycles. It's important to test the SHA-1
instruction with the largest possible input size of 65535 bytes
(e.g. to make sure that it doesn't cause any buffers to overflow),
which means that the total cost of the test must be at least 2^16
UDVM cycles.

Would it be useful to have a note in the draft pointing out that
since the test needs a total of 66327 UDVM cycles, it must be
executed with a cpb of at least 32?

Regards,

Richard

> -----Original Message-----
> From: Lajos Zaccomer (ETH) [mailto:[email-masked]]
> Sent: Friday, January 17, 2003 11:08 AM
> To: [email-masked]
> Subject: [rohc] Torture test - 2.4. SHA-1
>
>
> Hi,
>
> The test of subject starts with 36480 available cpb (if
> defaut cycles_per_bit = 16 is used) in our implementation. I
> think it's all right, because the sigcomp message is 160
> bytes long, thus available cpb = (1000 + 8 * 160) * 16 =
> 36480 < 66327 that the execution of the whole test costs. The
> result is decompression failure when trying to execute the 3rd SHA-1.
> I suggest that this should also be corrected in the next
> draft that it could be executed with default cpb.
>
> BR/Zacco

---

From: "Lajos Zaccomer (ETH)" <[email-masked]>
Date: Fri, 17 Jan 2003 15:44:01 +0100

Hi,

I think it would be useful to describe a default test configuration at the beginning, and any alteration from that should be indicated before each test.

BR/Zacco

-----Original Message-----
From: Price, Richard [mailto:[email-masked]]
Sent: Friday, January 17, 2003 3:43 PM
To: 'Lajos Zaccomer (ETH)'; [email-masked]
Subject: RE: [rohc] Torture test - 2.4. SHA-1

Hi,

Regards,

Richard

---

From: "Price, Richard" <[email-masked]>
Date: Fri, 17 Jan 2003 14:57:28 -0000

Hi,

That sounds like a good idea, so I'll make sure to add it for the
next version of the torture tests.

Regards,

Richard

> Sent: Friday, January 17, 2003 2:44 PM
> To: Price, Richard; [email-masked]
> I think it would be useful to describe a default test
> configuration at the beginning, and any alteration from that
> should be indicated before each test.
>
> BR/Zacco
>