Subject: [rohc] SigComp and State

From: "Valerie Kenneally" <[email-masked]>
Date: Thu, 23 Jan 2003 18:10:47 -0000

Hi All,

	I am currently studying SigComp and am trying to understand each of the
different entities it entails.  RFC 3320 has the following explanation

"State Handler-the entity that can store and retrieve state. State is
information that is stored between SigComp messages, avoiding the need to
upload the data on a per-message basis."

I am trying to comprehend this idea of "State".  So I have the following
questions:

1.  Is state the uncompressed message details that are being sent on the
compressor side and the decompressed message on the receiving/decompressor
side?
2.  If this is the case and we create a state identifier on the compressor
side for the first message ever to be transmitted, is this state identifier
transmitted to the remote end-point along with the SigComp message, not for
decompression purposes in this case but in order to save state in the
decompressor side?

3.  If we send a Sigcomp message with a state identifier to be used for
decompression then are the state identifiers existent in the two
communicating endpoints mirror images of each other?  In other words do we
have mirror compartments at communicating entities?

Really hoping someone can clear up my understanding
Regards,
Val

-------------------Legal  Disclaimer---------------------------------------

The above electronic mail transmission is confidential and intended only for the person to whom it is addressed. Its contents may be protected by legal and/or professional privilege. Should it be received by you in error please contact the sender at the above quoted email address. Any unauthorised form of reproduction of this message is strictly prohibited. The Institute does not guarantee the security of any information electronically transmitted and is not liable if the information contained in this communication is not a proper and complete record of the message as transmitted by the sender nor for any delay in its receipt.

----------------------------------------------------------------------------------------

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lajos Zaccomer (ETH)" <[email-masked]>
Date: Fri, 24 Jan 2003 09:40:00 +0100

Hi Val,

I'm trying to answer your question the best I can.

A state may contain anything you want. In most cases, states are simply decompressed messages or just a part of them. But one can store other information in a state, for example a number identifying a message, or state length as it can not be retrieved with the STATE-ACCESS instruction. Only imagination limits what you can put into a state.

The state id should not be sent in the message. The STATE-CREATE instruction produces a state id for the state to be saved.

Not necessarily. If a state id is used to access a state, the state memory should be handled in a way that the sate can be accessed. But it does not mean we have mirror compartments. Think of dropped messages and shared states e.g!