Subject: RE: [rohc] a dummy application protocol (DAP) for SigComp interop

From: [email-masked]
Date: Mon, 27 Jan 2003 18:09:14 -0600

Here is the revised version of DAP:
- added "need-response" header field
- clarified how to derive a globally unique compartment-ID
- clarified on the "peer compartments"
- renamed "global-ID" to "endpoint-ID"

Please provide your comments promptly. The interop is close
and it would be good to freeze this asap. (Let's keep it
simple for now. We can always improve it later before the 
next interop.)

BR,
Zhigang

> -----Original Message-----
> From: Liu Zhigang.C (NRC/Dallas) 
> Sent: January 27, 2003 10:17 AM
> To: 'ext Lajos Zaccomer (ETH)'; [email-masked]
> Subject: RE: [rohc] a dummy application protocol (DAP) for SigComp
> interop
> 
> 
> The receiving node is also a sending node. It can can always send a DAP
> message in the reverse direction on which sigcomp signals can be piggybacked. 
> But you have a good point that it should be made explicit in the DAP.
> I'll send a revised version soon.
> 
> Zhigang
> 
> > -----Original Message-----
> > From: ext Lajos Zaccomer (ETH) 
> [mailto:[email-masked]]
> > Sent: January 27, 2003 5:30 AM
> > To: Liu Zhigang.C (NRC/Dallas); [email-masked]
> > Subject: RE: [rohc] a dummy application protocol (DAP) for SigComp
> > interop
> > 
> > 
> > Hi,
> > 
> > How will we test feedback, returned parameters and extended 
> > features with DAP? It seems that the receiving node is indeed 
> > a receiver and cannot be instructed to send me anything.
> > 
> > Zacco
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Saturday, January 25, 2003 2:04 AM
> > To: [email-masked]
> > Subject: [rohc] a dummy application protocol (DAP) for 
> SigComp interop
> > 
> > 
> > Hi,
> > 
> > Attached is a simple protocol that can be used for the 
> > interop test during SIPit in February. 
> > 
> > Your comments are welcome.
> > 
> > Zhigang
> > 
>

---

From: "Adam Roach" <[email-masked]>
Date: Mon, 27 Jan 2003 19:32:42 -0600

> - added "need-response" header field

I thought we had discussed having a *counter*, not a TRUE/FALSE value.
That way, you can avoid accidental infinite loops, *and* it makes it much
easier to run a test of, say, 4 back-and-forth messages (e.g. to retrive
state) than a simple TRUE/FALSE. Here's some text.

line-7 = "hops-left" ":" 1*digit

- If the header line-7 of a received DAP message is greater than zero, the
receiver will send back a response message to the sender. As mentioned
above, the response message must be compressed by and sent from the
local compressor compartment that is peer of the remote compressor
compartment. Line-7 of the response message will carry the value that
is one less than the value of line-7 from the received message.
Other than these constraints, the response message can carry
arbitrary message-header and message-body. For testing, the
message-body of a response may contain the message-header
of the original message that triggered the response.

/a

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc