Subject: RE: [rohc] Genration incrementation in RFC 2507

From: "Dintakurthi, Satyanarayana V" <[email-masked]>
Date: Tue, 7 Jan 2003 11:19:29 -0800

Hi Gaurav,

Please see my answers below.

-----Original Message-----
From: Gaurav Bhargava [mailto:[email-masked]] 
Sent: Tuesday, January 07, 2003 6:57 AM
To: 'rohc'
Subject: [rohc] Genration incrementation in RFC 2507

Hello All,

I have a doubt regarding the generation value for Non TCP Header Compression as per IPHC.  

The RFC 2507 states that generation value is incremented "if the header changes the context" in the compressor. 

I understand the concept of streams for a Non TCP case is implementation based. But if we take a normal case where for IP/UDP header I take all the DEF fields to define a context and hence a stream. Meaning I take IP src, dest addr, UDP src, dest ports as the fields which identify a context.

My question now is when one of these fields change, should I not go for a change in CID ? 

When the DEF fields change, it is a different packet stream and hence the CID changes.

If so then in what scenarios do I increase the generation for a CID/Context ?

There are a few cases in the RFC, in which the generation value is incremented, but the CID remains the same.

One situation is, when any of the NOCHANGE field which is not part of the DEF changes, the generation value is incremented to indicate the new version of the context. There could be other situations like this mentioned in the RFC.

Thanks in advance.

Warm Regards,

Gaurav

Any other comments on this are welcome.

Regards,

Satya

---

From: "Gaurav Bhargava" <[email-masked]>
Date: Wed, 8 Jan 2003 11:03:38 +0530

Thanks Satya.
I got the point.

Warm Regards,
Gaurav
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Dintakurthi, Satyanarayana V
Sent: Wednesday, 8 January 2003 12:49 AM
To: [email-masked]; rohc
Subject: RE: [rohc] Genration incrementation in RFC 2507

Hi Gaurav,

-----Original Message-----
From: Gaurav Bhargava [mailto:[email-masked]]
Sent: Tuesday, January 07, 2003 6:57 AM
To: 'rohc'
Subject: [rohc] Genration incrementation in RFC 2507

Hello All,

I have a doubt regarding the generation value for Non TCP Header Compression
as per IPHC.
The RFC 2507 states that generation value is incremented “if the header
changes the context” in the compressor.

I understand the concept of streams for a Non TCP case is implementation
based. But if we take a normal case where for IP/UDP header I take all the
DEF fields to define a context and hence a stream. Meaning I take IP src,
dest addr, UDP src, dest ports as the fields which identify a context.

My question now is when one of these fields change, should I not go for a
change in CID ?
When the DEF fields change, it is a different packet stream and hence the
CID changes.

If so then in what scenarios do I increase the generation for a CID/Context
?
There are a few cases in the RFC, in which the generation value is
incremented, but the CID remains the same.
One situation is, when any of the NOCHANGE field which is not part of the
DEF changes, the generation value is incremented to indicate the new version
of the context. There could be other situations like this mentioned in the
RFC.

Thanks in advance.

Warm Regards,
Gaurav

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************