Subject: RE: [rohc] COPY_LITERAL and COPY_OFFSET torture test

From: "Lajos Zaccomer (ETH)" <[email-masked]>
Date: Fri, 17 Jan 2003 15:05:00 +0100

Hi,

The updated draft still does not inform the users to set at least 32K UDVM memory. Either this notification should be inserted or the test should be modified that it can be run with UMS=2048. I vote for the latter one.
If the parameters may change test by test, there should be a short configuration instruction at the beginning of each test.

BR/Zacco

-----Original Message-----
From: Price, Richard [mailto:[email-masked]]
Sent: Tuesday, December 10, 2002 12:04 PM
To: 'Mural Kumar'; [email-masked]
Subject: RE: [rohc] COPY_LITERAL and COPY_OFFSET torture test

Hi Mural,

You're right that some of the torture tests require more than
4K of UDVM memory. For this particular test a minimum of 32K is
required, so it's correct for the UDVM to give an "out of memory"
error when running with only 4K.

Regards,

Richard

-----Original Message-----
From: Mural Kumar [mailto:[email-masked]]
Sent: Monday, December 09, 2002 2:55 AM
To: [email-masked]
Subject: [rohc] COPY_LITERAL and COPY_OFFSET torture test

Hi,
  I'm having problems with my UDVM on sigcomp torture test for COPY_LITERAL and COPY_OFFSET. Problem arises while executing LOAD ($offset, 1) instruction. The contents of udvm at address "offset" and "offset+1" are 0x40 and 0x40 before executing the LOAD instruction. So, LOAD fails claiming "address out of udvm memory" (I allocated 4k to UDVM). 
Does sigcomp tests expects 64k memory for UDVM? Did anyone had any problems executing this particular torture test?
thanks in advance,
murali.

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Fri, 17 Jan 2003 14:30:42 -0000

Hi,

Thanks for reminding me of this! I thought I'd updated all of the
tests to run in 2K but it looks like I missed one. Let me know
if there are any others so that they can be fixed in the next
version of the draft.

Regards,

Richard

> From: Lajos Zaccomer (ETH) [mailto:[email-masked]]
> Sent: Friday, January 17, 2003 2:05 PM
> To: Price, Richard; [email-masked]
> The updated draft still does not inform the users to set at 
> least 32K UDVM memory. Either this notification should be 
> inserted or the test should be modified that it can be run 
> with UMS=2048. I vote for the latter one.
> If the parameters may change test by test, there should be a 
> short configuration instruction at the beginning of each test.
> 
> BR/Zacco
> 
>   I'm having problems with my UDVM on sigcomp torture test 
> for COPY_LITERAL and COPY_OFFSET. Problem arises while 
> executing LOAD ($offset, 1) instruction. The contents of udvm 
> at address "offset" and "offset+1" are 0x40 and 0x40 before 
> executing the LOAD instruction. So, LOAD fails claiming 
> "address out of udvm memory" (I allocated 4k to UDVM). 
> Does sigcomp tests expects 64k memory for UDVM? Did anyone 
> had any problems executing this particular torture test?
> thanks in advance,
> murali.
> 
> 
> 
> 
> Do you Yahoo!?