Subject: [rohc] receiving uncompressed message

From: Chan Kwang Mien <[email-masked]>
Date: Sun, 19 Jan 2003 21:06:13 +0800

hi,

i would like to know what would happen if a SigComp-enabled host receives
uncompressed messages.
can the first 5 bits of the first byte (which is 11111) of a SigComp
message be used to detect whether the message is a SigComp message ? 
if it isn't then the message is an uncompressed message and would be passed
to the application without going through SigComp progressing. 
Does it make sense ?

Thanks!!

regards,
Kwang Mien

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Price, Richard" <[email-masked]>
Date: Mon, 20 Jan 2003 11:35:57 -0000

Hi Kwang Mien,

The first 5 bits of the SigComp header are included so that SigComp
messages can be distinguished from ordinary application messages.
If the bits aren't set to "11111" then the message is ignored by
SigComp and passed straight to the application.

Regards,

Richard

> -----Original Message-----
> From: Chan Kwang Mien [mailto:[email-masked]]
> Sent: Sunday, January 19, 2003 1:06 PM
> To: [email-masked]
> Subject: [rohc] receiving uncompressed message
> 
> 
> hi,
>