Subject: RE: [rohc] SigComp interoperability test

From: "West, Mark (ITN)" <[email-masked]>
Date: Mon, 13 Jan 2003 23:48:25 -0000

Calling all potential sigcomp interoperability test victims...

(and with many thanks to Robert, for your comments and suggestions for kicking off testing at SIPit.)

I'm certainly keen to do some SigComp testing -- we've had the RFC for *ages* now! ;-)
However (and this statement is verging on the heretical, but...) I don't really have any interest in SIP.  Worse still, I don't have SigComp integrated with a SIP stack [*gasp*].

Now, it's clear that 'SigComp for SIP' is a pretty major area of testing for a lot of people, and that's cool.  Personally, I also feel that there is a need for a degree of testing to be done purely at the SigComp level.  The vexed question is: will there be a chance to do any of this at SIPit?  (Would we even be allowed through the door?!)

Anyway, this begs a couple of questions that I'll throw open to the floor...
i) Is anyone else planning on attending SIPit with a view to doing SigComp testing (in any form?)
ii) If your answer to (i) is 'yes', then are you prepared to spend more than half a day getting to grips with some dedicated SigComp interoperability issues?

Don't be shy!  Let me know what you think...

TIA,

Mark.

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: 20 December 2002 16:45
> To: Surtees, Abigail
> Cc: [email-masked]; [email-masked]
> Subject: Re: [rohc] SigComp interoperability test
> 
> 
> 
> On Wed, 2002-12-18 at 13:04, Surtees, Abigail wrote:
> > Hi,
> > 
> > A quick question about the proposed SigComp testing at 
> SIPit, having had a look at the test description document...
> > 
> > It looks like the plan is to test 'SIP over SigComp' - i.e. 
> with SigComp integrated into a SIP stack.  Obviously we've 
> done a fair amount of UDVM testing (torture tests, etc.) and 
> a small amount of SigComp testing.  So, can we assume that 
> SigComp itself will be sufficiently tested by the SIP 
> exchanges?  (Or that SigComp will be previously/subsequently 
> tested in some (as yet undefined) standalone manner?)  Is 
> anyone prepared to confirm or deny this assumption?!
> 
> One way to get at least a thumbnail answer to that question 
> is to start
> an outline of an interop statement for sigcomp and see how 
> much of that
> statement could be filled out based on tests we're currently 
> describing.
> That effort is also likely to suggest further tests we can 
> document and
> perform.
> 
> > 
> > Also how much time is going to be allocated to testing 
> SigComp at SIPit?  (Our main interest would be in testing 
> SigComp -- we don't really have any interest in taking part 
> in general SIP tests...)
> As much time as there is interest. We have a side area for multiparty
> tests that run continually through the event. We typically have
> coordinated efforts taking a half day each, but if there is a group
> that wants to spend the whole week focusing on one thing, the
> resources are there for them to do so. Realistically, I'd expect
> there to be 1/2 to 1 day on this.
> 
> > 
> > Kind regards,
> > 
> > Abbie
> > 
> > Abbie Surtees
> > Engineer
> > Internet Applications and Mobility
> > Roke Manor Research Ltd
> > Tel:   +44 (0) 1794 833131
> > 
> > 
> > _______________________________________________
> > Rohc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/rohc
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Jan Christoffersson (EAB)" <[email-masked]>
Date: Tue, 14 Jan 2003 10:33:35 +0100

Hi,
Yes, Ericsson will be there with our implementation to do some SigComp testing.
It would be good if we could agree on some high level test cases before the meeting.

Is anyone else planning to participate in the SigComp testing? Nokia? Dynamicsoft?

Regards
Jan

-----Original Message-----
From: West, Mark (ITN) [mailto:[email-masked]]
Sent: den 14 januari 2003 00:48
To: Robert Sparks; Surtees, Abigail
Cc: [email-masked]; [email-masked]
Subject: RE: [rohc] SigComp interoperability test

TIA,

Mark.