Subject: RE: [rohc] RE: External Encoding Methods (was: RE: ROHC-FN Snapsh ot - Wednes day's update)

From: "Finking, Robert" <[email-masked]>
Date: Thu, 30 Sep 2004 16:50:22 +0100

I've added the following issue, I hope this captures it. If you disagree, shout up!

Issue8: "External" methods must be specified in the profile

Document: 	draft-ietf-rohc-formal-notation 	Section: 	4.8.7 External encoding methods
Category: 	Technical 	Priority: 	Must Fix
Status: 	No Discussion 	Assigned To: 	
Comment: 	

Created on 2004-09-30.15:37:57 by Raffles, last changed 2004-09-30.15:37:57.
Messages
msg11 	Author: Raffles 	Date: 2004-09-30.15:37:57

Encoding methods which are external to the FN in a profile
(i.e. those encoding methods which aren't primitive to the
FN and aren't defined as structures or lists with the
profile's FN), must be rigorously defined in the non FN part
of the profile, rather than just by referencing a definition
in another document.

-----Original Message-----
From: Finking, Robert 
Sent: Thursday, September 30, 2004 4:45 PM
To: 'Carsten Bormann'; Ghyslain Pelletier (LU/EAB)
Cc: Carsten Bormann; Lars-Erik Jonsson (LU/EAB); [email-masked]
Subject: RE: [rohc] RE: External Encoding Methods (was: RE: ROHC-FN Snapsh ot - Wednes day's update)

]>> Interesting.
]>> How would you define ipv4_inferred_checksum except in english?
]>> (How would you define "irregular" except in english?)
]>
]> I meant using the english language in an more or less informal manner, 
]> such as this possiblity was open in the latest version of the draft 
]> using the exemple (although it was flagged as not recommended to do 
]> so):
]>
]>    crc_field ::= _four_bit_crc; % see 
]> www.ciphersbyritter.com/ARTS/CRCMYST.HTM
]
]Ah, I hadn't seen this.
]This one we don't want.
]My assumption was that there was going to be a section in the 
]specification that makes use of FN that defines painstakingly (in 
]english language) what a _four_bit_crc is on both its uncompressed and 
]compressed side.

Ah OK, my bad, Mark and I may have misunderstood the intention here - or maybe it was just me ;-) I'll add that to the issues list... (I'm adding both things that have been decided need doing, and also things that we need to decide whether to do or not)

Cheers

Raffles

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Sep 2004 17:59:06 +0200

On Sep 30 2004, at 17:50 Uhr, Finking, Robert wrote:

> must be rigorously defined in the non FN part

They might be rigorously defined in the non FN part of the profile 
using language that references a definition in another document.
The point is that they must be rigorously defined, which you cannot do 
just by pointing to a document that does not rigorously define an 
encoding method.

Gruesse, Carsten