Subject: [rohc] RE: External Encoding Methods (was: RE: ROHC-FN Snapshot - Wednes day' s update)

From: "Finking, Robert" <[email-masked]>
Date: Thu, 30 Sep 2004 12:27:06 +0100

CVS merge and XML don't go so well together =( I think it worked OK when I was editing the document on behalf of all the busy people? All you need is to be able to trust that edits you submit get put in, and that there are no undisclosed edits. I'm sure Ghyslain is trustworthy! We can give CVS a go if you like, but we could get into a bad mess if we get a conflict.

One advantage of having a single editor is that everybody has to discuss things first...

Just a thought.

I'm happy to give CVS a go though if that's what everyone wants =)

Raffles

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Thursday, September 30, 2004 12:18 PM
To: Finking, Robert
Cc: Eilert Brinkmann; Ghyslain Pelletier (LU/EAB); Carsten Bormann; 'Lars-Erik Jonsson (LU/EAB)'; [email-masked]'; West, Mark; Kristofer Sandlund
Subject: Re: External Encoding Methods (was: RE: ROHC-FN Snapshot - Wednes day' s update)

On Sep 30 2004, at 13:09 Uhr, Finking, Robert wrote:

> OK, well please excuse one more non-mailing list post but... What is 
> the
> etiquette regarding posting attachments. In particular, when I pass 
> the FN
> token over to Ghyslain, should I just send him a private mail and 
> announce
> on the list that I've done so, or would it be right to attach the 
> current FN
> draft to my mail to the list?

Well, that's the problem.
Sending multi-myribytes drafts on the list is not what people want.
The right thing is to keep the draft in a repository, so everyone can 
see it, and there are revisions in the repository that are clearly 
marked with the issues that have been resolved in this revision.
(The alternative, to submit an I-D for every token handoff, is too 
slow.)

Question: Is everyone here CVS enabled? (I still have the repository 
from SigComp times open, and I could quickly give out passwords to 
everyone.)

Gruesse, Carsten

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Sep 2004 13:38:09 +0200

On Sep 30 2004, at 13:27 Uhr, Finking, Robert wrote:

> CVS merge and XML don't go so well together

Well, it's not wonderful if the XML is edited by tools that scramble 
the source layout, but even then it's not worse than sending files 
around.

> =( I think it worked OK when I was editing the document on behalf of 
> all the busy people? All you need is to be able to trust that edits 
> you submit get put in, and that there are no undisclosed edits. I'm 
> sure Ghyslain is trustworthy!

Yes, he is.  We could still use CVS to document progress.

> We can give CVS a go if you like, but we could get into a bad mess if 
> we get a conflict.

We don't have tp.

> One advantage of having a single editor is that everybody has to 

CVS does not mean that we *have* do to parallel edits.
It's just easier to submit a change this way.
We can have much smaller granularity of changes.
(And, at the current stage, I'm not sure I want to discuss every single 
wording issue.)

All this is moot if people who submit changes can't use CVS, so I'd 
like some feedback.
(Non-submitters can just use the web interface.)

Gruesse, Carsten