Subject: RE: [rohc] RE: I-D ACTION:draft-ietf-rohc-context-replication-04. txt

From: [email-masked]
Date: Fri, 24 Sep 2004 10:59:33 -0400

Ghyslain,

Based on past experience, it's good to make a spec clear. Otherwise, 
we may be hunted again by confusions in the future as we already 
saw in other specs. And the clarification doesn't require much
work: just adding two words in section 3.3.3.1 (see below) will 
do it. Or if you prefer, you can simply delete the sentence
completely. The first sentence "The criteria ... left to 
implementation" seems to be enough.

  For simplicity, contexts with the same or similar Source-IP and/or 
  Destination-IP may be considered as replicable contexts.

Br, Zhigang

> -----Original Message-----
> From: ext Ghyslain Pelletier (LU/EAB)
> [mailto:[email-masked]]
> Sent: 24 September, 2004 09:18 AM
> To: Liu Zhigang.C (Nokia-NRC/Dallas)
> Cc: [email-masked]
> Subject: RE: [rohc] RE: I-D
> ACTION:draft-ietf-rohc-context-replication-04. txt
> 
> 
> Hi Zhigang,
> 
> As said, packet formats are profile-specific, so in this 
> sense the draft does not define what field is replicated, 
> compressed or sent uncompressed in the IR-CR packet format. 
> 
> However, I understand why you raise the question, and I 
> recall that we had a discussion on the list regarding this - 
> my feeling is that the current text is inline with the 
> conclusions reached on the list.
> 
> Also, as you pointed out yourself - the text that you refer 
> to does not require anything, and in general is a fair 
> description of the general case as the wg as agreed to. I 
> thus don't think there is a need to modify this text.
> 
> Regards, 
> 
> ///Ghyslain
> 
> --
>  Ghyslain Pelletier, Dipl. Ing.
>  Wireless IP Optimizations
>  Ericsson Research, Corporate Unit
> 
>  Ericsson AB, Laboratoriegränd 11
>  Box 920, S-97128 Luleå, SWEDEN
>  Phone : +46 (0)  8 404 29 43
>  Mobile: +46 (0) 70 264 83 14
>  [email-masked]
>  http://www.ericsson.com
> 
> -----------------------------------
>  The opinions expressed in this
>  message are my personal opinions.
>  These opinions are not
>  necessarily those of my employer,
>  unless stated otherwise.
> -----------------------------------
> 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: den 24 september 2004 15:45
> > To: [email-masked]
> > Cc: Ghyslain Pelletier (LU/EAB); [email-masked]
> > Subject: RE: [rohc] RE: I-D
> > ACTION:draft-ietf-rohc-context-replication-04. txt
> > 
> > 
> > Ghyslain,
> > 
> > That's good. My question was mainly caused by the text below. 
> > They seem
> > to imply - though not require - that only context with the 
> > same source and/or
> > destination IP addresses can be used as the base context. 
> > Perhaps adding
> > a clarification in section 3.3.3.1 will help avoid future 
> confusions?
> > 
> > Section 1:
> > 
> >    Context replication allows some header fields, such as the 
> > IP source
> >    and/or destination addresses (16 octets each for IPv6), to 
> > be omitted
> >    within the special IR packet type specifically defined for
> >    replication. It also allows other fields, such as source and/or
> >    destination ports, to be either omitted or sent in a 
> > compressed form
> >    from the very first packet of the header compressed flow.
> > 
> > Section 3.3.3.1:
> > 
> >    The criteria for whether an existing context is a suitable base
> >    context for replication for a new flow are left to 
> implementations.
> >    For simplicity, contexts with the same Source-IP and/or 
> > Destination-
> >    IP may be considered as replicable contexts.
> > 
> > Br, Zhigang
> > 
> > > -----Original Message-----
> > > From: ext [email-masked] [mailto:[email-masked]]
> > > Sent: 24 September, 2004 01:50 AM
> > > To: Liu Zhigang.C (Nokia-NRC/Dallas)
> > > Cc: [email-masked]; [email-masked]
> > > Subject: RE: [rohc] RE: I-D
> > > ACTION:draft-ietf-rohc-context-replication-04. txt
> > > 
> > > 
> > > Zhigang, 
> > >  
> > > The draft does not preclude this. It is up to profiles 
> > > themselves to specify 
> > > what fields are replicated and how in the definition of the 
> > > profile-specific 
> > > part of the IR-CR packet format. 
> > >  
> > > Regards, 
> > >  
> > > /Ghyslain 
> > >  
> > > Quoting [email-masked]: 
> > >  
> > > > Ghyslain, 
> > > >  
> > > > Sorry, I forgot another general question I have: does the 
> > CR draft 
> > > > allow a new packet flow to reuse a base context that has 
> > different 
> > > > but similar source and/or destination IP addresses? 
> > > >  
> > > > Br, Zhigang 
> > > >  
> > > > _______________________________________________ 
> > > > Rohc mailing list 
> > > > [email-masked] 
> > > > https://www1.ietf.org/mailman/listinfo/rohc 
> > > >  
> > > >  
> > >  
> > >  
> > >  
> > > 
> > > 
> > 
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Fri, 24 Sep 2004 18:15:18 +0200

Making this change just creates more confusion in my opinion. The original
text explains how it works in its most simple way and is a good example.

Considering that we after duscussions of the specifics of how this should
be designed for the TCP profile case came to the conclusion that we just
replicate identical IP addresses is just another argument for not creating
more confusion, as I believe an addition of "similar" here would do.

/L-E

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, September 24, 2004 4:59 PM
Subject: RE: [rohc] RE: I-D ACTION:draft-ietf-rohc-context-replication-04.
txt

> > thus don't think there is a need to modify this text.

----------------------------------------------------------------------------
----