Subject: RE: [rohc] RE: External Encoding Methods (was: RE: ROHC-FN Snapsh ot - Wednes day's update)

From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
Date: Thu, 30 Sep 2004 16:27:07 +0200

Inline.

/Ghyslain

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Carsten Bormann
> Sent: den 30 september 2004 14:53
> To: Lars-Erik Jonsson (LU/EAB)
> Cc: Finking, Robert; [email-masked]; Carsten Bormann
> Subject: Re: [rohc] RE: External Encoding Methods (was: RE: ROHC-FN
> Snapsh ot - Wednes day's update)
> 
> 
> 
> On Sep 30 2004, at 14:40 Uhr, Lars-Erik Jonsson (LU/EAB) wrote:
> 
> > Why would you at all mention a method that is not defined in the FN?
> 
> One of the main advantages of having an FN is that it can be 
> automatically checked for completeness, inconsistencies etc.
> Cf. the use of tools like "smilint" in MIB module design.
> 
> If the FN code does not provide any indication that an 
> encoding method 
> name is, in fact, something that you expect to be defined 
> elsewhere, it 
> cannot distinguish between typos and english-language defined 
> encoding 
> methods.  Hence the idea to somehow declare the encoding methods 
> defined in english language.

Yes, we understand. However, this parsing is meant to make sure that the spec is ok, so these kind of things we must do before publication and it shouldn't belong to the FN then.
 
> The underscore notation essentially says "trust me, this is defined 
> elsewhere" at the place where the encoding method defined in english 
> language is being referenced.
> The explicit declaration provides even better error checking, but 
> requires another line in the FN code.

A profile using FN should be complete before publication, so these mechanism are not valid after that point, right? So why have then in the FN???
 
> Gruesse, Carsten
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Sep 2004 16:34:09 +0200

On Sep 30 2004, at 16:27 Uhr, Ghyslain Pelletier (LU/EAB) wrote:

> So why have then in the FN???

Ah, that's indeed a quite valid question.
The reason why I would do it this way is that you don't want to have 
manual editing steps to change the development version of the FN spec 
into the published version of the FN spec.
These are error prone.

Gruesse, Carsten