Subject: RE: [rohc] RE: I-D ACTION:draft-ietf-rohc-context-replication-04. txt

From: [email-masked]
Date: Fri, 24 Sep 2004 17:28:04 -0400

OK, so you agreed that ACK of IR packets are mandatory in O-mode.

Now, now back to my rationale for requiring IR-CR packets to be ACKed:

1) ACK of IR packets is mandatory in O- and R-mode in RFC 3095.

2) Context replication is designed for links with feedback 
channels. So, U-mode is less relevant here (the main reason
to start in U-mode as specified in RFC 3095 is that the compressor 
may not know if there is a feedback channel available).

3) IR-CR packets essentially replace the IR packets. Therefore,
it make sense to make ACK of IR-CR mandatory.

4) The base context MUST have been ACKed. So from implementation
perspective, ACK is not a new thing.

And more importantly, IR-CR actually depends on more factors than
IR packets. Even if the base context has been ACKed, there is no
guarantee that the context was not deleted by the decompressor
(e.g. after timeout) before it is used by the compressor as the
reference. (This actually is pointed out in the CR draft.) Therefore, 
ACK of IR-CR is even more critical than ACK of IR packets.

BR,
Zhigang

> -----Original Message-----
> From: ext Lars-Erik Jonsson [mailto:[email-masked]]
> Sent: 24 September, 2004 02:58 PM
> To: Liu Zhigang.C (Nokia-NRC/Dallas); [email-masked]
> Subject: Re: [rohc] RE: I-D
> ACTION:draft-ietf-rohc-context-replication-04. txt
> 
> 
> The only way to end up in O mode is by sending an ack, so you 
> will have to
> send an ack to even get into the O mode scenario. However, it 
> is of course
> fine to stay in U mode, i.e. not to ack anything at all. So, 
> to clearly
> answer
> your question, for O mode operation you will have to send an ack, but
> considering 3095 in general, there is not mandatory to ack IR.
> 
> /L-E
> 
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, September 24, 2004 9:42 PM
> Subject: RE: [rohc] RE: I-D 
> ACTION:draft-ietf-rohc-context-replication-04.
> txt
> 
> 
> > > > Thus having ACKs optional for that
> > > > transition and having the possibility to rely on the
> > > > optimistic approach is perfectly proper.
> > >
> > > I have to disagree. If IR-CR packets essentially replace 
> IR packets for
> > > establishing a context and IR packets are ACKed per RFC 
> 3095, it seems
> > > to make sense to have IR-CR packets ACKed too. The rational behind
> > > ACKing IR packets even in O-mode in RFC 3095 is that IR 
> packets are
> > > obviously very important.
> >
> > Well the reason for acking an IR is basically that you want 
> to move to
> > O-mode from the initial U-mode. However, this is all 
> optional in 3095
> 
> Lars-Erik,
> 
> Are your sure it's optional? The text below in RFC 3095 clearly
> indicates the ACK of an IR packet is NOT optional. Not to mention the
> mandatory ACKs in R-mode.
> 
> ====================================
> 5.4.2.2.  Feedback logic (O-mode)
> 
>    NC:  - When an IR packet passes the CRC check, send an ACK(O).
> 
>    SC:  - When an IR packet is correctly decompressed, send an ACK(O).
>         - When a type 2 or an IR-DYN packet is correctly decompressed,
>           optionally send an ACK(O).
> 
>    FC:  - When an IR packet is correctly decompressed, send an ACK(O).
>         - When a type 2 or an IR-DYN packet is correctly decompressed,
>           optionally send an ACK(O).
> ======================================
> 
> Br, Zhigang
> 
> 
> 
> 
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Sat, 25 Sep 2004 08:27:36 +0200

> OK, so you agreed that ACK of IR packets are mandatory in O-mode.

As ACK is needed to ever reach O-mode, yes, that is obvious! 
But this is not the same thing as saying ACK or IR is mandatory in 3095.
> "Are your sure it's optional? The text below in RFC 3095 clearly
> indicates the ACK of an IR packet is NOT optional."
U-mode operation is fine, and nothing mandates a mode transition
to O-mode even if there is a feedback channel available, it's all up
to implementation. So 3095 in general does not mandate IR acks.

> may not know if there is a feedback channel available).

Even if there is a feedback channel, you do not have to switch
from U-mode. 

> it make sense to make ACK of IR-CR mandatory.

In 3095, you do not have to ack IR's, if you stay in U-mode,
and I can not see a reason to mandate anything, especially 
since that can not actually be done. It would be the same as
mandating non-U-mode operation.

We must also remember that the whole mode thing is a
profile specific issue, so mandating IR acks of IR-CR
in the gereric CR draft would be to mandate something 
that does not have to be mandated from a technical
point of view.

/L-E