Subject: RE: [rohc] RE: I-D ACTION:draft-ietf-rohc-context-replication-04. txt

From: [email-masked]
Date: Fri, 24 Sep 2004 18:05:30 -0400

> What is it that you think is unclear, that is so important and
> makes sense to specify explicitly in this document?

Lars-Erik,

I thought I already pointed out in my email below. For your convenience,
copy-and-paste again:

> > a new context
> > to be established by reusing a base context with a different
> > but similar source and/or destination IP addresses.

And why it is so important? That is because unlike other header 
fields, IP addresses are explicitly mentioned twice in the CR draft, 
which implies they can be omitted, but not compressed. (Please see my 
previous email for the text referred to.) In particular, text in 
section 1 lists IP addresses as header fields that can be omitted 
whereas it lists port numbers as header fields that can be either 
omitted or compressed. So, you can see why it is confusing.

(In addition, everyone knows IP addresses are special since that
is practically what is used for compressor to categorize context.)

One way to avoid the confusion is to simply add a sentence (I'm
using your own words) after the mentioning of IP addresses:

"Note that The CR draft does not preclude replication of any field 
in any way, as that depends on what protocol headers are addressed 
by a profile."

Or, we can make IP addresses non-special by removing references 
to them in the CR-draft. Fair enough?

Br, Zhigang

> -----Original Message-----
> From: ext Lars-Erik Jonsson [mailto:[email-masked]]
> Sent: 24 September, 2004 03:40 PM
> To: Liu Zhigang.C (Nokia-NRC/Dallas); [email-masked]
> Cc: [email-masked]
> Subject: Re: [rohc] RE: I-D
> ACTION:draft-ietf-rohc-context-replication-04. txt
> 
> 
> There are many things the CR draft does not preclude, as many
> details are to be defined on a per-profile basis. The CR draft
> does not preclude replication of any field in any way, as that
> depends on what protocol headers are addressed by a profile.
> What is it that you think is unclear, that is so important and
> makes sense to specify explicitly in this document?
> 
> /L-E
> 
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, September 24, 2004 10:02 PM
> Subject: RE: [rohc] RE: I-D 
> ACTION:draft-ietf-rohc-context-replication-04.
> txt
> 
> 
> > > Making this change just creates more confusion in my opinion.
> >
> > Lars-Erik,
> >
> > All it does is to clarify what Ghyslain just said in his
> > email earlier, i.e. the CR draft does not preclude a new context
> > to be established by reusing a base context with a different
> > but similar source and/or destination IP addresses.
> >
> > How come it "just creates more confusion"? I become speechless.
> > If you don't like the change I proposed, how about just adding the
> > text above? I really don't care, as long as the CR draft is
> > (perhaps redundantly) clear.
> >
> > Haven't we learned enough lessons about not being clear in the past?
> >
> > Br, Zhigang
> >
> 
> 
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Sat, 25 Sep 2004 08:34:09 +0200

> in any way, as that depends on what protocol headers are addressed 

Fine with me! it does not change anything technically, but if it makes
you happier....=)

Cheers,
/L-E