Subject: [rohc] RE: External Encoding Methods (was: RE: ROHC-FN Snapshot - Wednes day's update)

From: "Finking, Robert" <[email-masked]>
Date: Thu, 30 Sep 2004 12:06:24 +0100

The idea of the leading underscore was mine I must confess. I thought it
would be useful to have a visible cue as to which encoding methods were not
formally defined in the profile in the FN. Otherwise, presented with only
the FN (and you may well argue that that would never happen), the reader has
no way of discriminating between an encoding method that the author has
forgotten to define and one which is defined externally.

Regards

Raffles

-----Original Message-----
From: Lars-Erik Jonsson (LU/EAB) [mailto:[email-masked]] 
Sent: Thursday, September 30, 2004 12:01 PM
To: Ghyslain Pelletier (LU/EAB); 'Carsten Bormann'; Finking, Robert
Cc: 'Eilert Brinkmann'; [email-masked]'; West, Mark; 'Kristofer
Sandlund'
Subject: RE: External Encoding Methods (was: RE: ROHC-FN Snapshot - Wednes
day's update)

> I don't understand - I thought that we were trying to avoid 
> leaving it open to definitions in English? Also, I don't 
> think that coding methods in 3095 should be normative for FN...
> 
> So, I really don't like the addition of in the latest version 
> of external encoding methods allowing for a definition in 
> english. I think that the idea all along has been to create a 
> library of coding methods that was as generic and as complete 
> as possible, and possibility for profiles to define addition 
> methods. In this respect, I don't even understand why 
> External Encoding Methods must be defined in the FN. Isn't it 
> enough to state that profiles can in addition define formal 
> methods? No need to underscores for that either, right?

This has confused me too....

/L-E

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Sep 2004 13:28:19 +0200

On Sep 30 2004, at 13:06 Uhr, Finking, Robert wrote:

> leading underscore

It is one way to signal "dear reader, you have to look this up in the 
english text of the specification making use of FN".
It also makes the life of the parser easier.
An alternative would be to have something like (not an actual 
suggestion):

ipv4_inferred_length === #english#;

I don't care either way.

Gruesse, Carsten