Subject: RE: [rohc] RE: External Encoding Methods (was: RE: ROHC-FN Snapsh ot - Wednes day's update)

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Thu, 30 Sep 2004 15:47:50 +0200

Thanks, then I am much more sure that I get what you are saying.

What I still do not understand is why we need the "external
encoding method" ("_") being defined by the FN. Instead of
requiring all non-FN methods used in an FN specification to
be indicated with an underscore escape character, meaning 
that a potential parser could ignore it, it should be the
parser that would just say, "I've checked the specification
according to FN. All is fine, apart from the following 
methods being undefined: method_a, method_b, method_c"

The profile writer will know that these methods are ok, right?

/L-E

> >> One of the main advantages of having an FN is that it can be
> >> automatically checked for completeness, inconsistencies etc.
> >> Cf. the use of tools like "smilint" in MIB module design.
> >
> > You are not talking about checking the notation, but checking a
> > specification making use of the notation, right??
> 
> Good point.
> 
> Let's fix the language.
> 
> FN = formal notation.  This is what is being defined in the 
> specification (oops) draft called draft-ietf-rohc-formal-notation
> 
> FN specification.  This is one specification of a header compression 
> scheme that is written in formal notation.  This is what is being 
> defined in draft-ietf-rohc-tcp, together with additional information 
> that is needed to make the specification of the header compression 
> scheme a complete one.
> 
> I'm rather guilty of sloppy language here, because I have called the 
> specification document defining the FN "the FN 
> specification", which is 
> of course hard to distinguish from "an FN specification" in the sense 
> used above.  So I'll stop hurting ourselves now...
> 
> And yes, I want to check each "FN specification" using a semantic 
> checker, not the notation itself.
> 
> Gruesse, Carsten
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Sep 2004 15:55:28 +0200

> methods being undefined: method_a, method_b, method_c"

That's how we started.
Checking a list of half a dozen (or more) such names for typos after 
each semantic check gets pretty long in the tooth quickly, though.
That's pretty much why declarations in programming languages were 
invented.

Gruesse, Carsten