Subject: RE: [rohc] SigComp implementer's guide

From: "Lajos Zaccomer (IJ/ETH)" <[email-masked]>
Date: Thu, 25 Nov 2004 12:48:28 +0100

Hi Abbie,

Could you please relocate the "nice sentence"? ("In cases where
   the behaviour of the application restricts the message flow ...") My only problem is that it looks as though it is connected with NACK, but it is definitely not.

br/Zacco

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Surtees, Abigail
> Sent: Wednesday, November 24, 2004 7:02 PM
> To: [email-masked]
> Subject: [rohc] SigComp implementer's guide
> 
> 
> Hi All,
> 
> Since the last version I think it has been agreed that the 
> following should
> be added to the implementer's guide:
> 
> The shared-mode/minimum priority issue (text already 
> discussed on the list)
> SigComp shim uncompressed bytecode
> Discussion of the frequency of state identifier clashes (as 
> presented by
> Mark in San Diego)
> Note about the minor bugs in 3485 (incorrect priorities).
> 
> Are there any other issues that I've missed?
> 
> As these 4 actually amount to a fair amount of text, I won't 
> include it here
> but have uploaded a proposed version of the draft to
> <http://sigcomp.srmr.co.uk/~ahs/draft-ietf-rohc-sigcomp-impl-g
uide-04.txt>.
All comments and alteration suggestions to the text are appreciated.  In
particular, the sections above are  5.3, 11, 7 and 12, respectively.

Best regards,

Abbie

Abbie Surtees
Senior Engineer
Roke Manor Research Ltd
Old Salisbury Lane
Romsey, SO51 0ZN
Tel:   +44 (0) 1794 833131

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Thu, 25 Nov 2004 13:43:59 -0000

Hi Zacco,

This paragraph is the overall recommendations paragraph so I'd prefer to
keep the "nice sentence" in it.  However, I see that it could be interpreted
as relating to only the second sentence in the paragraph which is, as you
say, not the intention.  How about changing it slightly to the following?

"   Consequently, where NACK is not supported or for NACK averse
   compressors, the recommendation is that only one piece of minimum
   priority state should be present in a compartment at any one time.
   If both endpoints support NACK [3], then this recommendation may be
   relaxed, but implementers should think carefully about the
   consequences of creating multiple pieces of minimum priority state.
   In either case, if the behaviour of the application restricts the
   message flow, this fact could be exploited to allow safe creation of
   multiple minimum priority states; however, care must still be taken."

Best regards,

Abbie

> From: Lajos Zaccomer (IJ/ETH) [mailto:[email-masked]] 
> Sent: Thursday, November 25, 2004 11:48 AM
> To: Surtees, Abigail; [email-masked]
> Subject: RE: [rohc] SigComp implementer's guide
> 
> 
> Hi Abbie,
> 
>    the behaviour of the application restricts the message 
> flow ...") My only problem is that it looks as though it is 
> connected with NACK, but it is definitely not.
> 
> br/Zacco
>

---

From: "Lajos Zaccomer (IJ/ETH)" <[email-masked]>
Date: Thu, 25 Nov 2004 15:41:53 +0100

Hi Abbie,

Wonderful! Thanx.

Zacco

> From: Surtees, Abigail [mailto:[email-masked]]
> Sent: Thursday, November 25, 2004 2:44 PM
> To: Lajos Zaccomer (IJ/ETH); [email-masked]
> -- 
> Visit our website at www.roke.co.uk
> 
> Roke Manor Research Ltd, Roke Manor, Romsey, Hampshire SO51 0ZN, UK.
> 
> The information contained in this e-mail and any attachments 
> is proprietary to
> Roke Manor Research Ltd and must not be passed to any third 
> party without
> permission. This communication is for information only and 
> shall not create or
> change any contractual relationship.
>