Subject: RE: [rohc] ROHC-FN uncompressed field encodings list

From: "Finking, Robert" <[email-masked]>
Date: Mon, 8 Nov 2004 09:04:17 -0000

> 
> > Out of interest, what was wrong with the old way of doing it?
> 
> Convenience.  The specs are long enough at they are.
> (But then, I have no idea what "old way" you have in mind.)
> 

OK, fair point! This is what I meant (using the same example as previously):

  foo ===
  {
    uncompressed_format_1 = field_1,
                            field_2;

    uncompressed_format_2 = field_1,
                            field_3;

    default_encodings =
    {
      field_1 ::= some encoding method;
    }

    compressed_format_1 = field_1,
                          field_2
    {
       let(some_condition);
       field_2 ::= some encoding method;
    };

    compressed_format_2 = field_1,
                          field_3
    {
       let(some_condition);
       field_3 ::= some encoding method;
    };
  }

Which I think is negligibly less verbose that the new suggestion, but
certainly no more so, and I think clearer (though of course others may
differ).

So, my question is, what was wrong with the above? If nothing is wrong with
that, then can you give me a minimal example that demonstrates the problem.
Thanks.

Regards

Raffles

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Nov 2004 06:43:17 -0500

>        field_3 ::= some encoding method;

This gives you four combinations, of which two are ill-defined (no 
encoding method has been given for one of the fields).

Of course, you could propose to have combinations simply fail where 
there are undefined encoding methods.
This, of course, hinges on having an appropriate field name that you 
can make this decision on.  Hard to read, too (in typical complex 
cases).

Allowing field definitions in uncompressed formats strikes me as 
simpler, because it removes an unnecessary asymmetry, by the way.

Gruesse, Carsten