Subject: [rohc] SigComp implementer's guide

From: "Surtees, Abigail" <[email-masked]>
Date: Wed, 24 Nov 2004 18:01:55 -0000

Hi All,

Since the last version I think it has been agreed that the following should
be added to the implementer's guide:

The shared-mode/minimum priority issue (text already discussed on the list)
SigComp shim uncompressed bytecode
Discussion of the frequency of state identifier clashes (as presented by
Mark in San Diego)
Note about the minor bugs in 3485 (incorrect priorities).

Are there any other issues that I've missed?

As these 4 actually amount to a fair amount of text, I won't include it here
but have uploaded a proposed version of the draft to
<http://sigcomp.srmr.co.uk/~ahs/draft-ietf-rohc-sigcomp-impl-guide-04.txt>.
All comments and alteration suggestions to the text are appreciated.  In
particular, the sections above are  5.3, 11, 7 and 12, respectively.

Best regards,

Abbie

Abbie Surtees
Senior Engineer
Roke Manor Research Ltd
Old Salisbury Lane
Romsey, SO51 0ZN
Tel:   +44 (0) 1794 833131

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked]
Date: Thu, 25 Nov 2004 09:53:53 +0530

Hi All,
        I have picked up deflate code from zlib.org. I have observed 
following problems in it.
              1.        I set the static dictionary before calling 
deflate. function calling sequence is
         deflateInit(&objZstream, 8);
         deflateSetDictionary(&objZstream, .................)
         deflate(&objZstream, Z_FINISH);

         The problem is that I get 6 extra characters in compressed 
packet. To get rid of the problem I remove first 6 characters from the 
compressed packet and send it to decompressor. Decompressor is able to 
decompress the compressed message only after removing first 6 characters.
 
           2.  while debugging using Valgrind tool I found that one 
function in deflate code is using un-initialized variable.

 I am suspecting that 1st problem might be because of 2nd problem.

 Please give me any pointer if any of you have faced this kind of problem.

Thanks
Harish

***********************  HSS-Private   ***********************

"Please note:The email domain of Hughes Software Systems Ltd. has been changed to "hssworld.com" from hss.hns.com"

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited (HSS) and is intended 
solely for the use of the individual to whom it is addressed. It may contain  privileged or 
confidential information and should not be circulated or used for any purpose other than for 
what it is intended. If you have received this message in error, please notify the originator 
immediately. If you are not the intended recipient, you are notified that you are strictly 
prohibited from using, copying, altering, or disclosing the contents of this message. HSS 
accepts no responsibility for loss or damage arising from the use of the information transmitted 
by this email including damage from virus."