Subject: [rohc] ROHC-FN attributes - an inconsistency

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Thu, 24 Feb 2005 15:17:37 +0100

I've found one inconsistency in the ROHC-FN draft when it comes to
attributes. Section 3.2.1 talks about fields and encodings and says
the following about attributes:

  "Fields have attributes.  Attributes describe various things about the
   field, including the length of the field and whereabouts the field
   appears in the header.  For example:

     field:has_context

   indicates whether or not a context entry exists for this field."

However, section 4.3, which actually define what attributes are, says:

  "The notation defines six attributes, three for the uncompressed field
   and a corresponding three for the compressed field.  The attributes
   available for each field are as follows:

   uncompressed attributes of a field:
   o  "uncomp_value", "uncomp_length" and "uncomp_hdr_start",

   compressed attributes of a field:
   o  "comp_value", "comp_length" and "comp_hdr_start"."

Clearly, "has_context" is not one of the attributes defined, so I
think it is a rather bad attribute example for section 3.2.1.

/L-E

-----------------------------------
Lars-Erik Jonsson, M.Sc.
Senior Research Engineer
Wireless IP Optimizations
AWARE - Advanced Wireless Algorithm Research
Ericsson Research, Corporate Unit
Ericsson AB
Box 920, S-971 28 Luleå, Sweden
E-mail: [email-masked]                      /"\
Phone: +46 8 404 29 61                                      \ /
Fax: +46 920 996 21               ASCII Ribbon Campaign      X
Home: +46 920 999 57           against HTML email & vCards  / \

My opinions are my personal opinions and should not be considered
as the opinions of my employer, if not explicitly stated.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Finking, Robert" <[email-masked]>
Date: Thu, 24 Feb 2005 14:39:58 -0000

LOL - well spotted, thanks. I'll change the example. We removed that
attribute last week (along with a load of other stuff we don't use). It was
a vestige of list encoding.

Regards

Raffles

> -----Original Message-----
> From: Lars-Erik Jonsson (LU/EAB) 
> [mailto:[email-masked]] 
> Sent: Thursday, February 24, 2005 2:18 PM
> To: [email-masked]'
> Subject: [rohc] ROHC-FN attributes - an inconsistency
> 
>