Subject: RE: [rohc] SigComp user guide updates - LZJH message

From: "Surtees, Abigail" <[email-masked]>
Date: Tue, 28 Jun 2005 11:43:08 +0100

Hi Cristian,

I've had a quick look at this.  Our 2 decompressed messages differ in the first decompressed byte so it should be possible to quickly see what's happening.
We get '.'= 0x2e and you get 0x00.

I've looked at the bytecode and the message and here's what happens at our VM:

The first compressed byte is 0x5c = 0b 01011100, 
a single bit is read 0b0 (reading from the right, because the P bit is 1) 
This leaves 0b 0101110 in the compressed buffer.
The single bit of zero indicates an ordinal,
so 7 bits are then read as 0b 0111010 (reading right to left)
and then reversed (due to the F bit) to become 0b 010 1110 = 0x2e.

I hope this helps.  I'd be grateful is someone else can indicate whether or not they get the same decompressed message as we do.

Best regards,

Abbie

> -----Original Message-----
> From: Cristian CONSTANTIN [mailto:[email-masked]] 
> Sent: Friday, June 24, 2005 7:42 PM
> To: Surtees, Abigail
> Cc: [email-masked]
> Subject: Re: [rohc] SigComp user guide updates
> 
> 
> On Mon, Jun 06, 2005 at 02:57:29PM +0100, Surtees, Abigail wrote:
> > Hi All,
> > 
> > Other than the on-going discussions about "!", the user guide seems
> > pretty stable.  
> > 
> > One thing that I think it would be useful to add is the uncompressed
> > version of each of the sample messages.   If there are no 
> objections,
> > I'll propose some text to that effect.  Before I do, can 
> someone confirm
> > that they agree with me what the uncompressed messages are? 
>  I believe
> > they are:
> > 
> > Simplified LZSS: 	"The Restaurant at the End of the Universe\n"
> > LZSS:			"Oh no, not again!"
> > LZW:		  	"So long and thanks for all the fish!\n"
> > DEFLATE: 		"Life, the Universe and Everything\n"
> > LZJH: 		"...spending a year dead for tax purposes.\n"
> 
> cristian: am I the only one getting something else here?
> (see attachment)
> 
> > EPIC: 		"Arthur leapt to his feet like an 
> author hearing the
> > phone ring"
> > 
> > Are there any other changes/additions for the user guide?  
> (I'll fix the
> > colour typo too. ;-)
> > 
> > Best regards,
> > 
> > Abbie
> > 
> > 
> > Abbie Surtees
> > Senior Engineer
> > Roke Manor Research Ltd
> > Old Salisbury Lane
> > Romsey, SO51 0ZN
> > Tel:   +44 (0) 1794 833131
> > 
> > 
> > _______________________________________________
> > Rohc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/rohc
> 
> -- 
>  _          | There are many people who use UNIX or Linux  
> (_'_        | who IMHO do not understand UNIX.
>   (_'rist   |              --David Korn  
> GPG public key at wwwkeys.de.pgp.net
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Tue, 28 Jun 2005 20:10:29 +0200

> I hope this helps.  I'd be grateful is someone else can indicate whether or not they get the same decompressed message as we do.

cristian: thanks a lot, abbie; unfortunately the one-liner perl script
which converted my hex dump into ascii was buggy and that's how 0x00
appeared in the ascii version. in fact the first byte produced by my
udvm is also 0x2e. the second and several others were different...

anyway, I have managed to fix the stupid bug in my code as well; which
appeared only when F-reversing bit strings of length 1 :-)) I guess
that's why I have got no errors with the other udvm examples/tests.

however, I can confirm now that I get:

"...spending a year dead for tax purposes.\n" 

as well.

thanks again.
bye now!
cristian