Subject: [rohc] UDP SN in UDP/IP in Unidirectional mode (no feedback channel)

From: [email-masked]
Date: Wed, 15 Jun 2005 18:22:58 +0200 (MEST)

Hello!

I am new on ROHC topic, so maybe this question is simple to answer for some
of you

In ROHC Profile 2 (UDP/IP) it is stated that compressor generates a 16 bit
UDP Sequence number (SN) which is used as RTP SN.

But if using ROHC Profile in U-mode with no feedback channel availible at
all, what is the purpose of UDP SN? Is it only needed for feedback? Or
whatfor does decompressor need it?

Thanks in advance and regards
Dario

-- 
Geschenkt: 3 Monate GMX ProMail gratis + 3 Ausgaben stern gratis
++ Jetzt anmelden & testen ++ http://www.gmx.net/de/go/promail ++

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Thu, 16 Jun 2005 08:39:20 +0200

The sequence number is used both for identification, i.e. when sending
feedback (as you mentioned), and as a kernel field for compression of
other fields, most specifically the RTP timestamp and the IP-ID. Since
the UDP profile is defined as a variant of the RTP profile, there had
to be a SN introduced to serve the same functions as the RTP SN do in
the RTP profile.

Note further that also the upcoming TCP profile has a compressor-
generated SN, called MSN (Master Sequence Number).

Rgds,
/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: den 15 juni 2005 18:23
> To: [email-masked]
> Subject: [rohc] UDP SN in UDP/IP in Unidirectional mode (no feedback
> channel)
> 
> 
> Hello!
> 
> I am new on ROHC topic, so maybe this question is simple to 
> answer for some of you
> 
> In ROHC Profile 2 (UDP/IP) it is stated that compressor 
> generates a 16 bit UDP Sequence number (SN) which is used
> as RTP SN.
> 
> But if using ROHC Profile in U-mode with no feedback channel 
> availible at all, what is the purpose of UDP SN? Is it only
> needed for feedback? Or whatfor does decompressor need it?
>