Subject: [rohc] Puzzle about RFC3095 CID be filled in PDCP PDU header

From: "LI_JING" <[email-masked]>
Date: Mon, 5 Dec 2005 12:06:09 +0800

Dear experts,
　　　　　　　　
　　  In   3GPP TS 25.323.450, description in
     5.1.3.2        Mapping of PID values for RFC 3095 with CIDs in PDCP PDU Header

    " If this method is configured by upper layers, PDCP shall not introduce CIDs in the ROHC packet format."　

     Because  ROHC packet has following fixed frame format, 
+---+--- --- --- +--- --- --------+
:              Add-CID octet           :                   if (CID 1-15) and (small CIDs)
+---+--- --- --- +--- --- --------+
| type indication   |     body           |                1 octet (8-x bits of body)
+---+--- ---+---+---+--- --- ---+
: :
/     0, 1, or 2 octets of CID          /              1 or 2 octets if (large CIDs)
: :
+---+---+---+---+---+---+---+---+
/              body                               /              variable length
+---+---+---+---+---+---+---+---+

which kind of following understanding is reasonable ?
   1> "PDCP shall not introduce CIDs in the ROHC packet format",so all CID octets in ROHC be set to 0 or be filled with
padding bits;
    2> or all CID octets disappear; and  ROHC packet format changed.

    In my mind,  it would cause mess if we change ROHC packet format  just because we get no need to fill 
effective CID in it.

   How about your ideas ?　　　　　　　　
　　　　　　　　　　　　　　　　
BR
LI JING  
TEL: (+86)029-87916666-6075
Mail: [email-masked]
****************************************************************
This e-mail and its attachments contain confidential information 
from DATANG MOBILE, which is intended only for the person or entity
whose address is listed above. Any use of the information contained 
herein in any way (including, but not limited to, total or partial
 disclosure, reproduction, or dissemination) by persons other than 
the intended recipient(s) is prohibited. If you receive this e-mail 
in error, please notify the sender by phone or email immediately 
and delete it!  Thank you.
*****************************************************************
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Mon, 5 Dec 2005 15:41:15 +0100

I consider it an unfortunate mistake that 3GPP specified this alternative 
way of transmitting the ROHC CIDs, thereby introducing additional 
complexity. An even bigger mistake was to introduce this alternative without 
clearly specifying it. The idea is of course to do 2>, which should be the 
way to implement it to get interoperability. However, not using this obscure 
variant (where a non-rohc part handles rohc functionality) is of course 
desirable, when it can be avoided.

/L-E

----- Original Message ----- 
From: "LI_JING" <[email-masked]>
To: "rohc" <[email-masked]>
Sent: Monday, December 05, 2005 5:06 AM
Subject: [rohc] Puzzle about RFC3095 CID be filled in PDCP PDU header

Dear experts,
　　　　　　　　
　　  In   3GPP TS 25.323.450, description in
     5.1.3.2        Mapping of PID values for RFC 3095 with CIDs in PDCP PDU 
Header

    " If this method is configured by upper layers, PDCP shall not introduce 
CIDs in the ROHC packet format."　

     Because  ROHC packet has following fixed frame format,
+---+--- --- --- +--- --- --------+
:              Add-CID octet           :                   if (CID 1-15) and 
(small CIDs)
+---+--- --- --- +--- --- --------+
| type indication   |     body           |                1 octet (8-x bits 
of body)
+---+--- ---+---+---+--- --- ---+
: :
/     0, 1, or 2 octets of CID          /              1 or 2 octets if 
(large CIDs)
: :
+---+---+---+---+---+---+---+---+
/              body                               /              variable 
length
+---+---+---+---+---+---+---+---+

which kind of following understanding is reasonable ?
   1> "PDCP shall not introduce CIDs in the ROHC packet format",so all CID 
octets in ROHC be set to 0 or be filled with
padding bits;
    2> or all CID octets disappear; and  ROHC packet format changed.

    In my mind,  it would cause mess if we change ROHC packet format  just 
because we get no need to fill
effective CID in it.

   How about your ideas ?　　　　　　　　
　　　　　　　　　　　　　　　　
BR
LI JING

--------------------------------------------------------------------------------