Subject: [rohc] ROHC Module

From: "Naveed Rehman" <[email-masked]>
Date: Thu, 15 Dec 2005 17:41:02 +0000

Hello,

Could anyone tell me where I can find a PPP independant ROHC module.

Regards

Naveed

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Klaus Warnke" <[email-masked]>
Date: Fri, 16 Dec 2005 11:25:51 +0100 (CET)

Hello Naveed,

there is a GPL implemantation of RoHC on SF:

http://rohc.sourceforge.net/

Maybe this can be used without PPP.
Here are many other RoHC links:

http://www.topology.org/comms/rohc.html

BR

On Thu, December 15, 2005 6:41 pm, Naveed Rehman wrote:
> <html><div style='background-color:'><P>Hello,</P>
> <P>Could anyone tell me where I can find a PPP independant ROHC
> module.</P>
> <P>Regards</P>
> <P>Naveed</P>
> <P>&nbsp;</P>
> <P><BR>&nbsp;</P>
> <DIV class=RTE></DIV></div></html>
>
>

-- 
Klaus Warnke
[email-masked]

---

From: Pedro Fortuna <[email-masked]>
Date: Fri, 16 Dec 2005 13:28:51 +0000

Hello,

AFAIK, that implementation cannot be used without PPP. If you want to
use it above a L2
technology you have to adapt the code for that. It shouldn't be too
dificult as the PPP code is easy to spot. Unfortunely that
implementation does not include a lot of RoHC stuff .e.g IPv6 profile,
so make sure it includes what you need.

If you ever find another open source implementation of RoHC please let me know.

Regards,
Pedro Fortuna

--
Cumprimentos,
Pedro Fortuna