Subject: [rohc] Sigcomp Torture Test discrepancy

From: "John Barber" <[email-masked]>
Date: Wed, 21 Dec 2005 22:10:08 -0000

Hi all,
 
I have a disagreement with the expected result of one of the Torture
Tests
(http://www.ietf.org/internet-drafts/draft-ietf-rohc-sigcomp-torture-tes
ts-03.txt).
 
For the test A.3.5, Bytecode state creation, execution of the first
message is said to consume 67 UDVM cycles. My figure is 66.
 
The instructions executed and the number of cycles are as follows:
 
COPY (length 8)   1 + 8  = 9 cycles
STATE-CREATE (state_length 8) 1 + 8 = 9 cycles
LOAD = 1 cycle
COPY (length 8) 1 + 8 = 9 cycles
STATE-CREATE (state_length 8) 1 + 8 = 9 cycles
STATE-CREATE (state_length 8) 1 + 8 = 9 cycles
JUMP = 1 cycle
INPUT-BYTES (length 1) 1 + 1 = 2 cycles
OUTPUT (output_length 2) 1 + 2 = 3 cycles (note: output_length is 3 in
the assembler code, but the code is modified to give an output_length of
2 at the time the instruction is executed, so this is the value that
should be used)
END-MESSAGE (state_length 13) 1 + 13 = 14 cycles
 
Total of above = 66 cycles.
 
If I have made a mistake in the above, please could you let me know
where I have gone wrong? Otherwise if I am right, perhaps this could be
logged as a correction for the next version of the document...
 
Whilst I'm on the subject, two other incredibly minor issues:
1. Section 2.5, page 12, quotes offsets of 178 for overlap_end and 163
for overlap_start. I am seeing values of 177 and 162 instead, whether
running my own assembled code or the supplied bytecode. This does not
affect the result of the test, however.
2. Section 2.16, page 29, there seems to be a missing "at (512)"
statement immediately before the label ":state_start"
 
Regards, John
 
P.S. I would like to add that the Torture Test document has been an
incredibly useful resource during my Sigcomp implementation. Many thanks
to all involved for producing such a detailed set of tests.
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Fri, 23 Dec 2005 10:21:23 -0000

Hi John,
 
You are right - I've just run the test on our vm and it does take 66
cycles - this appears to be a typo or relic.  Your other comments are
also correct.
 
However, this draft has now been approved by the IESG for publication as
an informational RFC (see
http://www1.ietf.org/mail-archive/web/rohc/current/msg04084.html).
 
Lars-Erik, if there is no objection within the working group, is it
possible to take account of these comments before RFC publication or is
it too late?
 
Best regards and Merry Christmas,
 
Abbie

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] On
Behalf Of John Barber
	Sent: Wednesday, December 21, 2005 10:10 PM
	To: [email-masked]
	Subject: [rohc] Sigcomp Torture Test discrepancy

	Hi all,
	 
	I have a disagreement with the expected result of one of the
Torture Tests
(http://www.ietf.org/internet-drafts/draft-ietf-rohc-sigcomp-torture-tes
ts-03.txt).
	 
	For the test A.3.5, Bytecode state creation, execution of the
first message is said to consume 67 UDVM cycles. My figure is 66.
	 
	The instructions executed and the number of cycles are as
follows:
	 
	COPY (length 8)   1 + 8  = 9 cycles
	STATE-CREATE (state_length 8) 1 + 8 = 9 cycles
	LOAD = 1 cycle
	COPY (length 8) 1 + 8 = 9 cycles
	STATE-CREATE (state_length 8) 1 + 8 = 9 cycles
	STATE-CREATE (state_length 8) 1 + 8 = 9 cycles
	JUMP = 1 cycle
	INPUT-BYTES (length 1) 1 + 1 = 2 cycles
	OUTPUT (output_length 2) 1 + 2 = 3 cycles (note: output_length
is 3 in the assembler code, but the code is modified to give an
output_length of 2 at the time the instruction is executed, so this is
the value that should be used)
	END-MESSAGE (state_length 13) 1 + 13 = 14 cycles

	If I have made a mistake in the above, please could you let me
know where I have gone wrong? Otherwise if I am right, perhaps this
could be logged as a correction for the next version of the document...
	 
	Whilst I'm on the subject, two other incredibly minor issues:
	1. Section 2.5, page 12, quotes offsets of 178 for overlap_end
and 163 for overlap_start. I am seeing values of 177 and 162 instead,
whether running my own assembled code or the supplied bytecode. This
does not affect the result of the test, however.
	2. Section 2.16, page 29, there seems to be a missing "at (512)"
statement immediately before the label ":state_start"
	 
	Regards, John
	 
	P.S. I would like to add that the Torture Test document has been
an incredibly useful resource during my Sigcomp implementation. Many
thanks to all involved for producing such a detailed set of tests.

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Fri, 30 Dec 2005 12:14:11 +0100

Abbie,

Please address these corrections in the RFC AUTH48 stage, with
cc to WG chairs and ADs.

Thanks,
/L-E

----Original Message----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Surtees, Abigail
Sent: den 23 december 2005 11:21
To: John Barber; [email-masked]; Lars-Erik Jonsson (LU/EAB)
Subject: RE: [rohc] Sigcomp Torture Test discrepancy

> Hi John,
> 
> You are right - I've just run the test on our vm and it does
> take 66 cycles - this appears to be a typo or relic.  Your
> other comments are also correct.
> 
> However, this draft has now been approved by the IESG for
> publication as an informational RFC (see
> Lars-Erik, if there is no objection within the working group,
> is it possible to take account of these comments before RFC
> publication or is it too late?
> 
> 	From: [email-masked]
> [mailto:[email-masked]] On Behalf Of John Barber
> 	I have a disagreement with the expected result of one
> of the Torture Tests
> (http://www.ietf.org/internet-drafts/draft-ietf-rohc-sigcomp-t
> orture-tests-03.txt). 
> 
> 	For the test A.3.5, Bytecode state creation, execution
> of the first message is said to consume 67 UDVM cycles. My
> figure is 66.
> 
> 	OUTPUT (output_length 2) 1 + 2 = 3 cycles (note:
> output_length is 3 in the assembler code, but the code is
> modified to give an output_length of 2 at the time the
> instruction is executed, so this is the value that should be used)
> 	If I have made a mistake in the above, please could you
> let me know where I have gone wrong? Otherwise if I am right,
> perhaps this could be logged as a correction for the next
> version of the document...
> 
> 	1. Section 2.5, page 12, quotes offsets of 178 for
> overlap_end and 163 for overlap_start. I am seeing values of
> 177 and 162 instead, whether running my own assembled code or
> the supplied bytecode. This does not affect the result of the test,
> however. 
> 	2. Section 2.16, page 29, there seems to be a missing
> "at (512)" statement immediately before the label ":state_start"
> 
> 	Regards, John
> 
> 	P.S. I would like to add that the Torture Test document
> has been an incredibly useful resource during my Sigcomp
> implementation. Many thanks to all involved for producing
> such a detailed set of tests.