Subject: [rohc] about "P" value for WLSB decode

From: "LI_JING" <[email-masked]>
Date: Tue, 13 Dec 2005 10:03:45 +0800

Dear experts,
　　　　　　　　
　　　  Sure we know, for WLSB encode, "K" value in compress side was concluded from compress side. Generally speaking ,suppose we want to fill SN  with "K"  value (for example, N)into  the  the choiced packet type:
      if  the N less than the max  bits number (for example, M)for the choiced packet type ,in fact, we'll fill M bits
of  LSB SN into the packet. So far, everything is OK.

           When decompress side receive above packet, we use M instead of N ,as "K" value in decompress side,to calculate "P" value of SN for decompress side. If the "P"value at decompress side is totally different from "P"value at compress side, how could we sure to rebirth the same SN as for compress side ? 

            In other words, for WLSB encoding side and decoding side, is it a must to keep same K  value and P value for given coding field to regenerate it correctlly ?

　　　　　　　　　
　　　　　　　　　　　　　　　　
BR
LI JING  
TEL: (+86)029-87916666-6075
Mail: [email-masked]
****************************************************************
This e-mail and its attachments contain confidential information 
from DATANG MOBILE, which is intended only for the person or entity
whose address is listed above. Any use of the information contained 
herein in any way (including, but not limited to, total or partial
 disclosure, reproduction, or dissemination) by persons other than 
the intended recipient(s) is prohibited. If you receive this e-mail 
in error, please notify the sender by phone or email immediately 
and delete it!  Thank you.
*****************************************************************
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carl Knutsson <[email-masked]>
Date: Tue, 13 Dec 2005 09:39:01 +0100

Hi,

Please find the answers inline..

Regards,

/Carl Knutsson, Effnet AB

LI_JING wrote:
> Dear experts,
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡
> ¡¡¡¡¡¡  Sure we know, for WLSB encode, "K" value in compress side was 
> concluded from compress side. Generally speaking ,suppose we want to 
> fill SN  with "K"  value (for example, N)into  the  the choiced packet type:
>       if  the N less than the max  bits number (for example, M)for the 
> choiced packet type ,in fact, we'll fill M bits
>            When decompress side receive above packet, we use M instead 
> of N ,as "K" value in decompress side,to calculate "P" value of SN for 
> decompress side. If the "P"value at decompress side is totally different 
> from "P"value at compress side, how could we sure to rebirth the same SN 
> as for compress side ?

The size of k-value is given by size of the field for the compressed 
packet type. The p-value is specified per profile and field (see section 
5.7 for RTP, section 5.11 for UDP and section 5.12 for ESP).

>  
>             In other words, for WLSB encoding side and decoding side, is 
> it a must to keep same K  value and P value for given coding field to 
> regenerate it correctlly ?

yes, see comment above.

>  
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡
> BR
> LI JING  
> Mail: [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>