Subject: [rohc] Liaison request from 3GPP2

From: Thomas Narten <[email-masked]>
Date: Fri, 26 May 2006 14:45:57 -0400

ROHC WG:

3GPP2 has sent the following request to the ROHC WG.

> The RoHC WG is currently working on revising the IP/UDP/RTP profiles
> defined in RFC 3095 to add support for reordering among other
> things. Reordering support in RoHC is extremely important for 3GPP2,
> since packets can arrive out-of-order due to handoffs as well as ARQ
> techniques at the physical and higher layers. Based on the RoHC WG
> charter, the WG is expected to produce a couple of related documents 
> RoHC framework draft and Revised IP/UDP/RTP profiles draft.

> Both these documents are essential for 3GPP2. We would greatly
> appreciate it if you could provide us the target completion dates of
> the above drafts. Also, we request that the work on these documents
> be completed as soon as possible.

(It doesn't appear the WG has discussed these, as I find no record in
the WG archives. Also, I can't tell of ROHC met in Dallas. There was a
slot for ROHC on the published agenda, but the proceedings say the WG
didn't meet.)

Can someone please report on the status of the following two
documents:

 - draft-ietf-rohc-rfc3095bis-framework
 - draft-ietf-rohc-rfc3095bis-improvements

Are they close to being finished? Are there known outstanding issues
that need to be addressed? 
 
Thomas

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Ghyslain Pelletier \(LU/EAB\)" <[email-masked]>
Date: Fri, 26 May 2006 21:29:32 +0200

Thomas, RoHCers,

The output that 3GPP2 expect from this WG in the liaison is actually three documents:

  - draft-ietf-rohc-rfc3095bis-improvements (to be published as Informational)
  - draft-ietf-rohc-rfc3095bis-framework (to be published as PS)
  - RoHCv2 profiles (to be published as PS, does not exist publicly yet)

So, there is a whole draft missing here as you can see. I've already notified Rohit Kapoor (which I believe is involved in 3GPP2 std?) that I will submit a draft describing the updated RoHC profiles (RoHCv2 profiles) by the cut-off date for initial submissions. I have already notified the WG chair of the upcoming draft as well. Look for draft-pelletier-rohcv2-profiles-00.txt by mid-June. I've already updating my priority list with this one on top.

>  - draft-ietf-rohc-rfc3095bis-framework

This draft specifies the RoHC framework. It does not include any update to profiles. In my opinion, it is already ready for a wglc, however there is no point in having a wglc until its companion draft describing the updated profiles (RoHCv2 profiles) is also ready for wlgc. Currently as I wrote above, this draft only exists on my computer, i.e. it is yet to be available as a draft individual submission, but I'm a couple of week for making it available.

>  - draft-ietf-rohc-rfc3095bis-improvements

This draft is meant to be published as informational. It contains suggested improvement for the updated RoHC profiles (RoHCv2 profiles) as agreed on the mailing list. However, it is of not really of any help to 3GPP2 as it only describes what should be done for the RoHCv2 profiles. It is some kind of "requirements" document
 
> Are they close to being finished? Are there known outstanding
> issues that need to be addressed?

I think there has been only limited discussions of the framework and the improvements draft on the mailing list, nothing at a physical meeting. The RoHC WG hasn't met at last IETF. I am not sure yet if there will be a WG meeting in Montreal, but I think it may be good to have one to discuss how to move forward on this issue. Should we push the chairman to request a meeting slot in Montreal? Any opinions? Anyone interested in meeting physically to discuss how to move this work forward once I've sent in the base draft for the updated profiles?

Regards,

/Ghyslain

--
 Ghyslain Pelletier, Dipl. Ing.
 Wireless IP Optimizations
 Ericsson Research, Corporate Unit

 Ericsson AB, Laboratoriegränd 11
 Box 920, S-97128 Luleå, SWEDEN
 Phone : +46 (0)  8 404 29 43
 Mobile: +46 (0) 70 264 83 14
 Ghyslain.Pelletier at ericsson.com
 http://www.ericsson.com

-----------------------------------
 The opinions expressed in this
 message are my personal opinions.
 These opinions are not
 necessarily those of my employer,
 unless stated otherwise.
-----------------------------------

Thomas Narten wrote:
>> defined in RFC 3095 to add support for reordering among other things.
>> Reordering support in RoHC is extremely important for 3GPP2, since
>> packets can arrive out-of-order due to handoffs as well as ARQ
>> Â­ RoHC framework draft and Revised IP/UDP/RTP profiles draft.
> 
> (It doesn't appear the WG has discussed these, as I find no
> record in the WG archives. Also, I can't tell of ROHC met in
> Dallas. There was a slot for ROHC on the published agenda,
> but the proceedings say the WG didn't meet.)
> 
> Are they close to being finished? Are there known outstanding
> issues that need to be addressed?
> 
> Thomas
>

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Wed, 31 May 2006 16:27:31 +0200

Thomas, Ghyslain, others,

(filling in some details in the excellent summary from Ghyslain)

> So, there is a whole draft missing here as you can see. I've
> already notified Rohit Kapoor (which I believe is involved in
> 3GPP2 std?) that I will submit a draft describing the updated
> RoHC profiles (RoHCv2 profiles) by the cut-off date for
> initial submissions. I have already notified the WG chair of
> the upcoming draft as well. Look for
> draft-pelletier-rohcv2-profiles-00.txt by mid-June.

That is excellent, I hope we can then get discussions going on
this draft, and the intent would then be to turn this document
into the envisioned WG draft.

Ghyslain, for alignment with the WG draft name, which will be:
   draft-ietf-rohc-rfc3095bis-profiles-00.txt,
please name the upcoming initial individual draft similarily:
   draft-pelletier-rohc-rfc3095bis-profiles-00.txt

> This draft specifies the RoHC framework. It does not include
> any update to profiles. In my opinion, it is already ready
> for a wglc, however there is no point in having a wglc until
> its companion draft describing the updated profiles (RoHCv2
> profiles) is also ready for wlgc. Currently as I wrote above,
> this draft only exists on my computer, i.e. it is yet to be
> available as a draft individual submission, but I'm a couple
> of week for making it available.
> 
> This draft is meant to be published as informational. It
> contains suggested improvement for the updated RoHC profiles
> (RoHCv2 profiles) as agreed on the mailing list. However, it
> is of not really of any help to 3GPP2 as it only describes
> what should be done for the RoHCv2 profiles. It is some kind
> of "requirements" document
> 
> I think there has been only limited discussions of the
> framework and the improvements draft on the mailing list,
> nothing at a physical meeting.

Well, the improvements draft has been discussed point-by-point
before it even became a separate draft (discussions were 
carried out while it was part of draft-ietf-rohc-rtp-impl-guide),
establishing consensus for all items. However, I believe it is
reasonable to believe some people may have additional ideas to
bring for v2, and such ideas should then be brought to the mail
list. If not, the improvements  draft as it currently looks is
what consitutes the technical direction for the profiles draft.

> Should we push the chairman to request a meeting slot in
> Montreal? Any opinions?

A meeting slot will be requested!

/L-E

---

From: "Ghyslain Pelletier \(LU/EAB\)" <[email-masked]>
Date: Wed, 31 May 2006 16:31:54 +0200

Lars-Erik,

>    draft-pelletier-rohc-rfc3095bis-profiles-00.txt

I don't really agree with this, as the RoHCv2 profiles are not meant to
replace the already existing profiles, but rather to create an updated
variants without replacing the current profiles. In other words, new
profile numbers should be issued by IANA. So I don't see the RoHCv2
profiles draft having the "bis" in its name.

For the framework draft, it is already borderline but less of an issue
as it is compatible with RFC3095, but I am not sure it is really a "bis"
either, unless a bis can update and replace only a part of an existing
specification.

/Ghyslain

Lars-Erik Jonsson (LU/EAB) wrote:
>> So, there is a whole draft missing here as you can see. I've already
>> notified Rohit Kapoor (which I believe is involved in
>> 3GPP2 std?) that I will submit a draft describing the updated RoHC
>> profiles (RoHCv2 profiles) by the cut-off date for initial
>> submissions. I have already notified the WG chair of the upcoming
>> draft as well. Look for draft-pelletier-rohcv2-profiles-00.txt by
>> mid-June.
> 
> That is excellent, I hope we can then get discussions going
> on this draft, and the intent would then be to turn this
> document into the envisioned WG draft.
> 
>> This draft specifies the RoHC framework. It does not include any
>> update to profiles. In my opinion, it is already ready for a wglc,
>> however there is no point in having a wglc until its companion draft
>> describing the updated profiles (RoHCv2
>> profiles) is also ready for wlgc. Currently as I wrote above, this
>> draft only exists on my computer, i.e. it is yet to be available as a
>> draft individual submission, but I'm a couple of week for making it
>> available. 
>> 
>> This draft is meant to be published as informational. It contains
>> suggested improvement for the updated RoHC profiles
>> (RoHCv2 profiles) as agreed on the mailing list. However, it is of
>> not really of any help to 3GPP2 as it only describes what should be
>> done for the RoHCv2 profiles. It is some kind of "requirements"
>> document 
>> 
>> I think there has been only limited discussions of the framework and
>> the improvements draft on the mailing list, nothing at a physical
>> meeting.
> 
> Well, the improvements draft has been discussed
> point-by-point before it even became a separate draft
> (discussions were carried out while it was part of
> draft-ietf-rohc-rtp-impl-guide), establishing consensus for
> all items. However, I believe it is reasonable to believe
> some people may have additional ideas to bring for v2, and
> such ideas should then be brought to the mail list. If not,
> the improvements  draft as it currently looks is what
> consitutes the technical direction for the profiles draft.
> 
>> Should we push the chairman to request a meeting slot in Montreal?
>> Any opinions?
>

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Wed, 31 May 2006 16:44:13 +0200

Ghyslain, 

>> please name the upcoming initial individual draft similarly:
> I don't really agree with this, as the RoHCv2 profiles are
> not meant to replace the already existing profiles, but
> rather to create an updated variants without replacing the
> current profiles. In other words, new profile numbers should
> be issued by IANA. So I don't see the RoHCv2 profiles draft having
> the "bis" in its name.

There is no single meaning associated with the use of "bis". The
two new documents specify an updated version of the protocol
specified by 3095, therefore it can be called a bis to 3095. Of
course it will have to be allocated new profile numbers since it
is not identical to 3095, but that is irrelevant when it comes
to naming. 

For this working group, bis is a proper name for the work we
are now doing producing an updated version of our current
protocol(s). This work will thus be captured in three documents
with consistent names:
- draft-ietf-rohc-rfc3095bis-improvements
- draft-ietf-rohc-rfc3095bis-framework
- draft-ietf-rohc-rfc3095bis-profiles

/L-E