Subject: [rohc] Sigcomp Record Marking

From: Srinivas R Thota <[email-masked]>
Date: Fri, 19 May 2006 14:04:16 +0530

Why does Sigcomp use record marking for finding the compressed message 
delimiter,
can't this be done by having the length of Sigcomp message in Sigcomp 
message header ?

Regards,
Srinivas R Thota

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "West, Mark" <[email-masked]>
Date: Fri, 19 May 2006 09:40:50 +0100

Srinivas,

SigComp has to run over UDP and TCP.  For UDP there's an implicit length (derived from the payload length).  For TCP there has to be explicit length indication (either, as you suggest, by including the length in the header; or by marking records).

We went for record marking, so as not to have different versions of the header.

Cheers,

Mark.

-----Original Message-----
From: Srinivas R Thota [mailto:[email-masked]]
Sent: Fri 5/19/2006 9:34 AM
To: [email-masked]
Subject: [rohc] Sigcomp Record Marking

Regards,
Srinivas R Thota