Subject: [rohc] question about rohc tcp profile

From: ben ata ibtissem <[email-masked]>
Date: Thu, 30 Nov 2006 14:29:05 +0100 (CET)

hello,
I implement the profile rohc tcp of rohc ,but i have
one probleme, in fact for rohc to transit from one
mode to an other i.e for example from unidirectionnel
mode to o mode or R mode, it use the feedbacks and
especially the field mode in witch the decompressor 
indicate what mode he wish to use , but for the
feedbacks of tcp this field(mode field ) don't exist
so  it can't transit from one mode to an other , to my
opinion since the tcp is usally bidirectionnel and all
is acquitted so the profile rohc tcp we allways be in
the R mode
the question is:is it, my opinion, true or not, and if
it is true , we wil have an other problem in fact rohc
always start in the Unidirectionnel mode so how can i
do i.e can i initialise the mode directly in  the R
mode or i can't?
thank you 

		
___________________________________________________________________________ 
Yahoo! Mail réinvente le mail ! Découvrez le nouveau Yahoo! Mail et son interface révolutionnaire.
http://fr.mail.yahoo.com

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "West, Mark" <[email-masked]>
Date: Thu, 30 Nov 2006 13:56:31 -0000

There is no 'R' mode in ROHC TCP -- this may explain why it appears hard to find... ;-)

The compressor can operate with or without feedback; it simply assumes that feedback will be used if and when it receives some feedback.  (i.e. this is much less complex than the modes and 'transition logic' from RFC 3095.)

It is also worth noting that, although TCP is bi-directional, this does not necessarily follow for any particular link-layer, over which ROHC TCP could be run.

Cheers,

Mark.

-----Original Message-----
From: ben ata ibtissem [mailto:[email-masked]]
Sent: Thu 11/30/2006 1:29 PM
To: [email-masked]
Subject: [rohc] question about rohc tcp profile
 
hello,