Subject: [rohc] Sigcomp Users guide - basic question

From: tana m <[email-masked]>
Date: Wed, 29 Nov 2006 13:39:30 -0800 (PST)

Could someone please clarify?

In the Deflate bytecode section of 4464, why are 3 bits being read first as extra lengt h bits even before the Input-huffman starts reading bits to decode ? I was expecting to see 3 bits being read to indicate the block type (01). 

Thanks.

---------------------------------
Cheap Talk? Check out Yahoo! Messenger's low PC-to-Phone call rates.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Thu, 30 Nov 2006 10:39:49 -0000

Hi,

I should also have pointed out that all the bytecode provided in the rfc
is an *example* of bytecode that could be used for each algorithm.  It
may not be the best/most efficient way to write it and it's up to the
implementer whether/how to make use of it, the other mechanisms
described in the rfc and anything else you come up with yourself.

Best regards,

Abbie

> -----Original Message-----
> From: cco [mailto:[email-masked]] 
> Sent: 30 November 2006 10:31
> To: Surtees, Abigail
> Cc: tana m; [email-masked]
> Subject: Re: [rohc] Sigcomp Users guide - basic question
> 
> On Thu, Nov 30, 2006 at 10:02:30AM -0000, Surtees, Abigail wrote:
> > Hi Tana,
> >  
> > The bits that are read are the block type, but the Deflate bytecode 
> > assumes the block type so they are read (to remove them from the
> > message) but not used.  When reading input, you have to put it 
> > somewhere and extra_length_bits is not in use at that point 
> so that's 
> > where they're put (rather than having to add another 2byte 
> 'variable' 
> > that's never used).
> >  
> > I hope that makes sense.
> 
> cristian: what is maybe important to be stressed once again: 
> the bytecode in the rfc decompresses only fixed Huffman codes 
> blocks (see 3.2.6. Compression with fixed Huffman codes 
> (BTYPE=01), rfc1951)
> 
> bye now!
> cristian
>