Subject: [rohc] question about rohc tcp profile

From: ben ata ibtissem <[email-masked]>
Date: Tue, 28 Nov 2006 00:28:49 +0100 (CET)

Hello,
I implement the profile ROHC-TCP of the ROHC
compression method according to the ietf draft , but i
don't understand how to choose the good packet to send
from the different formats of ROHC-TCP compressed
packets.
for example, i consider the case where ipid is
sequential , i have IR, IR-DYN, 8 others formats of
compressed packets and the common format but , i
implemented all these packets but i don't know how the
compressor can decide of the good compressed packet to
send from all these packet  enumerated above.
i will be grateful if you can answer me.
thank you

		
___________________________________________________________________________ 
Découvrez une nouvelle façon d'obtenir des réponses à toutes vos questions ! 
Profitez des connaissances, des opinions et des expériences des internautes sur Yahoo! Questions/Réponses 
http://fr.answers.yahoo.com

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Finking, Robert" <[email-masked]>
Date: Tue, 28 Nov 2006 08:54:43 -0000

Wow -that was fast- well done!

I am sure Kris will give a more helpful answer, but the bottom line is, it is up to you.

We have purposely avoided specifying a means of choosing a particular format from the many available to give the implementer as much flexibility as possible. To achieve optimum compression you need to choose a sequence of formats whose combined lengths are as shorter than any other sequence. A fairly good approximation of this is to treat each header separately and send the shortest format which safely communicates the header you are currently compressing.

So, a simple sensible answer is just "pick the shortest" (subject to availability of necessary context etc.)

I hope that helps a little.

Regards

Raffles

> -----Original Message-----
> From: ben ata ibtissem [mailto:[email-masked]] 
> Sent: Monday, November 27, 2006 11:29 PM
> To: [email-masked]
> Subject: [rohc] question about rohc tcp profile
> 
> 
> Hello,
> compressor can decide of the good compressed packet to send 
> from all these packet  enumerated above. i will be grateful 
> if you can answer me. thank you
> 
> 
> 	
> 
> 	
> 		
> Profitez des connaissances, des opinions et des expériences 
> des internautes sur Yahoo! Questions/Réponses