Subject: [Roll] Which MOP for RPL AODV?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Oct 2021 06:28:43 +0000

Dear all,

RPL AODV is close to completion, congrats to the authors!
Now, there's the question of the MOP and 2 options, reuse the experimental one for P2P RPL, or take another.

Right now, the draft takes 5 and P2P has 4 (https://www.iana.org/assignments/rpl/rpl.xhtml#mop)

My observation is that P2P is the experiment that leads to AODV, so AODV should deprecate it.

I have not heard of real deployments, and if that happened, I do not expect a mix of devices that would create confusion.
So would that be OK to assign MOP 4 to RPL AODV?

Note that we only have up to 6 to play with, and the multicast and anycast supports are already on the cooking table.

Keep safe,

Pascal

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 6 Oct 2021 03:58:33 -0700

[Added the draft name to the subject to benefit my filters. ;-) ]

Pascal:

Hi!

I asked the same question (about aodv-rpl replacing/obsoleting rfc6997)
when I did my review [1] — more than two years ago!  But sadly received no
real reply from the WG — so we moved ahead with the document as it is now.
Peter brought the question back in his IoT DIT review [2] earlier this
year, but again no discussion from the WG.

It is clear to see that aodv-rpl uses some of the technology from rfc6997
and, as I understand it, a deployment would never include both.  The
question then is valid and I would love to see more interest this time
around.

Just FYI — there would need to be some process behind a move to formally
replace rfc6997 (beyond updating the draft).  We can deal with that if we
need to.

Thanks!

Alvaro.

[1] https://mailarchive.ietf.org/arch/msg/roll/XXaPFyhqiUS_bpYSJT45UaLyeec/
[2]
https://mailarchive.ietf.org/arch/msg/iot-directorate/f2GUlTDX4ppY1GKjQFqS8930ZYI/

On October 6, 2021 at 2:29:30 AM, Pascal Thubert (pthubert) (
pthubert=[email-masked]) wrote:

Dear all,

Now, there’s the question of the MOP and 2 options, reuse the experimental
one for P2P RPL, or take another.

Right now, the draft takes 5 and P2P has 4 (
https://www.iana.org/assignments/rpl/rpl.xhtml#mop)

My observation is that P2P is the experiment that leads to AODV, so AODV
should deprecate it.

I have not heard of real deployments, and if that happened, I do not expect
a mix of devices that would create confusion.

Note that we only have up to 6 to play with, and the multicast and anycast
supports are already on the cooking table.

Keep safe,

Pascal

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Wed, 06 Oct 2021 14:45:08 -0400

> AODV should deprecate it.

Agreed.

    > I have not heard of real deployments, and if that happened, I do not
    > expect a mix of devices that would create confusion.  So would that be
    > OK to assign MOP 4 to RPL AODV?

You've convinced me.

Alvaro Retana <[email-masked]> wrote:
    > Just FYI — there would need to be some process behind a move to
    > formally replace rfc6997 (beyond updating the draft).  We can deal with
    > that if we need to.

So, obsoletes RFC6997 then?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 6 Oct 2021 12:49:48 -0700

On October 6, 2021 at 2:46:25 PM, Michael Richardson wrote:

Michael:

Hi!

...
> Alvaro Retana wrote:

If that's what the WG wants then yes.

rfc6997 is required by rfc7733 (Applicability Statement...Home
Automation and Building Control), so we would need to Update that.

Also, rfc6998 (Measurement of Routing Metrics in LLNs) depends on
rfc6997: "...the utility of this mechanism is dependent on the
existence of P2P-RPL [RFC6997]."  We would need to see if rfc6998 also
works with aodv-rpl and Update or Obsolete.

None of this is a showstopper (from my point of view), but it does
require some work and most likely a new IETF LC (at least).

The alternative (just thinking out loud) would be to specify the use
of the same MOP along with some text explaining why it is not an issue
that the value is shared -- and what could happen if both device types
were mixed.  This option should require less work/process because
we're not affecting other documents.

Alvaro.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Oct 2021 20:14:11 +0000

I like the option that both RFCs use mop 4 but never coexist in a network, Alvaro. 

Even though the work that validates that AODV applies equally to P2P RPL for the 2 RFCs you mentioned would be useful and the update worthwhile.

Take care,

Pascal

> Le 6 oct. 2021 à 21:50, Alvaro Retana <[email-masked]> a écrit :
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Oct 2021 12:07:53 +0000

Hello Alvaro:

I read from the parallel thread that sharing MOP 4 between the 2 reactive versions of RPL would be OK.
I did not see a response from the authors so I’m cc’ing the draft .all list just in case.
We do not need to deprecate P2P RPL as long as it is never present in the same network as AODV RPL.
Maybe a  sentence in AODV RPL about that in the IANA section would help?

Keep safe;
Pascal

From: Alvaro Retana <[email-masked]>
Sent: mercredi 6 octobre 2021 12:59
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Which MOP for RPL AODV? (draft-ietf-roll-aodv-rpl)

Pascal:

Hi!

I asked the same question (about aodv-rpl replacing/obsoleting rfc6997) when I did my review [1] — more than two years ago!  But sadly received no real reply from the WG — so we moved ahead with the document as it is now.  Peter brought the question back in his IoT DIT review [2] earlier this year, but again no discussion from the WG.

It is clear to see that aodv-rpl uses some of the technology from rfc6997 and, as I understand it, a deployment would never include both.  The question then is valid and I would love to see more interest this time around.

Just FYI — there would need to be some process behind a move to formally replace rfc6997 (beyond updating the draft).  We can deal with that if we need to.

Thanks!

Alvaro.

[1] https://mailarchive.ietf.org/arch/msg/roll/XXaPFyhqiUS_bpYSJT45UaLyeec/
[2] https://mailarchive.ietf.org/arch/msg/iot-directorate/f2GUlTDX4ppY1GKjQFqS8930ZYI/

On October 6, 2021 at 2:29:30 AM, Pascal Thubert (pthubert) (pthubert=[email-masked]<mailto:pthubert=[email-masked]>) wrote:
Dear all,

RPL AODV is close to completion, congrats to the authors!
Now, there’s the question of the MOP and 2 options, reuse the experimental one for P2P RPL, or take another.

Keep safe,

Pascal

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 8 Oct 2021 07:30:00 -0700

Hi!

Yes, we do need to hear from the authors, who’ll need to eventually make
any needed changes.

If we’re moving forward with using MOP 4, then this is what we would need
(at least):

- IANA Considerations: request to add aodv-rpl as a reference in the
registry.

- A new section that talks about how the reuse is ok, and any consequences
of overlapping.  A requirement to not use both variations in the same
network would be fine too.

I will rely on the Chairs to decide if the discussion is enough to reach
consensus on the path forward.

Thanks!

Alvaro.

On October 8, 2021 at 8:08:09 AM, Pascal Thubert (pthubert) (
[email-masked]) wrote:

Hello Alvaro:

I read from the parallel thread that sharing MOP 4 between the 2 reactive
versions of RPL would be OK.

I did not see a response from the authors so I’m cc’ing the draft .all list
just in case.

We do not need to deprecate P2P RPL as long as it is never present in the
same network as AODV RPL.

Keep safe;

Pascal

*From:* Alvaro Retana <[email-masked]>
*Sent:* mercredi 6 octobre 2021 12:59
*To:* Pascal Thubert (pthubert) <[email-masked]>
*Cc:* Routing Over Low power and Lossy networks <[email-masked]>
*Subject:* Re: [Roll] Which MOP for RPL AODV? (draft-ietf-roll-aodv-rpl)

Pascal:

Hi!

Thanks!

Alvaro.

[2]

Dear all,

Keep safe,

Pascal

---

From: Charlie Perkins <[email-masked]>
Date: Sun, 10 Oct 2021 05:46:28 -0700

Hello folks,

I think it would be just fine to use the value of 4 for the MOP. Are 
there other changes, besides those noted below, that are needed to be 
made before issuing a new revision for the draft?

Naturally Yours,
Charlie P.

On 10/8/2021 7:30 AM, Alvaro Retana wrote:
> Hi!
>
> Yes, we do need to hear from the authors, who’ll need to eventually 
> make any needed changes.
>
> If we’re moving forward with using MOP 4, then this is what we would 
> need (at least):
>
> - A new section that talks about how the reuse is ok, and any 
> consequences of overlapping.  A requirement to not use both variations 
> in the same network would be fine too.
>
>
> I will rely on the Chairs to decide if the discussion is enough to 
> reach consensus on the path forward.
>
>
> Thanks!
>
> Alvaro.
>
> On October 8, 2021 at 8:08:09 AM, Pascal Thubert (pthubert) 
> ([email-masked] <mailto:[email-masked]>) wrote:
>
>> Hello Alvaro:
>>
>> *From:* Alvaro Retana <[email-masked] 
>> <mailto:[email-masked]>>
>> *To:* Pascal Thubert (pthubert) <[email-masked] 
>> <mailto:[email-masked]>>
>> *Cc:* Routing Over Low power and Lossy networks <[email-masked] 
>> <mailto:[email-masked]>>
>> I asked the same question (about aodv-rpl replacing/obsoleting 
>> rfc6997) when I did my review [1] — more than two years ago!  But 
>> sadly received no real reply from the WG — so we moved ahead with the 
>> document as it is now.  Peter brought the question back in his IoT 
>> DIT review [2] earlier this year, but again no discussion from the WG.
>>
>> It is clear to see that aodv-rpl uses some of the technology from 
>> rfc6997 and, as I understand it, a deployment would never include 
>> both. The question then is valid and I would love to see more 
>> interest this time around.
>>
>> formally replace rfc6997 (beyond updating the draft).  We can deal 
>> with that if we need to.
>>
>> Thanks!
>>
>> Alvaro.
>>
>> [1] 
>> https://mailarchive.ietf.org/arch/msg/roll/XXaPFyhqiUS_bpYSJT45UaLyeec/ 
>> <https://mailarchive.ietf.org/arch/msg/roll/XXaPFyhqiUS_bpYSJT45UaLyeec/> 
>>
>>
>> [2] 
>> <https://mailarchive.ietf.org/arch/msg/iot-directorate/f2GUlTDX4ppY1GKjQFqS8930ZYI/> 
>>
>>
>> On October 6, 2021 at 2:29:30 AM, Pascal Thubert (pthubert) 
>> (pthubert=[email-masked] 
>> <mailto:pthubert=[email-masked]>) wrote:
>>
>>     Dear all,
>>
>>     Now, there’s the question of the MOP and 2 options, reuse the
>>     experimental one for P2P RPL, or take another.
>>
>>     Right now, the draft takes 5 and P2P has 4
>>     (https://www.iana.org/assignments/rpl/rpl.xhtml#mop
>>     <https://www.iana.org/assignments/rpl/rpl.xhtml#mop>)
>>
>>     I have not heard of real deployments, and if that happened, I do
>>     not expect a mix of devices that would create confusion.
>>
>>     Note that we only have up to 6 to play with, and the multicast
>>     and anycast supports are already on the cooking table.
>>
>>     Keep safe,
>>
>>     Pascal
>>
>>     [email-masked] <mailto:[email-masked]>
>>     <https://www.ietf.org/mailman/listinfo/roll>
>>

---

From: Michael Richardson <[email-masked]>
Date: Sun, 10 Oct 2021 12:30:21 -0400

> network would be fine too.

Is there an upgrade consideration if we re-use?
We could also allocate a new MOP, and deprecate MOP 4, and reuse it later on.

My belief is that there are few deployments of P2P RPL today, and that a
forklift upgrade of them is acceptable.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 10 Oct 2021 17:44:00 +0000

Hello Michael

As long as no one forms a network that has both that should not be a problem, should it?

Regards,

Pascal

Le 10 oct. 2021 à 18:30, Michael Richardson <[email-masked]> a écrit :

---

From: Michael Richardson <[email-masked]>
Date: Sun, 10 Oct 2021 21:33:42 -0400

> As long as no one forms a network that has both that should not be a

The concern would be if someone was upgrading.
I don't think that there is enough deployment for this to matter.

---

From: Ines Robles <[email-masked]>
Date: Wed, 13 Oct 2021 01:33:37 +0300

Hi,

On Sun, Oct 10, 2021 at 7:30 PM Michael Richardson <[email-masked]>
wrote:

> need
> consequences
> We could also allocate a new MOP,

The current MOP in the doc is 5, I understand this would be the new MOP,
right?

> and deprecate MOP 4, and reuse it later on.
>

I think if we deprecate MOP4, it makes sense to me to assign it to
AODV-RPL, right?

> forklift upgrade of them is acceptable.

RIOT OS has implemented P2P RPL
https://api.riot-os.org/group__net__gnrc__rpl__p2p.html
But yes, I have not found further deployments.

 Thanks,
Ines.

---

From: Ines Robles <[email-masked]>
Date: Wed, 13 Oct 2021 01:58:19 +0300

Dear all,

Please let us know by 16th Oct if you have some objection to assign MOP 4
to AODV-RPL.

So far, we have these options (you can find them in the thread [1]):

*Option 1: Keep the current MOP for AODV-RPL => MOP = 5

* Option 2: Assign MOP 4 (P2P RPL) to AODV-RPL:
    -Action Points with this:
        - IANA Considerations: request to add aodv-rpl as a reference in
the registry.
        - A new section that talks about how the reuse is ok, and any
consequences of overlapping.  A requirement to not use both variations
(P2P-RPL and AODV-RPL) in the same network would be fine too.
       - Are you aware of some deployment of P2P-RPL?

*Option 3: Allocate a new MOP, deprecate MOP 4 and reuse it later on.

Please let us know your thoughts on this,

Thanks,

Ines and Dominique.
[1] https://mailarchive.ietf.org/arch/msg/roll/HaqbaOhGzM5hbHEL7rpgEgskqUY/

On Wed, Oct 6, 2021 at 1:58 PM Alvaro Retana <[email-masked]> wrote:

> expect a mix of devices that would create confusion.
>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 12 Oct 2021 19:39:01 -0400

> - Are you aware of some deployment of P2P-RPL?

Works for me.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 13 Oct 2021 06:13:08 +0000

For all I know you’re correct Ines

Regards,

Pascal

Le 13 oct. 2021 à 00:34, Ines Robles <[email-masked]> a écrit :

Hi,

On Sun, Oct 10, 2021 at 7:30 PM Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:

The current MOP in the doc is 5, I understand this would be the new MOP,  right?

I think if we deprecate MOP4, it makes sense to me to assign it to AODV-RPL, right?

RIOT OS has implemented P2P RPL https://api.riot-os.org/group__net__gnrc__rpl__p2p.html
But yes, I have not found further deployments.

 Thanks,
Ines.

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 19 Oct 2021 21:54:21 +0200

Hi Ines,

I think it is better to assign AODV_RPL using 5. Not sure why just because
not much used  P2P_RPL we change to another protocol, is this option taken
often in IETF WGs.

Best Regards
AB

On Wed, Oct 13, 2021 at 12:59 AM Ines Robles <mariainesrobles=
[email-masked]> wrote:

> https://mailarchive.ietf.org/arch/msg/roll/HaqbaOhGzM5hbHEL7rpgEgskqUY/
>
>> Note that we only have up to 6 to play with, and the multicast and
>> anycast supports are already on the cooking table.
>>
>>
>>
>> Keep safe,
>>
>>
>>
>> Pascal
>>
>>

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 19 Oct 2021 22:02:47 +0200

> As long as no one forms a network that has both that should not be a

So if the WG goes for this option of using 4 for AODV, then yes there is no
options for users to have both in one network.
Currently we have 5 available can be used, with more options for LLNs
users, so why not give more opportunities until future decisions?

AB

---

From: Michael Richardson <[email-masked]>
Date: Tue, 19 Oct 2021 18:08:23 -0400

Abdussalam Baryun <[email-masked]> wrote:
    > I think it is better to assign AODV_RPL using 5. Not sure why just
    > because not much used P2P_RPL we change to another protocol, is this
    > option taken often in IETF WGs.

Until we do RPL v2 with MOPEX, we'll have only 1 MOP value left (6).
AODV_RPL replaces/upgrades P2P_RPL.
We think that P2P_RPL isn't widely deployed.

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 20 Oct 2021 16:56:34 +0200

On Wed, Oct 20, 2021 at 12:08 AM Michael Richardson <[email-masked]>
wrote:

> I replied to the request of WG chair asking what WG thinks.
The AD commented before that there was not much discussion in WG which is
negative sign.
It is still difficult to notice what the WG thinks, so not sure what you
mean by We_think.

AB

---

From: Ines Robles <[email-masked]>
Date: Wed, 20 Oct 2021 20:30:57 +0300

Thank you Abdussalam and Michael for your comments, we will consider them.
I understand that Michael was referring to the Mailing list discussions,
where it was highlighted that P2P_RPL is not widely deployed.  Please let
us know if you are aware of some deployment.

BR,
Ines