Subject: Re: [Roll] WGLC draft-ietf-roll-aodv-rpl-12

From: Ines Robles <[email-masked]>
Date: Sun, 6 Mar 2022 22:55:12 +0200

Dear all,

Thank you very much for the comments received on this draft. The authors
are working on addressing them.

We still would like to receive further feedback, specially in the use of
the MOP=4 and its relation with P2P-RPL:

"AODV-RPL uses the "P2P Route Discovery Mode of Operation" (MOP == 4) with
   three new Options for the DIO message, dedicated to discover P2P
   routes.  These P2P routes may differ from routes discoverable by
   native RPL.  Since AODV-RPL uses newly defined Options, there is no
   conflict with P2P-RPL [RFC6997
<https://datatracker.ietf.org/doc/html/rfc6997>], a previous document
using the same
   MOP.  AODV-RPL can be operated whether or not native RPL is running
   otherwise."

Thank you very much in advance,

Ines and Dominique.

On Mon, Jan 31, 2022 at 8:52 AM Ines Robles <[email-masked]>
wrote:

> Dear all,
>
> Please find below a new version of aodv-rpl draft. This email starts a
> WGLC of one week.
>
> Please review and send your comments by 5th February.
>
> Note that this draft updates the MOP to 4  [
> https://mailarchive.ietf.org/arch/msg/roll/yNEWYkKGcrDWYfKxCaCCX96lCUY/]
>
> Thank you,
>
> Ines and Dominique.
>
> On Sun, Jan 30, 2022 at 7:27 PM <[email-masked]> wrote:
>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>> This draft is a work item of the Routing Over Low power and Lossy
>> networks WG of the IETF.
>>
>>         Title           : Supporting Asymmetric Links in Low Power
>> Networks: AODV-RPL
>>         Authors         : Charles E. Perkins
>>                           S.V.R Anand
>>                           Satish Anamalamudi
>>                           Bing Liu
>>         Filename        : draft-ietf-roll-aodv-rpl-12.txt
>>         Pages           : 32
>>         Date            : 2022-01-30
>>
>> Abstract:
>>    Route discovery for symmetric and asymmetric Peer-to-Peer (P2P)
>>    traffic flows is a desirable feature in Low power and Lossy Networks
>>    (LLNs).  For that purpose, this document specifies a reactive P2P
>>    route discovery mechanism for both hop-by-hop routing and source
>>    routing: Ad Hoc On-demand Distance Vector Routing (AODV) based RPL
>>    protocol (AODV-RPL).  Paired Instances are used to construct
>>    directional paths, for cases where there are asymmetric links between
>>    source and target nodes.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-roll-aodv-rpl/
>>
>> There is also an htmlized version available at:
>> https://datatracker.ietf.org/doc/html/draft-ietf-roll-aodv-rpl-12
>>
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-roll-aodv-rpl-12
>>
>>
>> Internet-Drafts are also available by rsync at rsync.ietf.org:
>> :internet-drafts
>>
>>
>> _______________________________________________
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
>>
>

---

From: Charles Perkins <[email-masked]>
Date: Wed, 9 Mar 2022 07:52:10 -0800

Hello Pascal,

Did you mean that AODV-RPL is the replacement protocol for P2P-RPL? Or 
that it could be viewed as a replacement protocol for RPL?

I hope you will excuse my long delay in seeking this clarification. Your 
email below got overwhelmed in my inbox, but thank goodness not lost.

We just issued revision ...-13 for AODV-RPL and tried to respond to your 
suggestion.  Please take a look!

Naturally Yours,
Charlie P.

On 1/31/2022 8:02 AM, Pascal Thubert (pthubert) wrote:
>
> About “
>
> AODV-RPL can be operated whether or not native RPL is running otherwise.
>
> “
>
> I agree that the advertisements can be differentiated; still it’s 
> simpler to discourage using both protocols in the same network. Why do 
> so since this is essentially the replacement protocol?
>
> Keep safe;
>
> Pascal
>
> *From:* Roll <[email-masked]> *On Behalf Of *Ines Robles
> *Sent:* lundi 31 janvier 2022 7:52
> *To:* roll <[email-masked]>
> *Subject:* [Roll] WGLC draft-ietf-roll-aodv-rpl-12
>
> Dear all,
>
> Note that this draft updates the MOP to 4  
> [https://mailarchive.ietf.org/arch/msg/roll/yNEWYkKGcrDWYfKxCaCCX96lCUY/]
>
> Thank you,
>
> Ines and Dominique.
>
>     Internet-Drafts are also available by rsync at
>     rsync.ietf.org::internet-drafts
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 9 Mar 2022 15:58:13 +0000

Hello Charlie

The AODV flavor completes the RPL family. It replaces P2P (which was experimental) as the reference reactive variation of RPL.

The original RPL is proactive and distributed; it remains as the central option.

At the other extreme from reactive, we find route projection that is the SDN (centralized) variation.

Together those 3 provide a comprehensive tool set for LLNs…

Regards,

Pascal

Le 9 mars 2022 à 16:52, Charles Perkins <[email-masked]> a écrit :

 Hello Pascal,

Did you mean that AODV-RPL is the replacement protocol for P2P-RPL?  Or that it could be viewed as a replacement protocol for RPL?

I hope you will excuse my long delay in seeking this clarification.  Your email below got overwhelmed in my inbox, but thank goodness not lost.

We just issued revision ...-13 for AODV-RPL and tried to respond to your suggestion.  Please take a look!

Naturally Yours,
Charlie P.

On 1/31/2022 8:02 AM, Pascal Thubert (pthubert) wrote:
About “
AODV-RPL can be operated whether or not native RPL is running otherwise.
“
I agree that the advertisements can be differentiated; still it’s simpler to discourage using both protocols in the same network. Why do so since this is essentially the replacement protocol?

Keep safe;

Pascal

From: Roll <[email-masked]><mailto:[email-masked]> On Behalf Of Ines Robles
Sent: lundi 31 janvier 2022 7:52
To: roll <[email-masked]><mailto:[email-masked]>
Subject: [Roll] WGLC draft-ietf-roll-aodv-rpl-12

Dear all,

Please find below a new version of aodv-rpl draft. This email starts a WGLC of one week.

Note that this draft updates the MOP to 4  [https://mailarchive.ietf.org/arch/msg/roll/yNEWYkKGcrDWYfKxCaCCX96lCUY/]

Thank you,

Ines and Dominique.

On Sun, Jan 30, 2022 at 7:27 PM <[email-masked]<mailto:[email-masked]>> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Routing Over Low power and Lossy networks WG of the IETF.

        Title           : Supporting Asymmetric Links in Low Power Networks: AODV-RPL
        Authors         : Charles E. Perkins
                          S.V.R Anand
                          Satish Anamalamudi
                          Bing Liu
        Filename        : draft-ietf-roll-aodv-rpl-12.txt
        Pages           : 32
        Date            : 2022-01-30

Abstract:

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll