Subject: Re: ranger operator clashes

From: Gerald Andrew Winters <[email-masked]>
Date: Fri, 11 Sep 1998 13:29:23 -0400 (EDT)

Hello Cengiz,

Let me begin by saying I am in agreement with your solution
to this problem and think it is a good idea.  There are at 
least one or two additional solutions, such as taking the 
intersection of the ranges.  But in my view the different 
solutions seem to have equal weight so our task now is to 
come to a consensus.

Let me focus on a couple points for clarity sake.

In your view, is this part of the "general rule" for 
combining range operators?

prefix^n-m^- = prefix^(n-1)-32

And finally on the issue of encountering the same route set 
more than once during a recursive expansion, do you agree 
with the following text as part of our rules for route set 
expansion?

"The algorithm for combining route prefixes encountered
during recursive route set expansions is to take the union
of all prefixes encountered.  So route set maintainers need
to be aware that a given route set will be expanded a second
time if the range operators are distinct and that the rules
for intersecting range operators do not apply."

--jerry

---

From: Cengiz Alaettinoglu <[email-masked]>
Date: Fri, 11 Sep 1998 10:49:35 -0700 (PDT)

> prefix^n-m^- = prefix^(n-1)-32

I think you mean n+1? i.e.
 prefix^n-m^- = prefix^(n+1)-32

If so, we are in agreement.

> for intersecting range operators do not apply."

Yes, I agree. Though you may want to rephares the "rules
for intersecting range operators do not apply". It is kind of
confusing.