Subject: RE: [RPSEC] Topic 1: Section 3.1 Threat Sources

From: [email-masked]
Date: Tue, 18 Mar 2003 18:23:19 -0500 (EST)

>I agree Changing data passed on by another router should be the problem
>targeted
>by integrity check. But, when this router sends the modified/forged routing
>data
>out, it also impersonates other routers for those routing
>data belongs to.

I would disagree.  The router Bob says "hi, I'm Bob.  Here's a message I got from router George."
And the message was not one sent by George.  Bob is forgeing/falsifying/modifying a message
from George.  That's not impersonation.  The receiver is under no misimpression of which router
it is speaking to.  But the integrity or authenticity of the message has been attacked.

If the postman delivers a letter to you and the letter is forged, the postman is not
impersonating the sender.

--Sandy
_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: "Dijiang Huang" <[email-masked]>
Date: Tue, 18 Mar 2003 18:24:06 -0600

Sandy,

> impersonating the sender.

Sometimes it is hard for a router to tell the message is from a
originator or a forwarder. A router only can receive routing information
from its immediate neighbors, but the routing information may have been
already
passed via multiple hops (such as through flooding). In this sense, the
router
may not have clues where the routing information comes from, it may be
impersonated.

The router Bob maliciously says "hi, I'm Bob.  Here's a  message about
George.", When its
neighbor John forwards this message to Tom and says "hi, I'm John.  Here's a
message
about George."  Will Tom really believe it originated from George or not?
Especially, in link
state routing domain, when a subverted router partition the network, it can
not directly
but indirectly impersonate routers from one partition to another partition.

--Dijiang