Subject: [RPSEC] BGP route validation

From: David b <[email-masked]>
Date: Sat, 26 Nov 2005 02:39:00 +0530

hi all,

I would like to know if we can validate the paths generated by the BGP local
decision process by any means ?
how much overhead will that incur to converge the BGP routes?
_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: Doug Montgomery <[email-masked]>
Date: Sat, 26 Nov 2005 21:42:07 -0500

David b wrote:
> hi all,
> 
> I would like to know if we can validate the paths generated by the BGP
> local decision process by any means ?

What exactly do you mean by "validate the paths generated"?

Do you mean given an Adj-RIB-ins and some formal description of the local
decision process, validate that the Adj-RIB-outs are feasible?

Do you mean to do this at a single node, or for an entire network?

Always confused by the notion of validating paths...
dougm