Subject: [RPSEC] Follow-up on discussion on BGP session security draft

From: "Michael H. Behringer" <[email-masked]>
Date: Thu, 26 Jul 2007 18:28:31 -0500

Following up on the discussion we had in the WG meeting, on draft-behringer-bgp-session-sec-req-01.txt. [Thanks for the excellent minutes, Geoff!]

The key issue as I see it is the scope of the document and the potential overlap with draft-bellovin-tcpsec-01.txt. (The other issues are comparatively minor, and will be addressed after we clarified the scope of the doc.) Let me try to address those here. 

- Scope of the document. 

Strictly speaking the WG is focusing on *protocol* security requirements, ie, the BGP protocol specific security stuff. Right now my doc addresses a wider scope, namely all the security mechanisms that a BGP speaker should implement to secure a BGP peering. This includes mechanisms on several layers. So strictly speaking the doc is out of scope. However, if we are that strict, *nothing* is going to be in scope for BGP, not even the bellovin draft, since tcpsec is not part of the BGP protocol either. ;-)  

It was also pointed out that the document is a mix between operational requirements, and implementation requirements. That needs to be clarified as well. (At least what the intention is.)

My goal was to address real, practical requirements (leave out detailed discussion here, there is still a lot of work to be done). I agree the scope needs refining, along what I wrote above, and I'll give it a try. I am open for suggestions. 

But having discussed with various people, I think, assuming the fixes above, we are in agreement that this scope is correct, and fits into the WG charter. Is this correct? 

- Overlap with draft-bellovin-tcpsec-01.txt

I *had* actually read the -00 draft, but forgot to add the reference. I think that the two documents address a different problem space. The Bellovin draft is TCP specific, not focused on BGP. However, it is an excellent analysis of the security requirements for this space. It is clear that my document must reference the Bellovin draft, and must also explain how the two documents fit together. This will also be addressed. 
Can we have a vote: With those clarifications, does the document fit into the WG charter? 

[If there is consensus, I will address the other points raised in version -02]

Thanks for your feedback!
Michael

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: Geoff Huston <[email-masked]>
Date: Sat, 28 Jul 2007 00:06:39 +1000

I agree with the proposition that this work fits within the WG charter, 
provides requirement information above and beyond TCP transport, and I 
support the adoption of this draft as a WG document.

    Geoff

Michael H. Behringer wrote:
[...]
> But having discussed with various people, I think, assuming the fixes 
> above, we are in agreement that this scope is correct, and fits into the 
> WG charter. Is this correct?