Subject: [RRG] Knee jerking

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Mar 2008 10:18:24 +1300

On 2008-03-25 16:35, Dino Farinacci wrote:
...
>> Ok, I'm fine with that.  You're effectively shifting to a NAT approach
>> for
>> transition.  If you do that, do you even need PTRs anymore?
> 
> Well you know the knee-jerk reaction to NATs.

Here's the thing... IPv4 is already irremediably broken by
NAT (i.e. all upper layer designs must already allow for
IPv4 NAT, or even worse NAPT). So if the LISP transition
for IPv4 sites includes NAT, it really isn't a new problem
for the upper layers.

However, it would be sad if LISP required NAT for IPv6,
since the reality is that we're looking at this whole
class of solutions (and shim6) precisely to avoid the need
for NAT. In fact, although I don't fully agree with
draft-rosenberg-internet-waist-hourglass, it does point
us in the direction of needing a complete new identity
system at layer 4, if we end up breaking IPv6 with NAT too.

      Brian

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/rrg/> & ftp://psg.com/pub/lists/rrg

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 25 Mar 2008 14:31:47 -0700

> NAT (i.e. all upper layer designs must already allow for

I know what you mean, but saying IPv4 is broken is a bit strong. I'd  
argue you should thank NATs for allowing the Internet to scale to what  
it is today in terms of the number of hosts that can talk to each other.

> for IPv4 sites includes NAT, it really isn't a new problem

Right.

> since the reality is that we're looking at this whole

Well since we have more address space, and it's not out of the  
question of getting a /8 or /16 of EID-space, PTRs look attractive.

Do you think so?

> system at layer 4, if we end up breaking IPv6 with NAT too.

Don't you think a mass PI allocation scheme is going to break IPv6 if  
we don't do anything about it?

Dino

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Mar 2008 10:43:36 +1300

> it is today in terms of the number of hosts that can talk to each other.

Indeed. Although there is a dream world in which NAT didn't
happen and we got IPv6 deployed in 1998 because we had to...

> Well since we have more address space, and it's not out of the question
> of getting a /8 or /16 of EID-space, PTRs look attractive.
> 
> Do you think so?

Yes, I think we put 128 bits in IPv6 so that we could use
them :-)

> Don't you think a mass PI allocation scheme is going to break IPv6 if we
> don't do anything about it?

Absolutely. That's partly why we're here, isn't it?

    Brian