Subject: [RRG] Some concern about the flat label as identifier

From: Xu Xiaohu <[email-masked]>
Date: Mon, 17 Mar 2008 11:59:42 +0100

> > Second, as I said above, I am quite unsure that the old way of
> > thinking of general purpose end system IDs is actually useful.  We
> > can have network-layer identities, or transport-layer ones, but
> > what will we use them for?
> 
> They are very useful for host mobility and multi-access.
> Architecturally, their economic value derives from them allowing a
> host a better capability of choice between operators in a multi-
> access situation.

Hi Pekka,

I have a concern about the business model of the HIP which uses HIT (flat
label) as host identifier.

Since the public key is self-generated by hosts and the HIT is the hash
value of the public key which has no organization semantics, how can the
id/loc mapping management been shared among different countries and
different service providers? I don't believe it's acceptable from both
political and economic aspects that all the mapping management is dominated
by a single company, such as Skype.

Best wishes,
Xiaohu XU

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/rrg/> & ftp://psg.com/pub/lists/rrg

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 17 Mar 2008 12:17:53 +0100

On Mon, Mar 17, 2008 at 11:59:42AM +0100,
 Xu Xiaohu <[email-masked]> wrote 
 a message of 31 lines which said:

> I have a concern about the business model of the HIP which uses HIT
> (flat label) as host identifier.

It seems it is more correct to say that the identifier is the HI, not
the HIT.

> how can the id/loc mapping management been shared among different
> countries and different service providers?

There are several ways. One is to use the DNS (draft-ietf-hip-dns)
with all its limitations but also its strengths. 

Another one is the use of a DHT (draft-ahrenholz-hiprg-dht). The DHT
spreads the identifiers "at random". If you prefer more control on the
placement of keys, see draft-mathy-lisp-dht.

> I don't believe it's acceptable from both political and economic
> aspects that all the mapping management is dominated by a single
> company, such as Skype.

But certainly nobody suggested so.

---

From: Xu Xiaohu <[email-masked]>
Date: Mon, 17 Mar 2008 13:37:06 +0100

> It seems it is more correct to say that the identifier is the HI, not

However, in most cases the HIT plays the role of identifier. The HI is only
resorted when there is a conflict on the HIT.

> with all its limitations but also its strengths.

I don't think DNS is an optimal option since this approach requires every
host should have a FQDN name.

> placement of keys, see draft-mathy-lisp-dht.

If I understood the draft-mathy-lisp-dht correctly, the idea in this draft
is based on the hierarchical identifier, e.g. IP address, which can be
allocated and managed in a hierarchical way. So the idea in this draft is
not suitable for flat label used in HIP.

Best wishes,
Xiaohu XU

---

From: Randall Atkinson <[email-masked]>
Date: Mon, 17 Mar 2008 06:40:43 -0700

Earlier, Xu XiaoHu wrote:
% I don't think DNS is an optimal option since this approach
% requires every host should have a FQDN name.

In practice, hosts already should have a FQDN name,
so there would be no change from the existing deployed
Internet if one continued to rely on DNS.

As I think I commented earlier, nearly all current users are entirely
unable to distinguish "DNS fault" from "network down".  I learned
this in the late 1990s at a large multi-continent residential
broadband ISP.  I am told by ISP folks that it is even more true
today than it was back then.

One could imagine that some future Internet would remove
the reliance upon DNS entirely.  Perhaps that is what you
were contemplating ?  If so, please do explain in more
detail. :-)

Cheers,

Ran