Subject: [RRG] Publicly available LISP and shim6 implementations

From: Olivier Bonaventure <[email-masked]>
Date: Wed, 16 Jul 2008 21:34:44 +0200

Hello,

To allow researchers to experiment with some of the mechanisms that are 
being extensively discussed on the RRG mailing lists, we are happy to 
announce the public release of two implementations :

- OpenLISP is the first publicly available implementation of the Locator 
Identifier Separation Protocol (LISP) that has been extensively 
discussed within the RRG. OpenLISP runs on the FreeBSD kernel and has 
been written by Luigi Iannone.

- LinShim6 is the first implementation of the shim6 IPv6 host-based 
multihoming solution developped within the IETF shim6 working group. 
LinShim6 runs on the Linux kernel and has been written by Sebastien Barré.

You can find additional details (implementation reports, source code, 
papers, ...) about these two implementations from our webpage :

	http://inl.info.ucl.ac.be

Best regards,

Olivier Bonaventure

PS: Discussion about LISP/shim6 should be sent on the lisp/shim6 mailing 
lists and not on the RRG mailing list

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/rrg/> & ftp://psg.com/pub/lists/rrg

---

From: Olivier Bonaventure <[email-masked]>
Date: Wed, 16 Jul 2008 22:30:10 +0200

Hello,
> announce the public release of two implementations :

...

> lists and not on the RRG mailing list

Some rrgers replied that I forgot to give the addresses of these mailing 
lists. LISP can be discussed on [email-masked]
while shim6 can be discussed on [email-masked]

Olivier

-- 
http://inl.info.ucl.ac.be , UCLouvain, Belgium

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 16 Jul 2008 13:48:25 -0700

Oliver et al,

Integrating LISP with SEAL is a possible next step of interest.
If you would like to try putting your implementation together
with SEAL, let me know:

  http://osprey67.com/seal

(IMHO, in the future our LISP should be SEALed.)

Fred
[email-masked] 

>-----Original Message-----
>From: Olivier Bonaventure [mailto:[email-masked]] 
>Sent: Wednesday, July 16, 2008 12:35 PM
>To: rrg
>Cc: Luigi Iannone; Sébastien Barré
>Subject: [RRG] Publicly available LISP and shim6 implementations
>
>Hello,
>

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 16 Jul 2008 22:55:50 +0200

Hi Fred,

in the new openlisp report we cited seal (section 6.8.2)

I do not know yet the details of your implementation, but if it runs  
in the user space, thanks to OpenLISP's mapping sockets, to set MTU  
towards specific RLOCs is pretty easy.

Cheers

Luigi

>> lists and not on the RRG mailing list

Luigi Iannone

[email-masked]

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 16 Jul 2008 14:23:29 -0700

Luigi,
 
SEAL is right now implemented as a Linux kernel protocol module, and
used to support tunnel-mode and transport-mode applications. It sounds
like what you need is an application-mode instantiation of SEAL, where
the layering would be something like:
 
  Inner-IP/LISP-SEAL/UDP/Outer-IP
 
In that case, to do it at the application layer we would simply need to
pull the 'seal.c' code up into your application and implement some kind 
of packet filter that could capture IPv4 first-fragments ICMPv4 "Fragment
Needed" messages at the application layer. That shouldn't be too hard, I
don't think?
 
I'll desist now since this is vectoring off into discussion that should go
to the other lists. But, I just wanted to have this application-layer
implementation option for SEAL out on the table since it isn't well
documented in the current spec.
 
Fred

________________________________

	From: Luigi Iannone [mailto:[email-masked]] 
	Sent: Wednesday, July 16, 2008 1:56 PM
	To: Templin, Fred L
	Cc: [email-masked]; rrg; Sébastien Barré
	Subject: Re: [RRG] Publicly available LISP and shim6 implementations

	Hi Fred, 

	I do not know yet the details of your implementation, but if it runs in the user space, thanks to OpenLISP's mapping sockets, to set MTU towards specific RLOCs is pretty easy.

	Cheers

	Luigi

		Oliver et al,

		  http://osprey67.com/seal

		Fred

			-----Original Message-----
			From: Olivier Bonaventure [mailto:[email-masked]] 
			Sent: Wednesday, July 16, 2008 12:35 PM
			To: rrg
			Cc: Luigi Iannone; Sébastien Barré
			Subject: [RRG] Publicly available LISP and shim6 implementations

			Hello,

			To allow researchers to experiment with some of the mechanisms 
			that are 
			being extensively discussed on the RRG mailing lists, we are happy to 
			announce the public release of two implementations :

			- OpenLISP is the first publicly available implementation of 
			the Locator 
			Identifier Separation Protocol (LISP) that has been extensively 
			discussed within the RRG. OpenLISP runs on the FreeBSD kernel and has 
			been written by Luigi Iannone.

			- LinShim6 is the first implementation of the shim6 IPv6 host-based 
			multihoming solution developped within the IETF shim6 working group. 
			LinShim6 runs on the Linux kernel and has been written by 
			Sebastien Barré.

			Best regards,

			Olivier Bonaventure

			PS: Discussion about LISP/shim6 should be sent on the 
			lisp/shim6 mailing 
			lists and not on the RRG mailing list

	
	Luigi Iannone

---

From: David Meyer <[email-masked]>
Date: Wed, 16 Jul 2008 20:14:24 -0700

Between you guys and me, if I were you I'd exercise some
	judgement. 

	Just one person's opinion.

	Dave