Subject: Re: [rrg] [Fwd: I-D Action:draft-carpenter-renum-needs-work-00.txt]

From: [email-masked]
Date: Fri, 24 Oct 2008 06:53:49 EDT

Renumbering is impractical.This I can imagine and most of the  
RRG-mailinglist members do know it best (i.e much better than me).
Furthermore: It doesn't help wrt the IPv4 address depletion  issue. 
Whereas ID plus LOCATION would. Admitted, this can be attributed to LISP,  
too. But LISP doesn't exploit its own potential when it introduces a new name  
space but re-uses hereby the old one again (which is chaotic from the routing  
point of view).
 
Heiner 
 
In einer eMail vom 23.10.2008 22:43:52 Westeuropäische Normalzeit schreibt  
[email-masked]:

Hi
Ran and I drafted this in reaction to the earlier discussion  here
about the impracticality of renumbering. We'd like comments and,  above
all, contributions. For now, this list is suggested for any  discussion,
but I will also mention the draft on the intarea  list.

Brian

-------- Original Message  --------
Subject: I-D  Action:draft-carpenter-renum-needs-work-00.txt
Date: Thu, 23 Oct 2008  13:30:02 -0700 (PDT)
From: [email-masked]
Reply-To:  [email-masked]
To: [email-masked]

A New  Internet-Draft is available from the on-line Internet-Drafts  
directories.

Title         : Renumbering still needs work
Author(s)   : B. Carpenter, R. Atkinson
Filename        :  draft-carpenter-renum-needs-work-00.txt
Pages     : 18
Date       : 2008-10-23

This document reviews the existing  mechanisms for site renumbering
for both IPv4 and IPv6, and identifies  operational issues with those
mechanisms.  It also summarises current  technical proposals for
additional mechanisms.  Finally there is a gap  analysis.

A URL for this Internet-Draft  is:
http://www.ietf.org/internet-drafts/draft-carpenter-renum-needs-work-00.txt

_______________________________________________
rrg  mailing  list
[email-masked]
https://www.irtf.org/mailman/listinfo/rrg

_______________________________________________
rrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/rrg

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 25 Oct 2008 09:58:53 +1300

Heiner,

That is a known viewpoint. But the point of my message was to
ask for specific comments on and contributions to the draft.

    Brian

---

From: "Teco Boot" <[email-masked]>
Date: Sat, 25 Oct 2008 10:15:51 +0200

Hi Brian, RRG WG,

I am working on an automatic renumbering solution for MANETs (Autoconf WG, http://tools.ietf.org/id/draft-boot-autoconf-brdp-00.txt). Moreover, I try to fix ingress filtering problems. In my opinion there is a need to update routing mechanisms for this.

I discussed with Ran applicability of the BRDP Based Routing ideas for access networks. Ran "forced" me to kick out routing headers or encapsulation / tunnels. My current proposal meets Ran's requirement, but I had to use PBR. Please don't panic before checking the proposal!

I prepared a presentation for next RRG meeting. Preview of draft version: 
http://www.inf-net.nl/BRDP%20based%20routing%20-%20RRG.pdf
See "marketing data sheet" below for what it brings for us. Any comment is welcome. And let me know if RRG is interested. I asked already approval for a slot in next meeting.

I started writing Internet Draft text, this is to be published before Minneapolis. I could use some help here.

Kind regards, Teco

===
BRDP Based Routing -marketing- data sheet

 - Built on well known protocols such as IPv6 Neighbor Discovery and Policy Based Routing

 - Full support for multi-homing with multiple Provider Independent (PI) and Provider Aggregatable (PA) addresses

 - Helps scaling the Internet by removing needs for PI addresses

 - Border Router load balancing

 - Automatic ingress filter on first hop routers

 - No tunnels, routing headers or any other encapsulation

 - Extendable for ad hoc networking
===

---

From: "Flinck, Hannu (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 27 Oct 2008 14:46:34 +0200

Hello Teco

Quite interesting work. I also agree that there is a lot from MANET
community that can be reused in the rrg design work. However, the pdf
presentation leads me to wonder the interactions of the extended RAs
with IGPs. They should not be transparent to each other, shouldn't they?
The use of ND RA in the MANET network might be optimal, but not
necessarily so in the intra domain without taking into consideration
interactions with IGP.

Best regards
Hannu 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of ext Teco Boot
>Sent: Saturday, October 25, 2008 11:16
>To: 'Brian E Carpenter'
>Cc: [email-masked]; 'Randall Atkinson'; 'R Atkinson'
>Subject: Re: [rrg] [Fwd: I-D 
>Action:draft-carpenter-renum-needs-work-00.txt]
>
>Hi Brian, RRG WG,
>
>I am working on an automatic renumbering solution for MANETs 
>(Autoconf WG, 
>http://tools.ietf.org/id/draft-boot-autoconf-brdp-00.txt). 
>Moreover, I try to fix ingress filtering problems. In my 
>opinion there is a need to update routing mechanisms for this.
>
>I discussed with Ran applicability of the BRDP Based Routing 
>ideas for access networks. Ran "forced" me to kick out routing 
>headers or encapsulation / tunnels. My current proposal meets 
>Ran's requirement, but I had to use PBR. Please don't panic 
>before checking the proposal!
>
>See "marketing data sheet" below for what it brings for us. 
>Any comment is welcome. And let me know if RRG is interested. 
>I asked already approval for a slot in next meeting.
>
>I started writing Internet Draft text, this is to be published 
>before Minneapolis. I could use some help here.
>
>Kind regards, Teco
>
>===
> - Full support for multi-homing with multiple Provider 
>Independent (PI) and Provider Aggregatable (PA) addresses
>

---

From: "Teco Boot" <[email-masked]>
Date: Mon, 27 Oct 2008 20:40:54 +0100

Hi Hannu,

> However, the pdf

There are some options here. My current thought is use IGP to the maximum
extent (so I can blame the IGP:-). All packet forwarding is using FIB
lookup. 1st on DA, if no_match on BR address. I'm not sure yet on what a BR
should inject in the IGP, the full prefix it owns or just its configured
prefix on an interface. I'll write the options down in the I-D on BRDP Based
Routing (give me to the end this week).
The BRDP metric (UPM) is related to metrics of IGP, but not one to one. UPM
is for both directions and would be "uniform" for different IGPs.

> necessarily so in the intra domain without taking into consideration

I think it is always a compromise. Using ND is neutral on IGPs. And IPv6
routers have ND functions. 
Hosts may use BRIOs, ND is preferred over IGP for this reason.

Teco.

---

From: "Flinck, Hannu (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 28 Oct 2008 17:52:00 +0200

Well, why can't you carry the prefix info and metrics in IGP and use
RAs/ND only at the first hop router (the router that has a host route to
the client)?  

- Hannu

>From: ext Teco Boot [mailto:[email-masked]] 
>Sent: Monday, October 27, 2008 21:41
>To: Flinck, Hannu (NSN - FI/Espoo)
>Cc: [email-masked]
>Subject: RE: [rrg] [Fwd: I-D 
>There are some options here. My current thought is use IGP to 
>the maximum extent (so I can blame the IGP:-). All packet 
>forwarding is using FIB lookup. 1st on DA, if no_match on BR 
>address. I'm not sure yet on what a BR should inject in the 
>IGP, the full prefix it owns or just its configured prefix on 
>an interface. I'll write the options down in the I-D on BRDP 
>Based Routing (give me to the end this week).
>The BRDP metric (UPM) is related to metrics of IGP, but not 
>one to one. UPM is for both directions and would be "uniform" 
>for different IGPs.
>
>I think it is always a compromise. Using ND is neutral on 
>IGPs. And IPv6 routers have ND functions.

---

From: "Teco Boot" <[email-masked]>
Date: Tue, 28 Oct 2008 19:47:31 +0100

-- more on BRDP Based Routing:

> RAs/ND only at the first hop router (the router that has a host route
> to the client)?

[Teco:] 
This could be a feasible solution in some cases. However, BRDP is targeted
for Autoconf and this WG is chartered for defining an address
autoconfiguration solution, independent on (MANET) routing protocols. Using
PacketBB is an option, but how to support current MANET protocols? And what
about OSPF-MANET? 
Let's say it is the background of BRDP.