Subject: Cache size [Re: [RRG] Happiness; lack thereof]

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Mar 2008 16:36:44 +1300

On 2008-03-07 23:32, Luigi Iannone wrote:
...
>>
>> Finally, I cannot find why EID-to-RLOC cache is significantly smaller
>> (preferably, in terms of big-O) than the EID-to-RLOC database. Is
>> there any study of that issue?
>>
> You can get a look to:
> 
> http://inl.info.ucl.ac.be/publications/cost-caching-locatorid-mappings
> 
> There you can find the size of a cache.

That's a nice paper, but of course the size of cache is arbitrary - you
chose to limit it by setting the timeout, but if the cache is limited
by memory size, it could be much smaller (or much bigger). As with
any cache, the question is what is the working set needed to meet
a given performance goal.

> The size of the database, assuming granularity of prefixes annonced by
> BGP, is just the size of a BGP table.

Not if you want map granularity to be arbitarily fine. We've talked
about map sizes of at least 10^8. Your values for the working set
for a given site may be valid, however - that probably needs data
collection from a large sample of sites.

    Brian

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/rrg/> & ftp://psg.com/pub/lists/rrg

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 12 Mar 2008 14:21:42 +0100

Hi Brian,

> a given performance goal.

You are right. And actually our measurements hold in the context of a  
stub network having more or less the same size and traffic pattern as  
ours.
You cache the size of the nework and its traffic pattern and you can  
have different results.

> about map sizes of at least 10^8.
As i said, we assume a granularity equivalent to BGP prefixes.

> Your values for the working set
See my first point.

Luigi

>     Brian

Luigi Iannone

[email-masked]