Subject: [RRG] Routing RG charter

From: RJ Atkinson <[email-masked]>
Date: Mon, 21 Apr 2008 14:36:26 -0400

Some folks might want to go re-read the IRTF Routing RG
Charter (http://www.irtf.org/charter?gtype=rg&group=rrg),
in the interest of re-focusing the list conversations.

(I just did that myself, so I'm following my own suggestion. :-)

Among other things it says:
	- "...not yet mature enough for engineering work within the IETF."

	- "in scalability, mobility, multi-homing, and inter-domain
            traffic engineering"
	- "will produce a list of prioritised design goals"

One plain-language reading of these might mean:
	- protocol engineering being undertaken in an IETF WG
           is not within scope for the IRTF Routing RG.
	
	- Scalability must be addressed.
	- Mobility must be addressed.
	- Multi-homing must be addressed.
	- Inter-domain TE must be addressed.

Things unclear in the charter at present:
	- Is the scope (IPv4 only, IPv6 only, or IPv4 + IPv6) ?

Obvious things for the group to discuss probably include
the "prioritised design goals", though it seems clear that
these design goals will at least include:
	- scalability
	- mobility
	- multi-homing
	- inter-domain TE

 From that, it seems that only solving the site multi-homing problem
is not sufficient for the RG to meet the Routing RG charter,
that instead the broader set of issues needs to be addressed
by the outputs from the RG.

Yours,

Ran
[email-masked]

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/rrg/> & ftp://psg.com/pub/lists/rrg

---

From: Dan Jen <[email-masked]>
Date: Mon, 21 Apr 2008 12:45:55 -0700

> these design goals will at least include:

The design goals draft prioritizes the various topics you mentioned. 

http://tools.ietf.org/html/draft-irtf-rrg-design-goals-01

In this draft, routing scalability, no degradation in security, and
incremental deployability are REQUIRED features of any proposed
architecture.  

Scalable multihoming, TE support, and simplified renumbering for edge
sites are considered strongly desired.

Mobility support is the least desired of all things listed.

Not sure how much relevance this has, (the draft is also expired), but
just fyi.

Dan Jen