Subject: [Rserpool] Some question

From: Pablo Elias Alonso Martin <[email-masked]>
Date: Tue, 17 Jul 2001 12:11:23 +0200

Hi all! 

	I have some question.

	1) All messages in ASAP and ENRP protocol have a 64 bits number
called "ENRP endpoint message identifier" this number is:

	- For ASAP messages:
	ENRP endpoint message identifier #1 = 0x18038688
	ENRP endpoint message identifier #2 = 0x77734683

	-For ENRP messages:
	ENRP server message identifier #1 = 0x27047729
	ENRP server message identifier #2 = 0x53829149   

	What is the use for this number? This number is fixed?

	2) In RSerPool Architecture, the ENRP server concept it
ambiguous.
This is the figure we have on the Architecture draft:

               *********        ***********
               * PE/PU *        *ENRP Srvr*
               *********        ***********

               +-------+        +----+----+
  To other <-->| ASAP  |<------>|ASAP|ENRP| <---To Peer ENRP
  PE/PU        +-------+        +----+----+       Name Servers
               | SCTP  |        |  SCTP   |
               +-------+        +---------+
               |  IP   |        |   IP    |
               +-------+        +---------+
                    Figure 1: Typical protocol stack

	And the question are:

		In the ENRP Server, ASAP/ENRP layer, 
			+----+----+
			|ASAP|ENRP|
			+----+----+ 

	Are both protocol implemented independently and completely? Are
the communication between its going to be defined?
	Or the block is only one entity who understand both protocol?

	If the ENRP who act as at server or do we have a server over the
ENRP to answer the request?

	Graphically:
	a) Independent ENRP-Server
    	       +-------+        +---------+
	       | PE/PU |        |ENRP-Srvr|
               +-------+        +----+----+
  To other <-->| ASAP  |<------>|ASAP|ENRP| <---To Peer ENRP
  PE/PU        +-------+        +----+----+       Name Servers
               | SCTP  |        |  SCTP   |
               +-------+        +---------+
               |  IP   |        |   IP    |
               +-------+        +---------+

	b) ENRP over ASAP
    	       +-------+        +---------+
	       | PE/PU |        |  ENRP   |
               +-------+        +----+    +
  To other <-->| ASAP  |<------>|ASAP|    | <---To Peer ENRP
  PE/PU        +-------+        +----+----+       Name Servers
               | SCTP  |        |  SCTP   |
               +-------+        +---------+
               |  IP   |        |   IP    |
               +-------+        +---------+

	c)ASAP-ENRP application block
    	       +-------+        
	       | PE/PU |        
               +-------+        +----+----+
  To other <-->| ASAP  |<------>|ASAP-ENRP| <---To Peer ENRP
  PE/PU        +-------+        +----+----+       Name Servers
               | SCTP  |        |  SCTP   |
               +-------+        +---------+
               |  IP   |        |   IP    |
               +-------+        +---------+

	Regards,

		Pablo

-- 
Pablo Elías Alonso Martín		[email-masked]
Ericsson Spain R&D center		Phone: +34 91 339 4526
C/ Ombu 3. 5ª planta.			Fax: +34 91 339 2906
28.045 Madrid. Spain.

_______________________________________________
rserpool mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/rserpool

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 17 Jul 2001 11:27:56 -0500

Pablo,

Pls see my answers in-line....

-Qiaobing

>         What is the use for this number? This number is fixed?

They are merely protocol identifiers. The original ENRP/ASAP ran over
UDP with shared ports, therefore we used these identifiers to help the
message receiver. I think in the next revision we should remove these
protocol identifiers and eventually we should ask IANA to assign proto
IDs and/or well-known ports for ENRP and ASAP.

> This is the figure we have on the Architecture draft:

You've answered your questions below :-)

>         a) Independent ENRP-Server

Yes, this is what Figure 1 means. I guess the blank line between the
application part and the protocol stacks in Figure 1 is a little
confusing. Your above diagram is better.

>         b) ENRP over ASAP

No, b) and c) are not correct.