Subject: [Rserpool] Access to IP multicast.

From: "Jose Luis Jimenez Ramirez ECE/TL/NB ID-000 Tlf.4061" <[email-masked]>
Date: Mon, 23 Jul 2001 10:03:00 +0200 (MEST)

Hi Randall,

In a previous mail you said:

"The UDP figure that Jose 
schetched is wrong in the sense that you are using a UDP socket NOT
for UDP but for access to multi-cast... it just happens to be an API
restriction that you get access to the multicast via a UDP socket... "

I agree with you in the fact that, 
why access to the multicast IP service throught UDP when you 
can access directly to IP?. But a directly access to IP should 
be done by RawSockect, this means that you need to be ROOT user
to run your application. Doesn't it mean a bigger restriction?

                   - -
Saludos            º º
Jose.     --oOOo---()--oOOo--		  
		    _		 

_______________________________________________
rserpool mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/rserpool

---

From: Randall Stewart <[email-masked]>
Date: Mon, 23 Jul 2001 09:31:27 -0500

Jose:

I think the key here is we are talking conceptually not 
specific to a particular implementation. There will be
some implementations that have no penalty to access multicast
directly over IP. There will be other implementations that
must use a UDP socket in order to avoid "ROOT" restrictions.

We want to show the concepts IMHO and let the individual implementation
put it into place within its particular scope i.e. over UDP or directly
over IP.. based on their needs..

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)