Subject: Re: [Rserpool] ENRP server channel

From: "Jose Luis Jimenez Ramirez ECE/TL/NB ID-000 Tlf.4061" <[email-masked]>
Date: Wed, 18 Jul 2001 10:10:28 +0200 (MEST)

Hello Qiaobing,

Following with the Miguel Angel's question
It is said in the draft:

" At startup, before getting into service, the ENRP server
  (initiating server) shall MULTICAST a PEER_PRESENCE message with
  'Reply_required' flag set over the ENRP server channel. This is to
  inform any other existing peers in the operation scope about the
  initiating peer's presence."

--------------------------------------
1st Question is:
How should be done this multicasting??
It's obvious that SCTP can't be used to multicast the PEER_PRESENCE msg, due
the ENRP Server don't know how many other peers exist, and can't establish an
SCTP assoc with each one. so, the solution could be:

a) the ENRP Server is acting directly over IP by a RawSockect to send the msg.
b) the ENRP Server is acting directly over UDP/IP by a Sockect to send the msg.

--------------------------------------
2nd Question is:
"If there are responses to its PEER_PRESENCE message, the
    initiating server shall then take the actions described in 4.1.8"
    
    i.e. Server Download Peer List from a Peer Server

Well, Should this information exchange be done by establishment of an
SCTP association with the peer? if this is OK, ENRP should be working
like:
                           
 +---------------+
 |   ENRP-Srvr   |
 +----+----------+
 |ASAP|  ENRP    | <---To Peer ENRP
 +----+----------+       Name Servers
 |  SCTP   | UDP |
 +---------------+
 |   IP          |
 +---------------+ ?????

                   - -
Saludos            º º
Jose.     --oOOo---()--oOOo--

> Hi, Miguel Angel,
> 
> Multicast is an IP service and should be always available no matter what
> transport protocol you are using. Of cause there may be some Socket API
> restrictions that may force you to use a separate socket to do
> multicast.
> 
> -Qiaobing
> 
> "Miguel Angel Nieto Jimenez ECE/TL/NA TU-146 Tlf.91.339.4670" wrote:
> > 
> > Hi,
> >         I have a question about the 'ENRP server channel' definition:
> > 
> >       ENRP server channel:
> >           Defined by a well known multicast IP address and a well
> >           known port number. All ENRP servers in an operation scope
> >           can send multicast messages to other servers through this
> >           channel. PEs are also allowed to multicast on this channel
> >           occasionally.
> > 
> > If the ENRP server is over SCTP and this does not allow multicast,
> > then, how is the 'ENRP server channel' set up?
> > 
> > Regards
> >         Miguel Angel
> > 
> > _______________________________________________
> > rserpool mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/rserpool
> 
> _______________________________________________
> rserpool mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/rserpool

_______________________________________________
rserpool mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/rserpool

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 18 Jul 2001 18:19:31 -0500

Jose,

Pls see my comments below...

-Qiaobing

>   initiating peer's presence."

In ENRP, PEER_PRESENCE can be sent in different ways: point-to-point,
multicast, or "groupcast" (i.e., sending a separate copy to each member
of a known group). And you are right, at the startup time of a server,
"groupcast" will be unavailable. Therefore the spec recommends
multicast.

> b) the ENRP Server is acting directly over UDP/IP by a Sockect to send the msg.

I think the question is essentially "how to access IP multicast through
a socket interface?"

In my opinion this is really an API/implementation issue. E.g., your
ENRP server app can simply open an additional UDP socket and use it to
send and receive multicast messages. Or, you can construct an SCTP
socket interface so that it gives you the access to IP multicast
services, and then build your ENRP server app over it.

> SCTP association with the peer? 

Yes, you normally will setup an SCTP association with the peer. Or using
the UDP-tyle socket, you simply sends the request to the selected peer
server without going through an explicit association setup. Either way
would work.

> if this is OK, ENRP should be working
> like:
> 
>  +---------------+
>  |   ENRP-Srvr   |
>  +----+----------+

If the WG at the end agrees that multicast is indeed needed, the stack
should look more like: 

  +---------------+
  |   ENRP-Srvr   |
  +----+----------+
  |ASAP|  ENRP    | <---To Peer ENRP
  +----+----+     +       Name Servers
  |  SCTP   |     |
  +---------------+
  |   IP    |mcast|
  +---------------+

---

From: Randall Stewart <[email-masked]>
Date: Fri, 20 Jul 2001 11:19:26 -0500

> "groupcast" will be unavailable. Therefore the spec recommends

I agree, but I think we will need to add a method to have a
"pre-configured" group so one does not need to use multi-cast in
the upcoming revision...

> services, and then build your ENRP server app over it.
Agreed... the most common way will be to use a additional UDP socket
but we should not specify this...

> server without going through an explicit association setup. Either way

yep :)

> If the WG at the end agrees that multicast is indeed needed, the stack

You took the words out of my fingers :) ... The UDP figure that Jose 
schetched is wrong in the sense that you are using a UDP socket NOT
for UDP but for access to multi-cast... it just happens to be an API
restriction that you get access to the multicast via a UDP socket... 

I might add one change to your picture though..

   +---------------+
   |   ENRP-Srvr   |
   +----+----------+
   |ASAP|  ENRP    | <---To Peer ENRP
   +----+----+-----+       Name Servers
   |  SCTP   |mcast|
   +---------------+
   |      IP       |     
   +---------------+

Since I think that Mcast is a service of IP not at the same level
as IP...I may be wrong in this but it seem more correct to show
it as above...

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)