Subject: [Rserpool] Clarification regarding RSerPool support for non-SCTP transports

From: Phillip Conrad <[email-masked]>
Date: Tue, 26 Nov 2002 00:10:17 -0500

I would like to ask the working group for clarification of some points regarding support for transports other than SCTP.

As I understood it, a key motivator was to allow for the possibility of PUs that supported TCP but not SCTP.     The example of such a requirement was some device for which an SCTP implementation is not yet available; perhaps some particular model of cell phone, PDA, or whatnot.

As a result, I think we reached something like "rough consensus" on the following direction:

* to provide a way to send ASAP messages 
  between a PU and a PE over either SCTP or TCP

* to provide a way to send ASAP message between 
  an PU and a Name Server over either SCTP or TCP

* to require that ENRP messages among PEs must use SCTP only.

Three questions: 

(1) Is that the correct sense of the working group?  Is there any significant dissent from that point of view?   If so, please say so.

(2) There might be one additional goal: 

* to specify how RSerPool is used when the application prefers to use RSerPool only for server selection (i.e. to resolve a pool handle to a transport address) and to handle the sending/receiving of data outside the RSerPool framework.    The application also has the responsibility to detect and report server failures in this case.

Is there working group consensus about this goal... yes or no?  If any doubts whether this should be a goal, please speak up.

I know there is still not full working group consensus that the "mapping" approach taken in the current drafts is the right way to go (in fact, I am aware of some particular doubts).  But before we debate the "how", I want to be sure we at least have rough consensus on what the goal(s) is/are.

Thanks,
Phill Conrad

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Phillip Conrad <[email-masked]>
Date: Tue, 26 Nov 2002 01:17:09 -0500

Once slight correction to my earlier note:

>* to require that ENRP messages among PEs must use SCTP only.

oops.. that should have been:

* to require that ENRP messages among NSs use SCTP only
* to require that ASAP messages between a PE and a NS use SCTP only.

But the same questions remain.

Thanks,
Phill Conrad

---

From: Phillip Conrad <[email-masked]>
Date: Tue, 26 Nov 2002 01:17:09 -0500

Thanks,
Phill Conrad